Impress doesn't show bullets in .odp format 1.0-1.2 files

Bug #286405 reported by Mantas Kriaučiūnas on 2008-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenOffice
Fix Released
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Baltix)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Fixed in upcoming OOo 2.4.3

==

Binary package hint: openoffice.org

OpenOffice.org 2.x Impress doesn't show bullets in OpenDocument 1.0-1.2 format (.odp) files. In all OOo versions prior to OOo 3.0 beta2 bullets in Impress where exported in a non valid OpenDocument Format. This was fixed in OOo 3.0 beta2 which only exports valid OpenDocument Format. Those files will not show bullets in any OOo version older than 3.0 beta, including OOo 2.x and OOo 1.x as they expect a non valid format.

This bug is reported in OOo Issue Tracker: http://openoffice.org/issues/show_bug.cgi?id=91466

"According to OOo developers the problem here is that one can not have both, bullets in old version *and* valid ODF documents. The only fix would be to fix the old 2.x version"

I'm suggesting to fix this bug in OOo 2.4.1, which is in Ubuntu 8.04 LTS (for example by writing an extension for OOo 2.4.1 to support both - non-valid ODP files from OOo 2.x and valid files from OOo 3.x).

Chris Cheney (ccheney) on 2008-10-20
Changed in openoffice.org:
importance: Undecided → Medium
status: New → Triaged
Changed in openoffice:
status: Unknown → Fix Released
Chris Cheney (ccheney) on 2009-01-17
description: updated
Chris Cheney (ccheney) on 2009-03-22
summary: - [upstream] OOo 2.x Impress doesn't show bullets in OpenDocument 1.0-1.2
- format (.odp) files (fixed in OOo 3.0)
+ [upstream] [2.4.3] OOo 2.x Impress doesn't show bullets in OpenDocument
+ 1.0-1.2 format (.odp) files (fixed in OOo 3.0)

Mantas Kriaučiūnas, this issue is unreproducible in Ubuntu 1104, LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/286405/+attachment/2137286/+files/1.odp && loimpress -nologo 1.odp

notice bullets. Does this work for you?

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in openoffice.org (Ubuntu):
importance: Medium → Low
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - [upstream] [2.4.3] OOo 2.x Impress doesn't show bullets in OpenDocument
- 1.0-1.2 format (.odp) files (fixed in OOo 3.0)
+ Impress doesn't show bullets in .odp format 1.0-1.2 files

closing as invalid (expired) because of missing reply

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.