please merge memtest86+ 2.01 from debian unstable - supports additional hardware + important bugfixes

Bug #192517 reported by Valentin Rocher on 2008-02-16
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
memtest86+ (Baltix)
Undecided
Unassigned
memtest86+ (Debian)
Fix Released
Unknown
memtest86+ (Ubuntu)
Wishlist
Reinhard Tartler

Bug Description

Binary package hint: memtest86+

memtest86+ 2.0 and 2.01 (released on February 2008) are out and brings support for many additional hardware and other improvements + bugfixes !
Ubuntu has memtest86+ 1.70 (released on January 2007) since 7.10 (Gutsy), so, it would be wise to have more up to date version in Long Time Supported 8.04 (Hardy) version.

Source packages already packaged by debian : http://packages.debian.org/sid/memtest86+

Changelog from the http://memtest86.org site :

 *** Enhancements in v2.01 : ***

    * New Features
          o Added support for 45 nm Mobile Core 2 w/ 3 Mo L2
          o Added support for i945GM/PM/GME & i946PL/GZ
          o Added support for iGM965/iGL960/iPM965/iGME965/iGLE960
          o Added detection for SiS 649/656/671/672
          o Added detection for i430MX/i430TX
          o Added an optional beep mode (pass completed w/o error)
          o Pass duration 20% reduced
          o Removed the blinking cursor
          o Reverted Test #0 to cached
    * Bug Fixes
          o Solved a major bug in Memory Address Errors Reporting
          o Patched for Intel-Powered Mac
          o Corrected Intel 3-Series (P35/X38) chipset init
          o Corrected a bug with SPD Display and ESB6300
          o Correct a detection bug on P965/G965 C-Stepping
          o Solved a incoherency with pass progress indicator
          o Patched Makefile to compile on x86_64
          o Bootable Memtest86+ ISO more compatible

 *** Enhancements in v2.00 : ***

    * New Features
          o Major Architectures changes
          o Modulo test now use random pattern for better accuracy
          o Added Advanced DMI Errors Reporting Mode
          o Added support for bus ratio changes on Intel Core CPU
          o Added support for non-integer bus ratio on latest Intel CPU
          o Added SPD Data Display for all Intel Chipsets (more to come)
          o Added serial support as a linux boot parameter (Thanks to Michal S.)
          o Added preliminary support for VIA CN Isaiah CPU
          o Added preliminary support for Intel Nehalem
          o Added support for VIA C7/C7-D/C7-M/Eden on Esther Core
          o Added support for AMD K10 (Phenom) CPU w/ timings detection
          o Added support for Intel Pentium E w/ 1 MB L2 Cache
          o Added support for Intel Core 2 45nm (Penryn)
          o Added support for FSB1333/FSB1600 Intel CPU
          o Added support for Intel 5400A/5400B w/ timings detection
          o Added support for Intel Q35/P35/G33/Q33 w/ timings detection
          o Added support for Intel X38/X48 w/ timings detection
          o Added preliminary support for Intel 5000P/V/Z
          o Removed on-fly memory timings change (unstable)
    * Bug Fixes
          o Numerous (really) bug fixes

Related branches

description: updated

Btw, updating memtest86+ package to 2.01 fixes bug #50239 - serial support as a linux boot parameter was added in 2.0 :)

Changed in memtest86+:
status: Unknown → New

I also would like to see new version of memtest86 in new Ubuntu 8.04 LTS.

I will attempt to make .diffs

`diff -ur memtest86+-1.70/ memtest86+-2.01/ > memtest86+.diff`

'diff -u memtest86+-{1.70,2.01}/changelog > changelog.diff'

'diff -ruN memtest86+-{1.70,2.01}/ | diffstat > diffstat.txt'

Changed in memtest86+:
status: New → Fix Released
Changed in memtest86+:
importance: Undecided → Wishlist
status: New → Confirmed
description: updated
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :

I subscribed main sponsors for ubuntu to review the proposed package for intrepid. This package has been tested and it builds and works successfully on AMD64 architecture. The remaining ubuntu changes were the same as the ones for the 1.70 version.

Daniel Holbach (dholbach) wrote :

Reinhard: can you please take a look at it?

Reinhard Tartler (siretart) wrote :

I'm sorry that I noticed your merge too late :( - my fault.

- but the fixed package in now in intrepid, at last.

Changed in memtest86+:
status: Confirmed → Fix Released
Saivann Carignan (oxmosys) wrote :

Reinhard Tartler : I don't see memtest86+ 2.01 in the versions history for intrepid, did you upload it?

Reinhard Tartler (siretart) wrote :

actually, the upload failed, I forgot to add the orig.tar.gz to the upload. Reopening therefore.

Changed in memtest86+:
assignee: nobody → siretart
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package memtest86+ - 2.01-1ubuntu1

---------------
memtest86+ (2.01-1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control: Add lpia as supported architecture.
    - Makefile: Add -fno-stack-protector to CFLAGS, since this package does
      not link against libc.
    - Merge basically the same as the one from Saïvann Carignan, thanks for
      your work! LP: #192517
  * Simplify the patch from LP #129614, the preinst is fine in debian, the
    postinst needs to check for presence of /boot/grub.
  * Do not call update-grub, but update-grub2. See
    http://bugs.debian.org/460080 for details.
  * install ELF image of memtest86+ in the binary package Thanks to Forest
    Bond for the patch. (LP: #175720).

memtest86+ (2.01-1) unstable; urgency=low

  * New upstream release (Closes: #468780).
    * Serial console now supported as boot parameter (Closes: 308355).
  * Added in README.Debian a pointer to the GRUB Legacy sample config
    (Closes: #445517), mentionned that GRUB2 is automatically handled, and
    that the make-memtest86+-boot-floppy script uses GRUB Legacy.
  * Call update-grub2 instead of update-grub (Closes: #460080).

 -- Reinhard Tartler <email address hidden> Tue, 20 May 2008 17:04:27 +0200

Changed in memtest86+:
status: Triaged → Fix Released
Saivann Carignan (oxmosys) wrote :

Many thanks to Reinhard Tartler!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.