have the installer in other languages

Bug #116176 reported by Arthur Lutz
6
Affects Status Importance Assigned to Milestone
Wubi
Undecided
ecology2007
Baltix
Undecided
Unassigned

Bug Description

Since NSIS doesn't allow to change the language on the fly, does that mean you need an .exe for each language ?

How far are we from having a multilingual installer ? Do you want to setup the translation tool in launchpad ?

Revision history for this message
ecology2007 (ecology2007) wrote :

I am working on it right now.
Changing the language on the fly is not a problem anymore, wubi uses windows language when we have a translation for it, otherwise it uses english.
I have investigated a lot of different ways to do it, but none is 100 % satisfactory.
In particular, i have big issues when the translation is not 100 % complete, you can use only one language at once, and then the missing strings are replaced by empty strings, not by their english version.
Do you know either NSIS or launchpad gettext po files ?
Can you help ?

Below is attached the file containing our localized strings.

Revision history for this message
ecology2007 (ecology2007) wrote :

All required strings are in wubi devel revision 100,
the lupin-translation-team can start the translation.

http://ubuntuforums.org/showthread.php?t=457362

Revision history for this message
ecology2007 (ecology2007) wrote :
Revision history for this message
Darkmaster (darkmaster) wrote : Italian translation

Hi, I created an Italian Translation following your guidelines. Here is the file. Hope this helps :) I really love your program. It is allready helping me installing Ubuntu without fear on one of my friend's Computer. If only I could solve the damned 33% during virtual disk format bug....

Revision history for this message
Agostino Russo (ago) wrote :

thanks a lot for the translation, see the latest minefield for bug 33% and please let us know if it works.

Agostino Russo (ago)
Changed in wubi:
status: Unconfirmed → Fix Committed
Revision history for this message
Agostino Russo (ago) wrote :

Released as of Wubi-7.04.01+

Changed in wubi:
assignee: nobody → ecology2007
status: Fix Committed → Fix Released
Revision history for this message
Adrian (adriano9966) wrote : Re: [Bug 116176] Re: have the installer in other languages

-----Original Message-----
From: Agostino Russo <email address hidden>
To: <email address hidden>
Sent: Wed, 20 Jun 2007 11.27am
Subject: [Bug 116176] Re: have the installer in other languages

Released as of Wubi-7.04.01+

** Changed in: wubi (upstream)
     Assignee: (unassigned) => ecology2007
       Status: Fix Committed => Fix Released

--
have the installer in other languages
https://bugs.launchpad.net/bugs/116176
You received this bug notification because you are a member of Lupin
translation team, which is a direct subscriber.

salve agostino,
               sono proprio contento che mi dai quest'opportunita di rendermi utile,
pero non ho mica capito come devo fare per accedere a questi file.siccome non sono
tanto furbo con l utilita di linux mi trovo un attimo in imbarazzo per questo fatto.
ti prego di spedirmi un esempio di testo da tradure e farei il mio meglio ti prometto
              ti saluto cordialmente......Adrian p.s wubi e meraviglioso

hi agostino,
            I am delighted that you have given me the opportunity to make myself usefull
but im not exactly sure what I need to do to open these files.Being as though im not very
knowledgeable when it comes to using linux utilities I find myself at a loss as to how
to open them in order to translate.could you please send me an example of text to translate
and ill do my very best I promise kind regards Adrian ps wubi is really wonderful

________________________________________________________________________
Get a FREE AOL Email account with 2GB of storage. Plus, share and store photos and experience exclusively recorded live music Sessions from your favourite artists. Find out more at http://info.aol.co.uk/joinnow/?ncid=548.

Revision history for this message
Darkmaster (darkmaster) wrote :

@Adrian

Hi Adrian, guess I already created the Italian translation.... sorry :(
Ciao Adrian, temo di aver già provveduto a fornire la traduzione italiana.... sorry :(

Revision history for this message
lesmo (lesmo-sft) wrote :

Hi. I have a little time reading about Wubi translations, and I know
perfectly the spanish language it's my native language). And, because I'm
very new to the launchpad system, I was wondering if a spanish translation
is needed.

Greetings

2007/6/20, Darkmaster <email address hidden>:
>
> @Adrian
>
> Hi Adrian, guess I already created the Italian translation.... sorry :(
> Ciao Adrian, temo di aver già provveduto a fornire la traduzione
> italiana.... sorry :(
>
> --
> have the installer in other languages
> https://bugs.launchpad.net/bugs/116176
> You received this bug notification because you are a member of Lupin
> translation team, which is a direct subscriber.
>

--
El fuego quema, y quemar es malo ...

Revision history for this message
Darkmaster (darkmaster) wrote :

@lesmo

HI! Help is always appreciated, you can visit this ubuntu forum page:

http://ubuntuforums.org/showthread.php?t=457362

To have instructions about how to translate in other languages and which languages has already been translated. As for the Spanish translation, I see there that the user open2linux already took care of it...

Revision history for this message
lesmo (lesmo-sft) wrote :

Uh... Yeah, you're right. But (there's a but [not butt =P]), maybe I can
check for Spanish gramatical errors.

Wich ones? Well... In english the word YOU is used to refer to 3rd persons,
while you know them or not. For example, you can say (in english):
- Hello sir. Do you want to have a seat?

But in spanish you must choose between this ones:
- Hola señor. ¿Quiere sentarse?
- Hola señor. ¿Quieres sentarte?

Little difereces...

Anyway, future spanish translations are welcome =)

Thanks

2007/6/21, Darkmaster <email address hidden>:
>
> @lesmo
>
> HI! Help is always appreciated, you can visit this ubuntu forum page:
>
> http://ubuntuforums.org/showthread.php?t=457362
>
> To have instructions about how to translate in other languages and which
> languages has already been translated. As for the Spanish translation, I
> see there that the user open2linux already took care of it...
>
> --
> have the installer in other languages
> https://bugs.launchpad.net/bugs/116176
> You received this bug notification because you are a member of Lupin
> translation team, which is a direct subscriber.
>

--
El fuego quema, y quemar es malo ...

Revision history for this message
Mikel Pascual Aldabaldetreku (mpascual) wrote :

Hi

a little detail

if you're going to use the windows language for setting the installer's language, remember that there are lots of languages without a windows translation.

in my own language, the fact is that the translation is only half-done, and very little people uses it.

regards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers