Sorting of included and excluded backup folders

Bug #1193149 reported by sojusnik on 2013-06-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Back In Time
Fix Released
Wishlist
Unassigned

Bug Description

Would be nice, if the including or excluding backup folders could be sorted manually or at least alphabetically in the Back in Time GUI.

Germar (germar) on 2013-06-20
Changed in backintime:
importance: Undecided → Wishlist

+1
It is very difficult to have a good overview, as the backup folders are listed "randomly" (i.e. in the order of their date added).

I think a good way would be to have an icon in the Setting | Include/Exclude dialog, called "Re-arrange items" or similar.

Kind regards!
spectas

Germar (germar) on 2013-10-06
Changed in backintime:
status: New → Confirmed
Germar (germar) on 2013-12-12
Changed in backintime:
milestone: none → 1.1.0
Germar (germar) on 2014-04-02
Changed in backintime:
status: Confirmed → Fix Committed
Germar (germar) on 2015-01-15
Changed in backintime:
status: Fix Committed → Fix Released
sojusnik (sojusnik) wrote :

Great news!

Would be even better, if the sort order in the settings would stay after a restart.

Do you thought of implementing the same feature in the main window of BiT?

Germar (germar) wrote :

I did't like to show an extra column with the original sort order in numbers. That's why I didn't store the sort order.

What do you mean by implementing this in main window? Sorting in filesview is supported for a long time already.

sojusnik (sojusnik) wrote :

What would be the use of the column with the original sort numbers?

By the main window I mean the following: http://i.imgur.com/BwL7ffk.png

It would be more consistent to have the sort order of the included folders in the main window - matching the order from the settings menu.

Germar (germar) wrote :

Okay, now I see. Will have a look on how to implement sorting for this. It's not that easy as for include/exclude in Settings.

I think its important to have the all objects sorted in the order they were added, too. At the moment I've done this with an extra column which is hidden but is the default sort. If you click the header you'll change sort to the visible column.

I'll have a look if I can change this without having an ugly list.

BTW nice Theme! Is this Plasma5?

Thanks!

Regarding the sorting: Since the original sorting is saved, there is
actually no need for an additional column - the first click on the header
sorts the folders ascending, the second click descending and the third
shows the original state, read, the order they were originally added.

It's a quite popular theme and is called Numix¹ :)

¹ https://numixproject.org/

2015-01-18 20:43 GMT+01:00 Germar <email address hidden>:

> Okay, now I see. Will have a look on how to implement sorting for this.
> It's not that easy as for include/exclude in Settings.
>
> I think its important to have the all objects sorted in the order they
> were added, too. At the moment I've done this with an extra column which
> is hidden but is the default sort. If you click the header you'll change
> sort to the visible column.
>
> I'll have a look if I can change this without having an ugly list.
>
> BTW nice Theme! Is this Plasma5?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1193149
>
> Title:
> Sorting of included and excluded backup folders
>
> Status in Back In Time:
> Fix Released
>
> Bug description:
> Would be nice, if the including or excluding backup folders could be
> sorted manually or at least alphabetically in the Back in Time GUI.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/backintime/+bug/1193149/+subscriptions
>

Germar (germar) wrote :

Oh, quite easy ;-) Thanks
Sometimes I'm to complicated to see the simple solution

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers