Keyboard shortcuts overlay text too long

Bug #924840 reported by Alan Pope  on 2012-02-01
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Ubuntu Translations
Undecided
Unassigned
Unity
Low
Marco Trevisan (Treviño)
7.2
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)
Trusty
Undecided
Unassigned

Bug Description

[Inpact]
The shortcut overlay window listes some truncated keybindings and descriptions although there's enough horizontal space to show them all.

[Test case]
The test case for this bug depends a lot on the locale used and thus there's not an universal way to verify it, this is generally valid for English locale but should apply to others as well:

1. In Unity Control Center -> Appearance -> Behavior enable the workspaces
2. Hold down the super key unless the shortcut overlay window is not show (if it's
   supported, minimum resolution is 1366x768)
3. Both the keybindings and the descriptions should not be ellipsised if there's enough
   horizontal space to present them, for example the "Super + Alt + Cursor ke.."
   keybinding should be instead "Super + Alt + Cursor keys"

[Regression potential]
The view might be too large in some locales and thus not to show at all, although we should generally handle this as it used to be before.

----------

When I hold down Super I get a popup image detailing the shortcut keys. There are a few issues with this image which I have filed as separate bugs.

Workspaces Text too long to fit. I see "Super + Alt + Cursor ke.." Which I presume should say "Cursor keys"

Related branches

lp:~3v1n0/unity/shortcuts-hidpi
Andrea Azzarone: Approve on 2014-05-16
PS Jenkins bot: Pending (continuous-integration) requested 2014-05-16
lp:~3v1n0/unity/dynamic-shortcut-hint
Andrea Azzarone (community): Approve on 2014-05-15
lp:~unity-team/unity/7.2.2
Marco Trevisan (Treviño): Approve on 2014-07-04
Superseded for merging into lp:unity
Unity Team: Pending requested 2014-07-01
Alan Pope  (popey) wrote :
Changed in unity:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Simeon (simeon5) wrote :

This is a problem with translated texts too as german text for example is usually longer than english text.

Bence Lukács (lukacs-bence1) wrote :

It's a problem with hungarian texts too.
http://noob.hu/2012/02/28/shortcuts-overlay.png

Omer Akram (om26er) wrote :

Bence, you screenshot is not opening attach it to launchad :)

Bence Lukács (lukacs-bence1) wrote :

Sorry, here is the screenshot.

Omer Akram (om26er) on 2012-03-01
tags: added: needs-design
Simeon (simeon5) wrote :

This is really ugly, affects multiple languages and VERY visible so I think this should be fixed BEFORE the release!

Sebastien Bacher (seb128) wrote :

@Simeon: it's a no way a release blocker, we have hundred of annoyances and graphical issues that would be nice to fix and we will sort them over time, it just doesn't seem realistic that will be fixed during the hard freeze

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Eduard Gotwig (gotwig) wrote :

Why does Unity not apply the new translation strings for the overlay?

https://translations.launchpad.net/ubuntu/quantal/+source/unity/+pots/unity/de/+translate?batch=10&show=all&search=linke+oder+rechte e.g does not seem to work. It does still use the old strings.

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.3.0
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140607-0ubuntu1

---------------
unity (7.2.0+14.10.20140607-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)

  [ Marco Trevisan (Treviño) ]
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general. (LP:
    #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)
 -- Ubuntu daily release <email address hidden> Sat, 07 Jun 2014 16:27:46 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
description: updated

The version in trusty-proposed fixes the problem. At least that's how it looks for me on 1920x1080 resolution and Polish language.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: New → Fix Released
Changed in ubuntu-translations:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers