"Software Up to Date" should be called "Software Updater"

Reported by frizzle21 on 2011-12-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Session Menu
Low
Unassigned
indicator-session (Ubuntu)
Undecided
Unassigned

Bug Description

The Indicator Session Menu item "Software Up to Date" implies a state, which is yet to be determined by actually clicking this item; hence we face a race condition in the design of our menu/ui. The state which is yet to be determined is indicated before it is even known, which again is impossible.

Much better would be to name the item "Software Updater", especially because this is consistent with what happens, when the item is clicked or tapped on.
Clicking the item does not invoke the state "Software Up to Date", but it invokes an appliance, which offers different interaction possiblilities related to Software Updating. Such an appliance would be best named a Software Updater appliance, for short "Software Updater" - this is in great accord with the law of correspondence.

MPT has already specified this name in his spec, also mentioned here:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/618723

an asian proverb says: "solve one problem and a thousand problems vanish along with it"

description: updated
Bilal Akhtar (bilalakhtar) wrote :

For the sake of consistency, this bug is blocked on bug #618723 for now.

Bilal Akhtar (bilalakhtar) wrote :

Blocked by*

Changed in indicator-session:
status: New → Confirmed
Changed in indicator-session (Ubuntu):
status: New → Confirmed
Ted Gould (ted) on 2012-02-07
Changed in indicator-session:
importance: Undecided → Low
Jeremy Bicha (jbicha) wrote :

I'm closing this bug since the latest indicator-session doesn't include a link for Software Updater so there's nothing to fix now.

Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-session:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers