Ubuntu One sync emblem ruins text icons

Reported by David López on 2011-12-04
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Nautilus
New
Medium
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Icons of a text file show a few words in the first line of the file, very useful to locate a text file in a quick look. Same happens with pdf files, the icon is a small miniature of the first page.

However if text files are syncronized with ubuntu one the icon is blank (with a green mark in the right-lower corner of the icon), no traces of the text. That doesn't happen with pdf files, icons of the sync files are OK (miniature of the page and green mark)

-----------------------------

Los iconos de un archivo de texto muestran unas pocas letras de las primeras líneas del archivo, algo muy útil para localizar rápidamente archivos. Algo parecido pasa con los pdf, que muestran una miniatura de la primera página.

Sin embargo si los archivos de texto están compartidos mediante ubuntu one el icono queda completamente blabnco con la señal verde abajo a la izquierda, ni rastro del texto del interior del archivo. Esto no ocurre con los pdf, que el icono sigue teniendo la miniatura y encima la marca verde.

Agreed, the sync emblem is crass, let's get a better one!

Chris Wilson (notgary) wrote :

Confirmed because Mark says so.

Changed in ayatana-design:
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Rodney Dawes (dobey) wrote :

I don't think this has anything to do with Ubuntu One, actually. Do you see the same problem when other emblems are set on the text file? For example, if you create a symlink to another text file, does the symlink exhibit the same issue? Or if you make a text file readonly does the same happen?

David López (david-lopez-upct) wrote :

Rodney, you're right: symlinks or read-only emblems suffer the same problem in text files.

Rodney Dawes (dobey) wrote :

Moved this to nautilus as the problem is due to how emblems, and plaint text previews, are rendered. As noted in comment #4, the issue is with any emblem on a file with live text preview. This isn't an issue with PDF files, as they are rendered to thumbnail images, which then simply have the emblem composited on top. Possible solutions are to:

1) Render thumbnail PNGs of text files, instead of rendering live previews (which are basically useless anyway).
2) Disable live text preview (as it's basically useless if you aren't using extremely large icon sizes).
3) Fix nautilus to render live preview on top of composited icon with emblems (which may work already and simply require changes in the icon theme, which may look quite bad when live preview isn't used).

I would vote for number 2 myself. If Mark thinks the emblems used are just not good images, then a separate bug should be opened against the icon theme (humanity-icon-theme) for that specific issue, as Ubuntu One itself does not install any emblem images.

affects: ubuntuone-client → nautilus (Ubuntu)
David López (david-lopez-upct) wrote :

Live icons is a great feature in my opinion. For example when I run latex I obtain .tex, .log, .aux, .out and pdf files, and when I combine latex and maxima I also generate .mxx, .mac and .mac.log files. 8 files with the same name with only differ in extension, 7 of them text files.

My icons are not extremly large (they are "out of the box", I haven't resize them) and I can see 4 lines of text, 5 characters in each line. Those 20 characters allow me to instantly recognize which one is the .tex file, wich one are .log, etc, I don't need to look at the extension. That's the reason which I love live text icons. I attach a picture.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
TomasHnyk (sup) wrote :

I secon David lopez, the feature is great becaus it allows quicly recognizing what a given text i savout. It should get fixed.
So I would probably wote for 1), if it changes when a file is changed and it seems to be the least amount of work.

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Chris Wilson (notgary) wrote :

Going to close the paper cut task on this since I'm not aware of any qualified designers among our number.

Changed in hundredpapercuts:
status: Triaged → Invalid
importance: Medium → Undecided
assignee: Paper Cuts Ninja (papercuts-ninja) → nobody
TomasHnyk (sup) wrote :

Chris Wilson: Eh, there is no need to design anything, just to fix the bug (make the text appear)? I understand it might go beyond the scope of hundreds project, but the problem is not with icons, it is with the text not showing. Read the bug description again (hint: sabdfl got it wrong unless the description has changed in the meantime which it did not, if I see correctly).

Chris Wilson (notgary) wrote :

@TomasHnyk, You're right. I made a mistake with this one :)

Changed in hundredpapercuts:
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.