Launcher - The Launcher should provide instant visual feedback when a user clicks on a icon to launch an application

Reported by John Lea on 2011-11-21
98
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Nick Dedekind
unity (Ubuntu)
High
Unassigned

Bug Description

The Launcher should provide instant visual feedback when a user clicks on a icon to launch an application.

At the moment clicking on a Launcher icon to launch an application starts a slow pulsing animation while the application loads. However because the animation fades in slowly after the click, the responsiveness of the Launcher is being perceived as slow.

Desired resolution:

The following animations for when a user clicks on a Launcher icon to Launch an application should be tested:

a) Outerglow instantly switches on for a short set duration (fraction of a second)

b) Icon glow instantly inverts, and then pulse animation starts running from the inverted state. If backlight mode is set as 'always on', this means that on click the backlight instantly switches off. If backlight mode is set as 'toggles', this meas that on click the backlight instantly switches on. After this instant state inversion, the normal pulse animation starts running.

c) Any other ideas you think of ;-)

After these transitions are implemented they will need to be tested by design where the single option that will ship with 12.04 will be chosen..

Related branches

lp:~nick-dedekind/unity/lp893140.launcher-icon-feedback
Merged into lp:unity at revision 2891
John Lea: Approve (design) on 2012-11-14
Marco Trevisan (Treviño): Approve on 2012-11-12
Brandon Schaefer: Approve on 2012-11-09
Stephen M. Webb: Needs Fixing on 2012-11-07
PS Jenkins bot: Pending (continuous-integration) requested 2012-11-12
John Lea (johnlea) on 2011-11-21
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
tags: added: udp

+1 to this enhancement. I would love to see it glow instantly when clicked.

John Lea (johnlea) on 2011-11-21
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
Tim Penhey (thumper) on 2011-11-22
Changed in ayatana-design:
status: Triaged → Fix Committed
candtalan (aeclist) wrote :

Well done guys! this is seriously needed.

Please note that an associated GUI Launcher Icon function issue is driving me mad with frustration:
#992132 Launcher icons go into 'move position' mode too quickly

Omer Akram (om26er) on 2012-07-24
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity:
status: Triaged → In Progress
Changed in bamf:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
no longer affects: bamf
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2012-11-22
Changed in unity (Ubuntu):
milestone: none → ubuntu-13.04-alpha-1
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily12.12.05-0ubuntu1

---------------
unity (6.12.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
  * Automatic snapshot from revision 2905 (bootstrap)
    - Hide launcher tooltip once shortcut overlay appears (LP: #1035860)
    - Update shortcut overlay design (LP: #1049601)
    - Don't cut off shadow on launcher icon drag window (LP: #765715)
    - Provide more immediate feedback when clickong on launcher (LP: #893140)
    - Decorate spread windows in switcher (LP: #838222)
    - Make sure to initialize a variable before it can be used (LP: #1073516)
    - Fix FTBFS due to BAMF API change (LP: #1077937)
    - Run gtest during build (LP: #133637)
    - Make shopping lens test more robust (LP: #1077131)
    - Fix some random autopilot test failures (LP: #1078448)
    - Fix autopilot tests for details mode (LP: #1073892)
    - Fix autopilot tests for indicator-session (LP: #1075350)
    - Fix autopilot tests for non-English locales (LP: #1075898)

  [ Didier Roche ]
  * debian/control:
    - adding libgtest-dev and google-mock build-dep now that there are in main
      (LP: #1076763)
    - add libunity-core -> unity-common dep (LP: #1079132)
    - do not have unity-common dep on compiz-gnome: the migration code is only
      ran if compiz-gnome is installed, but compiz-gnome is pulled by compiz
      directly. We don't care if the migration code isn't executed.

  [ bschaefer ]
  * Ported to nux 4.0

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)

  [ Nick Dedekind ]
  * Previews loading more than 454 lines of description text crash Unity
    (LP: #1066788)

  [ Brandon Schaefer ]
  * unity::TimeUtil::TimeDelta returns an int value which overflows
    after 24 days of uptime (LP: #806248)
  * Top panel "tooltip" is gone (regression) (LP: #1085045)
  * Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars
    are too thin to grab on to. (LP: #608124)

  [ Andrea Azzarone ]
  * Dash - Regression: Clicking between filter label and 'All' button no
    longer toggles filter label (LP: #1080534)

  [ Didier Roche ]
  * libunity-core fails without the schemas from unity-common (LP:
    #1079132)

  [ Manuel de la Pena ]
  * There is no common ui element that behaves like a url link (LP:
    #1067705)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 2956
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:29 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints