Dash - horizontal divider line in between categories incorrectly drawn

Bug #841750 reported by John Lea on 2011-09-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Mirco Müller
unity-2d
Low
Tiago Salem Herrmann
unity (Ubuntu)
Medium
Mirco Müller
Oneiric
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Dash - horizontal divider line in between categories incorrectly drawn.

See the designs in https://chinstrap.canonical.com/~sabdfl/11_10/desktop_and_netbook/dash/ , this is what we are trying to replicate.

Desired resolution:
- line should be 1px high
- the colour of the line should be 100% white (#ffffff)
- the line should have a opacity of 15%
- the line should have a outer glow that is 20%, #ffffff, 6px
- the spacing on either side of the line should be 15px

----------------------

Bug reverted to 'Confirmed' because there are still the following outstanding issues:

In the App Lens (see attached image "dash_divider lines wrong1.png")
- there is a small 'bump' at the far left and far right ends of each divider line
- the spacing on either side of the line is only 10px, not the 15px specified above
- the divider does not have any opacity applied. The opacity of the line should be 15%
- sometimes after opening the app lens and waiting roughly 10 seconds the line grows in height and jumps to being 2px high.
- the vertical alignment of the horizontal dividers is wrong, see attached image "dash_divider_alignment.png"

In the File Lens (see attached image dash_divider_lines_wrong2.png)
- the horizontal divider lines don't appear at all

Related branches

John Lea (johnlea) on 2011-09-05
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
tags: added: onew udo
Mirco Müller (macslow) on 2011-09-21
Changed in unity:
status: New → Confirmed
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Medium
milestone: none → 4.18.0
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Mirco Müller (macslow)
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jason Smith (jassmith) wrote :

Implemented as latest mockup shows

Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

R

John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :

Reverted to confirmed because there are still a number of outstanding issues, see updated bug description.

description: updated
Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity-2d:
importance: Undecided → Medium
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.20.0 → 4.24.0
Mirco Müller (macslow) on 2011-10-07
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
milestone: none → oneiric-updates
Neil J. Patel (njpatel) on 2011-10-10
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released

Hello John, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Gerry Boland (gerboland) on 2011-11-29
Changed in unity-2d:
importance: Medium → Low
milestone: none → 5.2
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d (Ubuntu Oneiric):
status: New → Confirmed
Andrea Cimitan (cimi) on 2011-12-13
tags: added: unity3p
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
milestone: 5.2 → 5.4
Changed in unity-2d:
milestone: 5.2.1 → 5.6
Gerry Boland (gerboland) on 2012-02-28
Changed in unity-2d:
status: Confirmed → In Progress
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8
Gerry Boland (gerboland) on 2012-03-12
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-15
Changed in unity-2d:
milestone: 5.8 → 5.7
Didier Roche (didrocks) on 2012-03-19
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.7.0-0ubuntu1

---------------
unity-2d (5.7.0-0ubuntu1) precise; urgency=low

  * New upstream release:
    - unity-2d-panel crashed with SIGABRT in Unity2dDebug::unity2dQtHandler()
      (LP: #925457)
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #947278)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - [dash] [launcher] [panel] Tinting based on wallpaper missing
      (LP: #882101)
    - [launcher] In multimonitor setup Unity-2D only shows launcher on one
      monitor (fails MM UX spec #2.8) (LP: #780204)
    - [unity-2d] FF exception to add PointerBarrier to Unity2d (LP: #947976)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - lens switching is not keyboard navigable (LP: #945220)
    - [panel] [multi-monitor] On secondary screen, unable to scrub from
      indicator menu to app menu (LP: #844809)
    - "Workspaces" button displays previous wallpaper (LP: #900019)
    - Dash - cursor should change when pointer is over the search field
      (LP: #849175)
    - Filter checkboxes are without margins in right to left locales
      (LP: #949319)
    - [panel] [multi-monitor] Open indicator menu on one screen causes other
      indicator to look open too (LP: #844798)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - [launcher] Tile Progress bar starting from left of launcher, not
      container (LP: #912777)
    - Dash - dash is not closed with alt+f4 (LP: #891818)
    - [dash] Rating stars in right-to-left locales behave inconsistently.
      (LP: #945719)
    - LensButton.qml:72 warning when running unity-2d (LP: #947276)
    - [dash] Multi-range filters are rendered incorrectly in right-to-left
      locales (LP: #950649)
  * debian/unity-2d.gconf-defaults:
    - removed: not used anymore and causing regression with hide-mode=2
      by default, converted to the gsettings key (LP: #942772)
  * debian/unity-2d.preinst:
    - removed, was a natty -> oneiric transition
  * debian/control, debian/unity-2d-common.install:
    - create unity-2d-common and make some packages depending on it
    - move some files from unity-2d package to unity-2d-common
      (gsettings and apport hook) to have packaging shipping their schema
      (LP: #925457)
  * debian/unity-2d-common.install.in:
    - no more gconf -> gsettings migration shipped
  * debian/unity-2d.postinst, prerm, trigger:
    - moved to unity-2d-common new package, to ensure even people uninstalling
      unity-2d got the right metacity configuration in the session
    - update the trigger to the correct directory
  * debian/control:
    - bump to latest Standards-Version
    - fix some too long description
    - put the transitional packages in the oldlibs/extra section
    - build-dep on libxtst-dev, libxfixes-dev for barrier change
    - need latest metacity for barriers to work
 -- Didier Roche <email address hidden> Mon, 19 Mar 2012 14:07:10 +0100

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Logan Rosen (logan) on 2012-03-19
summary: - Dash - horizental divider line in between categories incorrectly drawn
+ Dash - horizontal divider line in between categories incorrectly drawn
description: updated
Nick Tait (jnick-tait) on 2012-04-26
tags: added: reviewedbydesignp
removed: udo udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-06-27
Changed in unity-2d (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers