launcher tooltip delay is useless and gives the impression as if the launcher is not responding

Reported by Omer Akram on 2011-06-30
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

I have been using unity 4.0.1 and the delay in showing the tooltip when you initially hover over a launcher tile is just annoying. The previous behavior was far superior(tm) so please revert it back to as it was.

This bug is the opposite of bug #687956.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Uname: Linux 3.0-2-generic i686
Architecture: i386
CompizPlugins: [core,detection,composite,opengl,compiztoolbox,decor,gnomecompat,grid,imgpng,move,place,regex,resize,scale,animation,expo,mousepoll,session,snap,vpswitch,wall,workarounds,ezoom,staticswitcher,unityshell]
Date: Thu Jun 30 23:19:52 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110624)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Omer Akram (om26er) wrote :

Note: I don't think this bug requires ayatana-design as affects as the initial change that happened to add delay was done without the inquiry from design afaik.

I agree that launcher looks like more unresponsive this with this delay.

Anyway, I'm marking this as needs-design because John Lea has marked ayatana-design task in bug #687956 as fix released.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity:
status: Invalid → Incomplete
Changed in unity (Ubuntu):
status: Invalid → Incomplete
description: updated
tags: added: needs-design
gluxon (bcheng-gt) wrote :

I have to agree with this. If the user is switching between applications, the label will show anyway after clicking on another application.

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Greg A (etulfetulf) wrote :

It was commented on the duplicate Bug #814441 that "A short delay before displayed is time-honored tooltip behaviour, otherwise we'd have them popping up all over the place."

I think there are two main problems with the current oneiric implementation. It is my belief that if both of these cannot be addressed we should revert to the previous instant tooltip behaviour. Given the comment above, I'm going to make some comparisons to tooltips in Firefox when mousing over both bookmarks (in the bookmark toolbar) and tabs.

#1. Delay makes launcher feel unresponsive/slow/buggy.

This is because there is no immediate feedback to the user when mousing over a launcher item. In Firefox there is immediate visual feedback in the form of a slight colour change / tinting. After about a second then the tooltip displays.

If the delay is to be kept then I think it is imperative that feedback is provided to the user by some other visual change when they mouse over a launcher item.

#2. Current behaviour is inconsistent (with itself)

The delay is (I believe) intended to only happen when a launcher item is first moved over. Subsequent moves to other launcher items make the tooltips show up instantly.

The proviso for instant tooltips is that the mouse stays on the launcher. This sounds fine, but in reality when moving the mouse up and down the launcher, the mouse regularly slips off the launcher (perhaps by only a couple of pixels). This means the delay happens again. I am also finding that moving the mouse down the right hand side of the launcher (keeping the mouse on the launcher) creates a delay on every launcher item (this is probably a separate bug). This is all confusing - sometimes we get the delay and at other times we don't.

If the delay is to stay, then I see two options:
A: Have a delay on all launcher items, even when moving from within the launcher. This is the behaviour found in Firefox.
B: Have an initial delay, but after that then as long as another tooltip has been visible in the past X seconds, then tooltips are shown without delay. (This is similar to how if the launcher has been moused over in the past X seconds, it is not autohidden.)

Omer Akram (om26er) wrote :

Could we have this reviewed again for the release? I have still not got used to this behavior after the constant usage of two months here.

LostOverThere (lostoverthere) wrote :

This is definitely an issue. The delay makes the launcher look incredibly sluggish, and even made me start searching the internet as to why my launcher was "acting slow" - only to discover it wasn't, and was simply a timed delay.

For the moment, is there any way to disable this delay, perhaps in dconf or something? While the delay should definitely be removed by default, it may be nice to have the option to set a delay in ccsm for those user who want it.

Adolfo Jayme (fitoschido) wrote :

Indeed. Now there are questions in AskUbuntu regarding how to disable tooltip delay.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Octavian Damiean (mainerror) wrote :

I agree on this. On top of that I also think that we are really missing an immediate feedback mechanism like Greg mentioned.

The delay should definitely be looked at. As a visual feedback mechanism there could be a decent glow around the launcher if you hover over it for example or to move it slightly out by x pixels.

Omer Akram (om26er) wrote :

Seems fixed in Precise

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Artem Vorotnikov (skybon) wrote :

UN-fixed after upgrading to Raring from Quantal. Getting 2-second tooltip delay.

Adolfo Jayme (fitoschido) wrote :

I reported a follow-up bug, LP: #1152390.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers