[UIFe] Add system setting icon to Launcher

Reported by Charline Poirier on 2011-04-18
142
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Didier Roche
unity (Ubuntu)
Undecided
Unassigned

Bug Description

In usability testing, participants didn't find the system settings. They expected to find an icon in the Launcher.

Desired solution:
- Add a 'system settings' icon to the launcher. This icon should be present in the launcher by default after a fresh install.
- Add a launcher quicklist that links to Personal, Hardware, and System setting categories (this change is optional for 11.10)
- The 'System Settings' launcher icon should be positioned directly above the workspace switcher icon.

Note that this change only applies to fresh installs. Users upgrading to Oneiric should not automatically have this icon added to their launcher.

tags: added: nattytesting
John Lea (johnlea) on 2011-04-18
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udo
Changed in ayatana-design:
importance: Undecided → High
status: New → Fix Committed
Patrick Scott (patrickscott52) wrote :

I'm no power user or expert but I'm not happy with this change. As a Windows 7 user, I don't want or expect a link to the control panel to be placed on the taskbar taking up space. The Unity launcher should be reserved for applications used once a day, not once a week. That being said I have no issue with you placing the shortcut there since I can very easily remove it. It's the idea of removing the "System Settings" option from the session menu that gets me, I thought it was really well placed there and very discoverable. It is also consistent with other operating systems since Windows has always had its Control Panel near the power buttons in the Start Menu...

Patrick Scott (patrickscott52) wrote :

Okay slightly reconsidering my previous comment. Maybe putting the "System Settings" option under the Session menu isn't the best placement, after all you are the ones conducting the usability tests here :) . But if it's to be removed from the Session menu, I'd liked to see it highlighted as a shortcut in the dash so that if people remove the shortcut you've added to the launcher it is still just one click away. And maybe you could also consider adding it to the context menu when right clicking the desktop background [just a thought]

Jeremy Bicha (jbicha) wrote :

I suggest don't remove the System Settings button from the session menu unless you're going to replace, for instance the "Mail" icon on the Dash homepage with a System Settings launcher, as hiding the Settings somewhere in Applications isn't solving this issue either.

Users who learn how to log off their computer (which should be everyone) won't be able to miss seeing the System Settings button anyway in its current location.

Patrick Scott (patrickscott52) wrote :

Agreed, unity launcher icons are temporary so it makes sense to either leave a permanent shortcut to system settings in the session menu or create a new shortcut in the Dash.

Vish (vish) wrote :

While adding the launcher maybe an easy workaround for making this 'easily accessible' and solve this issue in user-testing, it does not seem like a good long-term solution.

Yes, In a new install a user would surely want to change a few settings. But after changing the settings how often would they require that launcher? In the old GNOME panel, In my case, I've made a few adjustments early on and have very rarely visited the System menu. This icon would be a waste of space when it is not used meant to be used frequently or even required later by many.

Sure, the user can remove the icon if not using it, then where would the user find this System Settings option? The user will again be lost, or the user is forever bound to have this less frequently used icon in the launcher just for the sake of being able to find it again if ever he requires it.

Ideally, the System settings could be placed in a location along with the "About Version"(1) and the "Help and Support" (2) , but in the launcher is not the best solution.

(1) Bug #688008 : No graphical way to tell what version of Ubuntu you're using
(2) Bug #744565 : "Help and Support" not available in Natty

The settings entry point will remain in a menu. However, it may also be
added to the Launcher, where it can easily be removed.

Mark

As per Mark's comment, could someone from design team/John update the bug description, and remove the first part of the Desired solution?
"- Remove link to systems settings from the session menu"

 (I could edit it, but better if done by someone who is in-charge :) )

There is a usability issue with finding the system settings that we need to resolve. Participants have said during testing that they would expect system settings to be either in the Launcher or in what was at the time of testing named 'Home' (Nautilus). It seemed natural to put the system settings where most users expect to find them.

Of course, we will try and usability test other solutions before we settle on one.

Remember, though, that we were asking people to find the system
settings. That's artificial. If the defaults are sane, users will not
need the system settings when they start with the device. Items they
will need immediately are given high visibility, such as the network
indicator.

Their position in a menu users will touch every day means that they will
be discovered as users enjoy the device.

We could of course give people a device for 1, 2 or 5 days, and see what
they have learned about it and what their frustrations were, as a more
natural test.

Why don't we just have a 9th button in the Dash (not in-line with the other 8, or to the lower-right for example) that links to, say, a Settings dash/lens/place (that's not visible from the Launcher like other Places)?

You could have a properties/settings section and a system section, and maybe even a system overview section (with stuff like OS, version, kernel, RAM, CPU... - even usage)...

Or you could just have the button open GNOME System Settings.

Jamie Brewer (jamie-brewer) wrote :

"Their position in a menu users will touch every day means that they will
 be discovered as users enjoy the device."

Will they now?

I have Ubuntu on a netbook, and admin a handfull of Ubuntu workstations on the job. I might not touch the session menu once in a week, if that. My netbook gets put to sleep by closing the cover, it goes into hibernate as power management dictates, it gets restarted when Update Manager nags about it. The workstations stay on most of the time, they lock themselves then they're idle for X amount of time. They're sometimes manually restarted or logged out from but this is the exception rather than the rule.

Furthermore, when I was actively looking for it, the menu denoted by (and generally associated with) a power button isn't exactly the first, second or third place I'm going to look when I'm looking for, say, printer settings or the disk management tool.

(Unity experience level - replaced Windows with Ubuntu on my netbook a few months ago, tried the netbook remix first, got annoyed with it, went to standard Ubuntu. Upgraded to 11.04 today, giving Unity a second go...it's much smoother than in Maverick but still a few sticking points.)

Jamie Brewer (jamie-brewer) wrote :

Also, human perception is a dodgy thing. I may indeed have physically seen the entry for System Settings in the session menu before, but I didn't *know* it was there until I went back and looked at the design blog, which said it was there, because I wasn't expecting it to be there.

Jason Smith (jassmith) on 2011-05-05
Changed in unity:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Jason Smith (jassmith)
milestone: none → alpha1
milestone: alpha1 → ux-backlog-2
milestone: ux-backlog-2 → alpha1
Dag Ågren (paracelsus) wrote :

I didn't find out that System Settings was available in the session menu until I read this bug report, and I used it several times before that. Don't expect people to read and remember every entry in a menu.

Furthermore, the session menu is pretty clearly the "leave the computer" menu. Most of the options in there are only used when leaving the computer. This is why nobody expects to find a function which has nothing to do with leaving the computer in there.

It probably does no harm sitting there, but it also makes very little sense to have it there. If you need a permanent location for it, you really should try to think up a better one. Somewhere in the launcher overlay thing, perhaps?

Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Triaged
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Oier Mees (oier) wrote :

I agree with Matt Sturgeon and Dag. The Session is menu is the not a place where a user would look for system settings and in my opinion the Launcher is and should be place for frequently used apps (you don't change settings everyday). So I think that a new entry in the Dash would be the most logical and user friendly decision. Don't you agree?

Didier Roche (didrocks) on 2011-06-22
Changed in unity:
milestone: 4.0.1 → 4.2.0
Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
John Lea (johnlea) on 2011-09-16
description: updated
Didier Roche (didrocks) on 2011-09-16
Changed in unity:
status: Triaged → New
Changed in unity (Ubuntu):
status: Triaged → New
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
milestone: 4.8.0 → 4.18.0
John Lea (johnlea) on 2011-09-16
summary: - Add system setting icon to Launcher
+ [UIFe] Add system setting icon to Launcher
John Lea (johnlea) on 2011-09-16
Changed in ayatana-design:
importance: High → Critical
Jeremy Bicha (jbicha) wrote :

+1 from the Docs Team to add a System Settings launcher item by default.

Milo Casagrande (milo) wrote :

Hello,

from a translator point of view, not expressing the Translators Team will: how many translatable strings will this patch add? And, when is the expected deadline for translating those strings?

Since it will have a visual impact on users, it is necessary those are translated in time for being included: are those strings part of the non-langpack deadline? If so, that means translators will have more ore less 10 days if the patch is ready and the new strings are imported in a really fast way (the translation queue in this period can be quite busy, but we might monitor it and approve the template to speed it up).

Just to have a better idea of the impact and the time-table we could face.

Thank you for your attention.
Ciao.

Changed in ubuntu-translations:
importance: Undecided → High
David Planella (dpm) wrote :

Seconding Milo's concerns, it would be great to have more info on the exact strings this change would affect, so that we can ensure they can be translated in time and be thus usable for non-English speakers.

David Planella (dpm) wrote :

Also, pretty please with cherry on top: it would be great to stick to the process¹ and send a short e-mail to the ubuntu-translators and ubuntu-doc mailing lists for UI freeze exception requests.

Thanks!

[1] https://wiki.ubuntu.com/FreezeExceptionProcess#UserInterfaceFreeze_Exceptions

Martin Pitt (pitti) wrote :

Please keep in mind that space on the launcher is very limited and thus precious. On a netbook screen it is already full right now, so if we add this now, there will be another icon which will fold away. I think this would be an abuse, the launcher is meant to switch between running apps and launch often used ones, we should not use it to work around hard to find programs. Why can't we put it into the dash instead, similar to the lenses?

Martin Pitt (pitti) wrote :

That is to say, I object to making such changes at this point, as it feels like a quick shoot from the hip, and regresses the utility of the launcher.

Jeremy Bicha (jbicha) wrote :

I think the User Testing in this case is wrong or points to a misleading result. System Settings is quite a bit more discoverable in Ubuntu 11.10 than it was in 11.04. Here are several different ways of launching it:

1. At the bottom of most indicators is a button like "Sound Settings" which opens System Settings to the Sound panel with a button in the toolbar for All Settings.
2. Searching in the Dash also works well (Type in "Mouse" for instance).
3. And of course System Settings in the System Menu (now with an extra gear subicon)

Off-topic rant: the default launcher icons aren't all that useful. I complained about Ubuntu One being there in the very quickly closed bug 775251. And while it's nice to see that Ubuntu can open spreadsheets and PowerPoint presentations, most people don't do that very often.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Setting back to "New", as the UIFe has not been granted yet.

Changed in unity (Ubuntu):
status: Confirmed → New
Jason Smith (jassmith) on 2011-09-19
Changed in unity:
status: New → Invalid
John Lea (johnlea) on 2011-09-21
description: updated
Matthew East (mdke) wrote :

Just to be clear, the only approval that the docteam has given to this is to add an icon to the launcher. If, as appears to be proposed, the system settings icon is also *removed* from the session menu, it seems to me that this will break every piece of documentation that refers to system settings. I haven't checked but I would assume that there are a lot of these and therefore we can't agree to this at this late stage in the release cycle.

This comment might be redundant in circumstances where the release team has rejected the UIFE but I thought it was worth clarifying anyway.

Kate Stewart (kate.stewart) wrote :

Given the bugs we're trying to sort out right now on the desktop interfaces, would prefer not to add another point of variability (and source of potential regressions) into the release right now. Recommend this get defered to 'P' series.

description: updated
Didier Roche (didrocks) wrote :

Charline, the "Add a launcher quicklist that links to Personal, Internet and Network, Hardware, System and Other setting categories." isn't very clear and doesn't map with what is contained in gnome-control-center in Oneiric.

There are categories containing those names, but not element in it. I can maybe map "Personal" to "User Accounts", and "Hardware" to "Additional drivers", but I can't find anything mapping directly to the other items on the Quicklist. Can you please be more precise and directly name elements in gnome-control-center? Thanks.

John Lea (johnlea) wrote :

@didrocks; bug description updated with the new Gnome3 system setting categories.

description: updated
Didier Roche (didrocks) wrote :

@John: this Quicklist then can't be done then for this cycle, gnome-control-center doesn't allow scrolling or just showing one category. We can only show directy some capplet (like the "User Accounts" items), but not that and this kind of code change is risky 3 days from hard freeze.

In addition to this the window being pretty small and so, autoscrolling to the right category doesn't seem needed?

(Still waiting the release team ack for making the other changes: 1. and 3.)

Martin Pitt (pitti) wrote :

> (Still waiting the release team ack for making the other changes: 1. and 3.)

Two release team members nacked it, but I heared that this might get a SABDFL override. Subscribing Mark.

Martin Pitt (pitti) wrote :

I suppose the quicklist isn't really a dealbreaker here, at least not for oneiric? The duplicate ubuntuone icon is being fixed, and then there's just four rows of icons in three categories, so it's not exactly crowded.

Martin Pitt (pitti) wrote :

> Note that this change only applies to fresh installs. Users upgrading to Oneiric should not automatically have this icon added to their launcher.

The only thing we can (easily) implement is "this change only applies to fresh user accounts". I suppose that's what you actually mean, just wanted to point it out.

John Lea (johnlea) wrote :

@didrocks; agreed, updated description to clarify that this is optional

@pitti; yes, this change only applies for fresh user accounts.

description: updated
Martin Pitt (pitti) wrote :

This got approved by Mark, so please go ahead.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-27
Changed in unity:
status: Invalid → Triaged
assignee: nobody → Didier Roche (didrocks)
status: Triaged → Fix Committed
Changed in ubuntu-translations:
status: New → Invalid
Didier Roche (didrocks) on 2011-09-27
Changed in unity:
milestone: 4.18.0 → 4.20.0
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

Hi Team,
I am a new comer to UBUNTU, and i have subscribed to the mailing list, can
you please let me know what i am supposed to do or can somebody become a
guide to me?

Thanks
Er. Gagandeep Singh

On Fri, Sep 16, 2011 at 2:35 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> You have been subscribed to a public bug by John Lea (johnlea):
>
> In usability testing, participants didn't find the system settings.
> They expected to find an icon in the Launcher.
>
> Desired solution:
> - Remove link to systems settings from the session menu
> - Add a 'system settings' icon to the launcher. This icon should be present
> in the launcher by default after a fresh install.
> - Add a launcher quicklist that links to Personal, Internet and Network,
> Hardware, System and Other setting categories.
> - The 'System Settings' launcher icon should be positioned directly above
> the workspace switcher icon.
>
> ** Affects: ayatana-design
> Importance: High
> Assignee: John Lea (johnlea)
> Status: Fix Released
>
> ** Affects: unity
> Importance: High
> Status: New
>
> ** Affects: unity (Ubuntu)
> Importance: Undecided
> Status: New
>
>
> ** Tags: backlog nattytesting udo
> --
> Add system setting icon to Launcher
> https://bugs.launchpad.net/bugs/764744
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is subscribed to the bug report.
>

manny (estelar57) wrote :

I heartily disagree with yet another icon is going to solve the Root of the problem.

People cant find even the most basic things because the Root problem is that there is no visible user guide / tutorial / help that the user can consult each time he needs it:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/860501

if they have problems finding the settings is because they also have problems finding everything else...

"Why give a hungry man 1 fish that is going to feed him for a day, when you can teach him how to fish and feed him for a lifetime ?"

why dont you guys apply "usability testing" to the Help in ubuntu instead ?

Matthew Paul Thomas (mpt) wrote :

manny, the help probably should be easier to find, but it's not "the root problem" for anything. Gordon Meyer's "Help is the last resort" is a good explanation of this. <http://www.g2meyer.com/usablehelp/lastreso.html>

John Lea (johnlea) on 2011-10-18
tags: added: reviewedbydesigno
removed: udo
no longer affects: ubuntu-translations
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers