keepassx isn't shown in indicator-applet

Reported by Yuriy Vidineev on 2011-03-15
166
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Wishlist
Unassigned
keepassx (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: keepassx

I want to see keepassx system tray icon (and use "Show system tray icon" setting for that). But it is unvisible.

P.S. My Ubuntu Natty is up to date
P.P.S. Sorry for my terrible English

c (lsching17) wrote :

when keepassx minimize to tray using unity desktop, tray icon is not shown

if login with Ubuntu classic interface, the tray icon can be displayed

Felix Geyer (debfx) wrote :

This is by design.
There is however a whitelist to which you could add keepassx.

Changed in keepassx (Ubuntu):
status: New → Invalid

Why, for instance, skype doesn't have this "feature" by design? I can see skype tray icon as usual (before unity).

In keepassx, if minimizing to tray icon is enabled when clicking on close or minimize buttons, the application disappears and you must kill it in terminal and reopen it. If you have unsaved passwords, you loose them.

Where can I change this whitelist?

Thank you

Yuriy Vidineev (adeptg) wrote :

Maybe keepassx can add themself to this whitelist when installing?

On Sun, May 01, 2011 at 07:15:33 (CEST), Yuriy Vidineev wrote:

> Maybe keepassx can add themself to this whitelist when installing?

hardly, as this is a per-user local setting and e.g. wouldn't affect
users created after installation of the package

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Reinhard Tartler (siretart) wrote :

The linked branch adds keepassx to the default whitelist in unity.

Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist

The problem here is a bug in keepassx that uses the deprecated systray. It should change to appindicators API (see https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationIndicators).

I'm almost sure the change to whitelist keepassx will not be approved and merged.

The currently whitelisted apps (Java, Mumble, Wine, Skype and hp-systray) is whitelisted only because the necessary changes to port to appinidicator were too big (is the case of Java and Wine) and we are out of time to do them for natty or because the software is not opensource (the case o Skype).

I don't know why the other two are on whitelist. For more info, see discussion in bug #685270 and the following comment: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/751171/comments/2.

Changed in keepassx (Ubuntu):
status: Invalid → New
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Felix Geyer (debfx) wrote :

> The problem here is a bug in keepassx that uses the deprecated systray.
Calling that a bug is a rather bold statement as unity is the only desktop environment that has removed support for classic system tray icons and at the same time does not provide a way to detect that.
I doubt that a keepassx tray icon using the new protocol would be useful on unity since it doesn't allow showing the application on left-click.

> I don't know why the other two are on whitelist.
Mumble is whitelisted because it's heavily used by Canonical and there is no StatusNotifierItem implementation for Qt yet.

Changed in keepassx (Ubuntu):
status: New → Invalid
Reinhard Tartler (siretart) wrote :

On Sun, May 01, 2011 at 21:40:54 (CEST), Marco Biscaro wrote:

> The problem here is a bug in keepassx that uses the deprecated systray.
> It should change to appindicators API (see
> https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationIndicators).

The list on the cited wiki page does not point to a library for plain
QT4 applications. How are QT4 applications such as keepassx supposed to
implement Application Indicators?

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Sorry, I didn't realize that keepassx is written using Qt.

Changed in unity (Ubuntu):
status: Invalid → New
Alex Launi (alexlauni) wrote :
Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Reopening the bug, Alex there is no binding for Qt allowing to use indicators yet and that's a valid issue in natty

Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in unity:
status: Invalid → Confirmed
importance: Undecided → Wishlist
Changed in keepassx (Ubuntu):
status: Invalid → Confirmed
tags: added: unity-notification-icon
CryptSphinx (cryptsphinx) wrote :

Identical Problem.

andypiper (andypiperuk) wrote :

I've tried manually adding 'keepassx' to the whitelist per the patch, and still don't actually seem to get the applet in the panel.

Christoph Korn (c-korn) wrote :

Try adding 'Keepassx'.
Works here.

mark (mark-carpaij) wrote :

i have a similar problem with KeepassX and systray. At first it won't pop-up. Adding it to the white-list solves the problem. Yet, when I add keepassx to my startup application, the first instance (i.e. the instance that is started automatically) does not appear in the systray. All the next instances do. Any idea how I can solve this?

Christoph Korn (c-korn) wrote :

I can confirm that the keepassx icon disappears. currently I cannot get it all.
Hopefully it will work after a restart again.

Attached you find a strace.

Changed in keepassx (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

the issue should be fixed with sni-qt on Oneiric

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Bortnyák Roland (antivirtel) wrote :

I still can confirm that issue, with the lastest versions. (Like sni-qt: 0.2.5-0ubuntu3) How can I triage it? Otherwise, when will we have it published?

Dan Kortschak (dan-kortschak) wrote :

Added 'all' to the whitelist, no keepassx as expected. Running 12.04.

Felix Geyer (debfx) wrote :

If you really want to use the keepassx tray icon on unity, start it likes this:
XDG_CURRENT_DESKTOP= keepassx

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments