[launcher] Indicator-only applications showing as open applications

Reported by jesusiniesta on 2011-01-15
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
BAMF
Undecided
Unassigned
Unity
Critical
Jason Smith
unity-2d
High
Unassigned

Bug Description

I use two apps that are only an indicator: lookit (to take screenshots) and pastie (an extended clipboard). They have no window, but when they are running they appear in the launcher: http://i.imgur.com/aKcUm.png

When using gnome-panel windows list, AWN or Docky they don't appear but in the indicator applet. With Unity (both the Qt-based version and the compiz-based one) they appear as open windows.

PD: Since it affects both compiz-based and Qt-based unity versions, I have reported this bug in both of them. Is that correct?

Florian Boucault (fboucault) wrote :

Nicely spotted jminiesta!
The bug should be marked as "Also affects project" Unity and the other reported against Unity 3D marked as duplicate of this one.

The good news is that it's likely a backend issue which means that it will be solved at the same time in both Unity 2D and 3D.

summary: - [indicator-applet] Indicator-only applications showing as open windows
+ [launcher] Indicator-only applications showing as open applications
Florian Boucault (fboucault) wrote :

Just to confirm: this is on Ubuntu Maverick?

Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
status: Confirmed → Incomplete
jesusiniesta (jesus-iniesta) wrote :

Yes, it's on Ubuntu Maverick.

I didn't realized that Unity Qt and Unity belong to the same project, what should I do with the other report?

Olivier Tilloy (osomon) wrote :

@Jesús: I marked this bug as "also affecting" Unity (which is the project for Unity-3D implemented on top of compiz). As to your other bug report, please mark it as duplicate of this one. Thanks!

Changed in unity-2d:
status: Incomplete → Confirmed
importance: Undecided → High
David Barth (dbarth) wrote :

Ultimately it's bamf that identifies and monitors applications, which explains why the two shells (or views) share the same issue.

Changed in unity:
importance: Undecided → Low
assignee: nobody → Jason Smith (jassmith)
David Barth (dbarth) wrote :

Requesting further design input, by linking to ayatana-design

jesusiniesta (jesus-iniesta) wrote :

I can't find my duplicated report in Unity. I guess it has been already marked, isn't it?

Florian Boucault (fboucault) wrote :

yes, jesusiniesta, both projects are now notified, thank you!

Neil J. Patel (njpatel) wrote :

Jason, can you please disable the indicator approver completely in bamf. We're moving to something else to do launcher customisation.

Changed in unity:
importance: Low → High
milestone: none → 3.2.16
status: New → Triaged
Neil J. Patel (njpatel) on 2011-01-27
Changed in unity:
milestone: 3.2.16 → 3.4
importance: High → Medium
importance: Medium → Critical
Changed in unity-2d:
milestone: none → 3.6
Changed in unity-2d:
milestone: 3.6 → 3.8
Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
milestone: 3.4 → 3.4.2
Neil J. Patel (njpatel) on 2011-02-09
Changed in bamf:
status: New → Fix Released
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-02-10
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-2d:
assignee: nobody → Ugo Riboni (uriboni)
Florian Boucault (fboucault) wrote :

The issue does not appear anymore in Unity 2D.

Changed in unity-2d:
status: Confirmed → Fix Committed
Ugo Riboni (uriboni) on 2011-03-09
Changed in unity-2d:
assignee: Ugo Riboni (uriboni) → nobody
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers