Launcher - Implement workspace/launcher cross interactions

Reported by John Lea on 2010-12-14
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity-2d
Medium
Unassigned
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

Implement workspace/launcher cross interactions

Description:

The application icons in the Launcher indicate the number of windows open in the current workspace. If a application has 1, 2 or 3 or more windows open in the current workspace, up to three 'pips' are displayed on the right hand side of the launcher icon. However if the application has no windows open in the current workspace but does have one or more windows open on other workspaces a triangle outline is displayed in the place of the pips.

See final design at https://chinstrap.canonical.com/~johnlea/1104launcher/launcher_window_on_other_workspace.png

The exact behavior that should result from clicking on a application icon in the launcher is application dependent; applications should be able to define custom behavior if they wish. All applications that do not explicitly define their 'on click' launcher icon behavior should fall back to the following decision tree to determine the correct action:

1. If the application has a window flagged 'Urgent' the user is directly transitioned to that window even if it is on another workspace.
2. If the application has one or more window(s) open on the current workspace, the most recently focused window is brought back into focus.
3. If the application has no windows in the current workspace, the user is transitioned to the most recently focused window from the other workspaces.
4. If no window is open in any of the workspaces a new window is opened in the current workspace.

John Lea (johnlea) on 2010-12-14
tags: added: udn-launcher udt
Changed in ayatana-design:
status: New → Fix Committed
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
John Lea (johnlea) on 2010-12-15
Changed in ayatana-design:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2010-12-15
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
milestone: none → 3.4
status: New → Confirmed
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.6
status: Confirmed → Triaged
Changed in unity-2d:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 3.6
Florian Boucault (fboucault) wrote :

Interaction part is already implemented in Unity 2D. For the indication of multiple windows see bug #676515

Changed in unity-2d:
status: Triaged → Fix Released
Changed in unity-2d:
milestone: 3.6 → 3.4
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.6
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Jason Smith (jassmith) wrote :

Unity 3D is as close as its going to get. Unfortunately due to compiz lacking support for notifying workspace switching (silly) we cant support the hollow icon or number adjustment for different viewports.

Changed in unity:
status: Triaged → Confirmed
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
David Barth (dbarth) on 2011-04-08
tags: added: too-late
Changed in unity:
milestone: 3.8.6 → backlog
John Lea (johnlea) on 2011-04-19
Changed in ayatana-design:
importance: Critical → Medium
tags: added: udo
Changed in ayatana-design:
importance: Medium → Low
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: backlog → ux-backlog-1
Jorge O. Castro (jorge) on 2011-06-06
Changed in unity:
milestone: ux-backlog-1 → backlog
assignee: Jason Smith (jassmith) → Unity Community Hackers (unity-community-hackers)
Jorge O. Castro (jorge) on 2011-06-06
tags: added: backlog
John Lea (johnlea) wrote :
John Lea (johnlea) on 2011-06-21
Changed in ayatana-design:
importance: Low → High

I was looking at this bug, what about keeping also the icon edge colored while don't coloring the icon background?
This could give more visibility to the icon that can't be considered completely "dead".

I attach an example to see how it look with this implementation.

Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → Treviño (Marco Trevisan) (3v1n0)
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Treviño (Marco Trevisan) (3v1n0)

Image updated, to see more examples.

In the proposed branch I did ( lp:~3v1n0/unity/fix-690143 ) I also added the backlight look that you can see in the above screenshots, adding more options to the Backlight Mode. Read the merge proposal for more informations.

Loris Zinsou (the-lz-himself) wrote :

Will it be possible to launch and application by dragging it from the launcher to a workspace in the worspace switcher view ? (like in Unity with mutter on Ubuntu 10.10 ?)

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-09-09
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
milestone: backlog → none
John Lea (johnlea) on 2011-09-30
tags: added: reviewedbydesigno
removed: udo udt
Changed in unity:
status: Fix Released → In Progress
milestone: none → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-01-20
Changed in unity (Ubuntu):
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Eddie Dunn (eddie-dunn) wrote :

Currently, there is no way to tell from the launcher icon that I have windows of an application open in both workspace 1 and workspace 2. This can prove to be very annoying. Consider this use case:

I open Firefox on workspace 1. I go to workspace 2 and open another Firefox window, and then Nautilkus. I fullscreen the Nautilus window.

If I go back to workspace 1 there is no way for me to easily go to the Firefox window on workspace 2. There isn't even a good way for me to tell that I have two Firefox windows open, because on workspace 1 the Firefox icon will only have one "pip" next to it. Even if I activate Expo I won't see the Firefox window on workspace 2 since it is hidden by the maximized Nautilus window.

There must be a better solution for this. Perhaps add a transparent pip next to the opaque one, to signify that the application also has a window on another workspace?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers