[regression] Dash - 'More suggestions' icons in App Lens are too large

Reported by John Lea on 2012-09-18
52
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Michal Hruby
6.0
High
Michal Hruby
libunity
Medium
Michal Hruby
unity-lens-applications
Medium
Michal Hruby
6.0
Medium
Michal Hruby
libunity (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]

 * Applications icons size is often only 64x64px, and Unity scales these icons to 96x96 in the "More suggestions" category, this leads to visible pixelization of the icons.

[Test Case]

 * Open applications lens (Super+A), observe that some icons look pixelated before the fix.
 * After applying the fix, the size of the icons in the "More suggestions" category should be limited to 64px.
 * Note that the ribbon with the price should stay the same size as before applying the fix (as if for 96px icon)

[Regression Potential]

- no icons appear in the "More suggestions" category (only an icon showing white sheet of paper)
- icons in music/video lens' "More suggestions" end up being limited to 64x64px

====================
Original description:

The icons in the App Lens and Dash Home for software that is 'available to download from the software centre' are too large.

The icons for applications in the Dash Home and the Apps Lens need to be the same size regardless of whether the app is already installed or whether it is available to download from the Software Centre. However the icons for magazines that are available from the Software Centre can be larger, e.g. the same size as the album covers, image thumbnails, etc...

Note that for 12.10 'price ribbon' should not be overlaid on top of the 'More suggestion' icons in the App Lens.

John Lea (johnlea) on 2012-09-18
tags: added: dashm udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → backlog
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in ayatana-design:
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2012-09-18
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.10
Changed in libunity:
milestone: none → 6.8.0
Omer Akram (om26er) on 2012-09-26
summary: - Dash - the icons in the App Lens for software that is 'available to
- download from the software centre' are too large
+ Dash - 'More suggestions' icons are too large
Changed in libunity:
status: New → Fix Committed
Changed in libunity (Ubuntu):
status: New → Fix Committed
Michal Hruby (mhr3) on 2012-09-26
Changed in libunity:
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → Medium
Changed in unity-lens-applications:
status: New → Fix Committed
Michal Hruby (mhr3) on 2012-09-28
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)

It's not only the icons in the "More..." section of the Dash, but also application icons. In my case, Unison, Guake Terminal / Guake Preferences, MeMaker, Xdiagnose, and Xmind are all WAY to big...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2012-10-03
tags: added: dashs
Changed in libunity:
status: Fix Committed → Fix Released
Alan Pope ㋛ (popey) on 2012-10-04
summary: - Dash - 'More suggestions' icons are too large
+ [UIFe] Dash - 'More suggestions' icons are too large

This bug was fixed in the package unity-lens-applications - 6.8.0-0ubuntu1

---------------
unity-lens-applications (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Use icon_url when displaying preview of an installable app; use
      find_pkg_icon instead of find_app_install_icon_path, as it also uses
      icons from ~/.cache/software-center/icons (LP: #1054085)
    - Remove unneeded gconf dep
    - Use size-hint for items in "More suggestions" category (LP: #1052513)
    - Disable collapsing by key (desktop file) when querying for specific
      packages (LP: #1057565)
    - Improve Utils.preprocess_text (LP: #1056743)
  * Bump libunity-dev dependency

  [ Didier Roche ]
  * Remove gconf build-dep as removed upstream.
 -- Didier Roche <email address hidden> Thu, 04 Oct 2012 16:22:31 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 6.8.0-0ubuntu1

---------------
libunity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * Install the new schema file
  * add intltool as a build-dep

  [ Dmitry Shachnev ]
  * Make libunity9 depend on unity-common >= 6.0.0-0ubuntu3 (LP: #1055019).

  [ Timo Jyrinki ]
  * New upstream release.
    - Converts white space to underscores when trying to export the mpris
      bus (LP: #1031933)
    - Added size hint to AnnotatedIcon (LP: #1052513)
    - Add remote search disabling option support to libunity for lenses to
      consume it (LP: #1054746)
    - Make sender wrap the title property and set the subtitle in the
      constructor. (LP: #1058198)
    - Allow null preview argument in preview_ready signal by declaring it
      with "?" (LP: #1060281)
  * debian/libunity9.symbols:
    - update symbols to include the new APIs
 -- Timo Jyrinki <email address hidden> Wed, 03 Oct 2012 09:22:42 +0300

Changed in libunity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-10-05
summary: - [UIFe] Dash - 'More suggestions' icons are too large
+ [UIFe] Dash - 'More suggestions' icons in App Lens are too large
Omer Akram (om26er) on 2012-10-05
summary: - [UIFe] Dash - 'More suggestions' icons in App Lens are too large
+ [UIFe][regression] Dash - 'More suggestions' icons in App Lens are too
+ large
John Lea (johnlea) on 2012-10-05
description: updated

Forgive me if I'm mistaken here, but this seems to have come back inside the applications lens. Seems fine for video for example. But application icons are too big and fuzzy.

Changed in unity-lens-applications (Ubuntu):
status: Fix Released → Confirmed
Rainer Rohde (rainer-rohde) wrote :

This issue still persists, in both the suggest app and the regular app lense.

Omer Akram (om26er) wrote :

I think the 'Unity' fix didn't land for some reason.

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Triaged → Fix Committed
Scott Kitterman (kitterman) wrote :

If further changes are needed to address this issue, they will need to be done post-release.

Changed in unity (Ubuntu):
milestone: ubuntu-12.10 → quantal-updates
Michal Hruby (mhr3) wrote :

Removing the UIFe, as we agreed with design to minimize the changes, and just use smaller icons in the category to prevent the pixelation.

summary: - [UIFe][regression] Dash - 'More suggestions' icons in App Lens are too
- large
+ [regression] Dash - 'More suggestions' icons in App Lens are too large
Michal Hruby (mhr3) on 2012-10-12
Changed in unity:
status: Fix Committed → In Progress
milestone: backlog → 7.0.0
status: In Progress → Fix Committed
Changed in unity-lens-applications:
status: Fix Released → Fix Committed
status: Fix Committed → In Progress
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → Medium
Michal Hruby (mhr3) on 2012-10-16
description: updated
Michal Hruby (mhr3) on 2012-10-16
Changed in unity-lens-applications:
milestone: none → 7.0.0
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → In Progress
description: updated
Alan Pope ㋛ (popey) on 2012-10-17
Changed in unity-lens-applications (Ubuntu Quantal):
status: Fix Released → Fix Committed
Scott Kitterman (kitterman) wrote :

This all needs to land post-release now, so unsubscribing the release team.

Changed in unity-lens-applications (Ubuntu Quantal):
milestone: none → quantal-updates

Hello John, or anyone else affected,

Accepted unity-lens-applications into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-applications/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Rainer Rohde (rainer-rohde) wrote :

For me, the issue still persists. My Guake and Xmind icons in the application lense are still huge, while the "More Suggestions" icons are also huge.

Chris Halse Rogers (raof) wrote :

Hello John, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

The fix in app lenses required the unity update as well, now in proposed. Seems fixed now.

tags: added: verification-done
removed: verification-needed
Rainer Rohde (rainer-rohde) wrote :

This is still not fixed, even after this morning's update... see screenshot attached. This bug extends towards the application lense as well, not only the "More suggestions" lense (which seems to have improved).

Kyle Brooks (brookskd) on 2012-10-26
information type: Public → Public Security
information type: Public Security → Public
Chris Halse Rogers (raof) wrote :

Hello John, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Rainer Rohde (rainer-rohde) wrote :

This issue still persists -- at least for the Application lense. See screenshot attached.

Steve Langasek (vorlon) wrote :

I have installed the unity and unity-lens-applications binary packages from proposed. After restarting compiz, I can confirm that the icon for e.g. Guake *is* smaller. So I think this is fixed. Rainer, are you sure you restarted compiz after installing the new version of unity?

tags: added: verification-done
removed: verification-needed
Rainer Rohde (rainer-rohde) wrote :

Steve,

I have since restarted my laptop multiple times; I am wondering whether I have the correct version installed. I do have the Quantal Proposed repo checked in Softare Sources, and I assume it would have been installed automatically without further ado.

unity 6.10.0-0ubuntu2
unity-common 6.10.0-0ubuntu2
unity-lens-applications 6.10.0-0ubuntu1
unity-services 6.10.0-0ubuntu2

Needless to say, my Guake, Unison, Xmind, and Indicator Weather icons are still larger than the rest.

Anything else I need to do?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.10.0-0ubuntu1

---------------
unity-lens-applications (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Dash - 'More suggestions' icons in App Lens are too large (LP: #1052513)
    - The look of price on 'Buy' button in the preview is inconsistent with
      other lenses (LP: #1061630)
    - Lots of IO during startup (LP: #1066816)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 16 Oct 2012 13:47:18 +0200

Changed in unity-lens-applications (Ubuntu):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.10.0-0ubuntu1

---------------
unity-lens-applications (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Dash - 'More suggestions' icons in App Lens are too large (LP: #1052513)
    - The look of price on 'Buy' button in the preview is inconsistent with
      other lenses (LP: #1061630)
    - Lots of IO during startup (LP: #1066816)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 16 Oct 2012 13:47:18 +0200

Changed in unity-lens-applications (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu2

---------------
unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 18:00:00 +0100

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu3

---------------
unity (6.10.0-0ubuntu3) raring; urgency=low

  * Upload to raring

unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Didier Roche <email address hidden> Fri, 09 Nov 2012 08:06:47 +0100

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Rainer Rohde (rainer-rohde) wrote :

I am on unity-lens-applications 6.10.0-0ubuntu1, with Quantal Proposed enabled in Software Sources. I still see large application icons as of today.

In my case, these icons are enlarged within the application lens:

Unison
Weather Indicator
Guake
Xmind
XDiagnose
XML Copy Editor

Shouldn't by now unity-lens-applications 6.10.0-0ubuntu2 be installed, which should take care of this issue?

Jeremy Bicha (jbicha) wrote :

Rainer, this bug was about all icons in More Suggestions in the Apps lens being too large. It's a different bug if specific apps have icons that are too large.

Rainer Rohde (rainer-rohde) wrote :

Thanks Jeremy -- I'll file a new bug report.

Stephen M. Webb (bregma) on 2013-02-17
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers