[FFe] Restore "Ubuntu Medium" weights in Ubuntu's binary .deb

Reported by John Lea on 2012-09-10
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
ubuntu-font-family-sources (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

This is a Feature Freeze Exception for Quantal for the 'ttf-ubuntu-font-family' binary package, which is built from the source package 'ubuntu-font-family-sources'. The only change would be to restore two '.ttf' font files that were not shipped for the final release of Precise, but which were otherwise continually present in the source package all along. The two files are the following and together take up 691kB of installed disk space (~337kB compressed on the CD):

  /usr/share/fonts/truetype/ubuntu-font-family/Ubuntu-M.ttf (Ubuntu Medium)
  /usr/share/fonts/truetype/ubuntu-font-family/Ubuntu-MI.ttf (Ubuntu Medium Italic)

As it stands Ubuntu's Quantal binary package is deficient and contains only a subset of the files that have otherwise been shipped. This is neither a new upstream version, nor a bugfix-only release, nor a brand new package, but a local distro packaging change.

Benefits:
 * Shipping complete package, as is expected by our users, particular those working in DTP
 * Enabling theme- and application-developers to be more creative in producing innovative human-optimised interfaces for the default software set shipping in Ubuntu
 * Fix version number to not override complete builds of the .deb with this copy.

Impacts:
 * These by itself does not cause a visible change in the default Ubuntu interface, ie those that are likely to be covered by the Ubuntu Doc Team's screenshots. It will generally cause a one-, or two-line addition to application font selection menus.
 * ~337kB of CD space.
 * Impacts of other software; For completeness, it should be noted there are broken applications/toolkits out there: Some tools using toolkits and applications make incorrect assumptions that the number of weights in a font where there are more than just the "simple four" of Regular/Italic/Bold/Bold-Italic. These applications already behave sub-optimally in the case of other advanced multi-weight fonts shipped in Ubuntu, such as 'fonts-linuxlibertine'; and this is not the fault of the upstream Ubuntu Font Family offering. Those applications (including Inkscape, Unity-2D in the case of Ubuntu 12.04 LTS, will remain broken until they and their underlying are fixed.

The proposed one-line diff in the attached branch consists of a single-line change to 'debian/*.install':

  +Ubuntu-M*.ttf /usr/share/fonts/truetype/ubuntu-font-family

These two files were dropped prior to the Ubuntu 12.04 LTS release for the benefit of Unity-2D, which is no longer shipped as default. Additionally it was uploaded with version number missing '~medium' thus giving no indication that the package shipped by Ubuntu is incomplete, and additionally causing the version in the distro to override otherwise complete builds of the .deb in PPAs. This is oversight that it was not reloaded in complete form on the first day of the Q cycle opening.

John Lea (johnlea) on 2012-09-10
tags: added: dashm udp
Changed in ayatana-design:
importance: Undecided → Critical
assignee: nobody → John Lea (johnlea)
status: New → Fix Committed
Changed in ubuntu-font-family:
status: New → Confirmed
Paul Sladen (sladen) wrote :

ubuntu-font-family-sources (0.80-0ubuntu2) precise; urgency=low

  * Don't ship Ubuntu Medium ("Ubuntu Light" "Bold") because
    of issues with the font/toolkit stacks on Ubuntu not working.
    Workaround for (LP: #744812).

 -- Florian Boucault <email address hidden> Wed, 21 Mar 2012 11:02:09 +0000

I think this should be deferred for the next cycle. UI Freeze is on Quantal and re-adding Medium will regress bug 744812, breaking Qt apps like Ubuntu One.

On 12/09/12 10:18, Adolfo Jayme Barrientos wrote:
> I think this should be deferred for the next cycle. UI Freeze is on
> Quantal and re-adding Medium will regress bug 744812, breaking Qt apps
> like Ubuntu One.

Unless we add it, I don't believe those apps will ever get fixed.

Please add it and fix the bugs.

Mark

(Note: Moving to the distro; Everything is there in the source package; it was uploaded with two files in the binary on the basis that Unity-2D's toolkit reacted quite badly. Those applications that pull matching service via fontconfig and also get upset at more than four weights per family in every other advanced typeface)

AFAICR, this QAed fine for Unity-3D prior to 12.04 LTS; and so I wouldn't expect anything else this time. If somebody can QA this with engineering builds (of Unity) I'd like to see the full build go back into the archive. It's an oversight on my part that I didn't back out the makefile comments and upload on the first day of Q opening.

It's not really the case of adding anything that, but restoring the normality of having the full build.

affects: ubuntu-font-family → ubuntu-font-family-sources (Ubuntu)
Changed in ubuntu-font-family-sources (Ubuntu):
importance: Undecided → Wishlist

Re: Popey et al; I'm happy to prepare and upload, but I need help with the QA from the Unity side (I'm travelling and don't have a Q-latest machine with me).

Alan Pope ㋛ (popey) wrote :

I tried the package sil2100 made which has the medium font in. The dash itself looks no different with the addition of the font. I can help you with further testing.

We need the paperwork (FFE/UIE) for this doing too.

Alan Pope ㋛ (popey) wrote :

dash without the medium font installed

Alan Pope ㋛ (popey) wrote :

dash with medium font installed...

Paul/John: Is there additional work required outside the installation of the font (and identifying qt/fontconfig related bugs) to enable the actual use of this font in Unity?

Paul Sladen (sladen) on 2012-09-14
summary: - Add "ubuntu medium" font to Ubuntu
+ [FFe] Restore "Ubuntu Medium" weights in Ubuntu's binary .deb
Paul Sladen (sladen) wrote :

Raised on #ubuntu-doc, requesting comment + subscribed:

  http://irclogs.ubuntu.com/2012/09/14/%23ubuntu-doc.html

Benjamin Kerensa (bkerensa) wrote :

On behalf of doc-team we are reviewing this and will provide a response shortly.

Paul Sladen (sladen) on 2012-09-14
description: updated
Changed in ubuntu-font-family-sources (Ubuntu):
status: Confirmed → New
John Lea (johnlea) wrote :

@popey; the reason that the Dash currently looks no different with the Medium font installed is that we need to font installed before we change the font weights in the dash so that we can test. So once the font is in we will update the relevant Dash elements.

Paul Sladen (sladen) wrote :

Thanks for the confirmation John, that the Screenshots are the same and this proposed patch does *not* by itself change anything visually in the default Unity experience. I wouldn't wish the analysis and fixing of this particular distro-packaging oversight to get side-tracked.

I think the second sentence might fall "Enabling theme- and application-developers to be more creative in producing innovative human-optimised interfaces for the default software set shipping in Ubuntu"! That would a separate issue, which can be proposed subsequently by the Unity team, based on its own merits, and with the relevant UIF applications made to the doc-team.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-font-family-sources (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

FFe request requires "New" before subscribing 'ubuntu-release'.

Changed in ubuntu-font-family-sources (Ubuntu):
status: Confirmed → New
Jeremy Bicha (jbicha) wrote :

+1 from the Docs Team for adding the additional font weight.

On the other hand, I think it's too late to be tweaking the fonts used in the Dash. Documentation string freeze is still scheduled for next Thursday which means we must start working on screenshots this weekend.

Alan Pope ㋛ (popey) on 2012-09-17
Changed in ubuntu-font-family-sources (Ubuntu):
importance: Wishlist → High
Iain Lane (laney) wrote :

It seems this was approved in comment #3.

Please go ahead.

Changed in ubuntu-font-family-sources (Ubuntu):
status: New → Triaged
Paul Sladen (sladen) wrote :

Laney: ta, thanks for that.

Felix Geyer (debfx) wrote :

Are there concrete plans on how to fix Qt to deal with this change?

Scott Kitterman (kitterman) wrote :

Please don't land this until the Qt issues are addressed.

John Lea (johnlea) on 2012-09-19
Changed in ayatana-design:
importance: Critical → High
Kate Stewart (kate.stewart) wrote :

Is there a good scope of impact on what we'll be breaking with this known? I've seen the comments in bug 744812 - is that the extent of it? or has someone done further testing with it?

I don't know if it's well characterized or not. Unfortunately, I have limited connectivity today and can't really look into it.

Dmitry Shachnev (mitya57) wrote :

What was happening in earlier pre-releases (that shipped Ubuntu medium) was that all Qt/KDE apps had a bold font (like here: https://launchpadlibrarian.net/67192564/qt-font-fail.png, it affects U1 control panel for example).

This is not the only issue as people also reported problems with LibreOffice, for example.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-font-family-sources - 0.80-0ubuntu3+console

---------------
ubuntu-font-family-sources (0.80-0ubuntu3+console) quantal; urgency=low

  * Restore shipping of Medium and Medium Italic for the binary package.
    (LP: #1048600)
 -- Paul Sladen <email address hidden> Fri, 14 Sep 2012 12:10:00 +0300

Changed in ubuntu-font-family-sources (Ubuntu):
status: Triaged → Fix Released
Scott Kitterman (kitterman) wrote :

So we don't care about regressions?

Iain Lane (laney) wrote :

I certainly do. I'll advocate for the revert if this causes insurmountable problems (it's a simple one-line packaging change to not install the file).

Iain Lane (laney) wrote :

It makes the U1 control panel use a bold font. (I believe this is the same as was observed before)

Lucazade (lucazade) wrote :

all kde apps now use bold fonts :S

Iain Lane (laney) wrote :

20/09 14:56:47 <ScottK> FYI, thanks to the recent "improvements" in the Ubuntu fonts, Kubuntu is dropping them for Quantal.

Stéphane Graber (stgraber) wrote :

The release team is now considering reverting this change unless the related bugs (u1/kde) are fixed before we start spinning the first beta2 candidates.

Please debug and fix the known issues or find people who can. Re-opening the bug for now.

Changed in ubuntu-font-family-sources (Ubuntu):
status: Fix Released → Triaged
Scott Kitterman (kitterman) wrote :

It's a Qt issue, not U1/KDE.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-font-family-sources - 0.80-0ubuntu4

---------------
ubuntu-font-family-sources (0.80-0ubuntu4) quantal; urgency=low

  * Revert (yes, again) the shipping of Medium. It causes too many bugs this
    late in the cycle. We'll flop once more at the very start of R cycle. (LP:
    #1048600)
 -- Iain Lane <email address hidden> Fri, 21 Sep 2012 12:51:56 +0100

Changed in ubuntu-font-family-sources (Ubuntu):
status: Triaged → Fix Released
Kate Stewart (kate.stewart) wrote :

Mark this as open, due to revert.

Changed in ubuntu-font-family-sources (Ubuntu Quantal):
status: Fix Released → Triaged
Michał Sawicz (saviq) wrote :

Hey,

I've put info about a possible workaround for Qt and packages for testing in the related bug:
https://bugs.launchpad.net/ubuntu-font-family/+bug/744812/comments/53

The patch itself is in the next comment:
https://bugs.launchpad.net/ubuntu-font-family/+bug/744812/comments/54

Changed in ubuntu-font-family-sources (Ubuntu Quantal):
status: Triaged → Won't Fix
Sebastien Bacher (seb128) wrote :

Reopening the quantal component, the sabdfl suggested we should try harder to get that in this cycle if possible so we will do that...

Changed in ubuntu-font-family-sources (Ubuntu Quantal):
status: Won't Fix → Triaged
milestone: none → ubuntu-12.10
Scott Kitterman (kitterman) wrote :

sabdfl'ing is only relevant on the record. Mark told me to get this in" is not sufficient.

Changed in ubuntu-font-family-sources (Ubuntu Quantal):
status: Triaged → Won't Fix

Scott, here it is for the record.

The light and medium font are our standard font for all content. Medium
has been bumped from the release multiple times, driving design folk
around the bend because software folk don't address the bug early in the
cycle, then say we're too late. We're not too late. Please include the
medium weight, and crystallize out the relevant software fix from folk
who care about the software.

Mark

Changed in ubuntu-font-family-sources (Ubuntu Quantal):
status: Won't Fix → Triaged
Mark Shuttleworth (sabdfl) wrote :

Thanks, Scott.

Scott Kitterman (kitterman) wrote :

Thanks for following up in the bug. FTR, the fix for Qt is in the archive and
we'll test it today to verify it works with the medium weight. I'm not sure
what else needs fixing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-font-family-sources - 0.80-0ubuntu5

---------------
ubuntu-font-family-sources (0.80-0ubuntu5) quantal; urgency=low

  [ Timo Jyrinki ]
  * Add modified Ubuntu-M.ttf binary (LP: #1054204)
  * Restore installing Ubuntu-M* (LP: #1048600)

  [ Iain Lane ]
  * Modify Ubuntu-MI.ttf in the same way (set "Family Name"), otherwise Ubuntu
    Medium Italic gets selected for Ubuntu Light Italic in LO.
 -- Iain Lane <email address hidden> Sat, 06 Oct 2012 13:20:49 +0100

Changed in ubuntu-font-family-sources (Ubuntu Quantal):
status: Triaged → Fix Released
Mark Shuttleworth (sabdfl) wrote :

There's apparently an issue in FontConfig which affects LibreOffice. I'm
sure it will get settled in the RC period.

Iain Lane (laney) on 2012-10-06
no longer affects: ubuntu-font-family-sources (Ubuntu R-series)
Dmitry Shachnev (mitya57) wrote :

@Mark: The LibreOffice issues should have been fixed in the latest update (0.80-0ubuntu5), see bug 1054204.

Paul Sladen (sladen) wrote :

@Laney & Timo: what is the plan for R if shipping with the diff as below? To (a) revert it after release, (b) hoping to ship the metadata-renamed .ttfs in perpetuity.

@Dmitry: for clarity, the change appears to have been made by adjusting the .ttfs rather than source code. (The are arguments both for and against this which I'd like to stay out of)

sfddiff --exact {/usr/share/fonts/truetype/ubuntu-font-family/,}Ubuntu-M.ttf

Names
 The family name differs. In /usr/share/fonts/truetype/ubuntu-font-family/Ubuntu-M.ttf it is (Ubuntu Light) while in /home/sladen/tmp/asdf/latest/Ubuntu-M.ttf it is (Ubuntu Medium)

sfddiff --exact {/usr/share/fonts/truetype/ubuntu-font-family/,}Ubuntu-MI.ttf

Names
 The family name differs. In /usr/share/fonts/truetype/ubuntu-font-family/Ubuntu-MI.ttf it is (Ubuntu Light) while in /home/sladen/tmp/asdf/latest/Ubuntu-MI.ttf it is (Ubuntu Medium)

Even if I'm not back, my offer stands (as per Qt), in that if somebody knowing the LO codebase can debug and find me at the appropriate set of functions/files I can try to offer up a patch.

Omer Akram (om26er) wrote :

re: comment #43: Subscribed Björn who is the maintainer of LO in Ubuntu and might be able to help

Mark Shuttleworth (sabdfl) wrote :

The preferred result is that the "bold of Ubuntu Light is Ubuntu
Medium", can you confirm this is the case in Qt apps now?

Jonathan Riddell (jr) wrote :

Qt lists Light as a choice under font style for the Ubuntu font (along with light, regular, medium, bold, italic, italic bold) rather than as a separate font. So it doesn't let you do "bold of Ubuntu Light".

Mark Shuttleworth (sabdfl) wrote :

On 08/10/12 17:53, Jonathan Riddell wrote:
> Qt lists Light as a choice under font style for the Ubuntu font (along
> with light, regular, medium, bold, italic, italic bold) rather than as a
> separate font. So it doesn't let you do "bold of Ubuntu Light".

OK. That's the right story for apps which support multiple weights of
the same face, like Scribus, and is great. We were hoping that simpler
apps, word processors etc, would present them as Ubuntu / Ubuntu Light,
two faces with the usual bold / italic / bold-italic options.

Mark

John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers