[UIFE]Dash - Selecting any of the Search Filters in the App Lens should show all matching apps underneath the 'Apps available to download' category header, even if the user has not typed a search term

Bug #1045762 reported by John Lea on 2012-09-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Invalid
High
Unassigned
unity-lens-applications
High
Paweł Stołowski
unity (Ubuntu)
High
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned

Bug Description

Selecting any of the Search Filters in the App Lens should show all matching apps underneath the 'Apps available to download' category header, even if the user has not typed a search term.

Currently if the user has not typed any search term, only a few apps are shown in this category after the user selects one or more search filters and this is wrong. All apps in the software centre that match the selected filtering should be shown.

Related branches

John Lea (johnlea) on 2012-09-04
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Changed in ayatana-design:
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
tags: added: dashm udp
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity-lens-applications:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → Pawel Stolowski (stolowski)
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) wrote :

UIFE ok'ed by design

summary: - Dash - Selecting any of the Search Filters in the App Lens should show
- all matching apps underneath the 'Apps available to download' category
- header, even if the user has not typed a search term
+ [UIFE]Dash - Selecting any of the Search Filters in the App Lens should
+ show all matching apps underneath the 'Apps available to download'
+ category header, even if the user has not typed a search term
John Lea (johnlea) on 2012-09-18
Changed in ayatana-design:
status: Fix Committed → Invalid
Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in unity-lens-applications (Ubuntu):
status: New → Invalid
Changed in unity-lens-applications:
status: In Progress → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.6.0-0ubuntu1

---------------
unity-lens-applications (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Home Lens requires binary names to be provided with results
      (LP: #1043775)
    - Dash - App Lens ratings are not working (LP: #1039789)
    - Dash - When an application is installed direct from a Dash Preview, the
      Software Centre should not be launched and the Software Centre window
      should not be opened (LP: #1045330)
    - [FFE][UIFE]Dash - Finesse the placement, movement and behaviour of the
      12.10 Dash (LP: #1049593)
    - Icons are missing in the previews for apps available for download
      (LP: #1050344)
    - Don't show 'Uninstall' button for critical apps (i.e. the ones that
      depend on ubuntu-desktop). (LP: #1047315)
    - List 10 'What's new' apps and the 12 'Top Rated' apps from Software
      Center in 'Apps Available for Download' before user performs any search
      if no filters are active. List 100 top rated apps according to active
      filters if search string is empty. (LP: #1045762)
    - Implemented price ribbons for Application Lens search results.
      (LP: #1049593)

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest libunity
 -- Didier Roche <email address hidden> Thu, 20 Sep 2012 16:17:10 +0200

Changed in unity-lens-applications (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers