Single click inside the Workspace Switcher should always return to a workspace

Bug #1033531 reported by Christian Giordano on 2012-08-06
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
Christian Giordano
Compiz
Wishlist
Renato Araujo Oliveira Filho
compiz (Ubuntu)
Wishlist
Unassigned

Bug Description

The primary function of the workspace switcher is to switch workspaces.
As a secondary function allow users to drag and drop windows from one workspace to another.

-------------------
Desired resolution:

1. Any Click (not drag) will exit the workspace switcher (this effectively maps all current double click actions to a single click instead)
2. Clicking on an app in the launcher while in the workspace switcher will take you to that app.
3. Press and drag to move a window (app) from one workspace to another.

The focused state of the workspace (when one is centered and expanded over the others) is effectively deprecated.

Note: This is a short term fix until "The Spread" (see http://design.canonical.com/the-toolkit/unity-task-switching/ ) is implemented. This bug will become invalid when work on the workspace part of this project starts.

Related branches

description: updated
summary: - Single click on the Workspace Switcher should always return to a
+ Single click inside the Workspace Switcher should always return to a
workspace
John Lea (johnlea) on 2012-08-06
description: updated
Changed in ayatana-design:
assignee: nobody → Christian Giordano (nuthinking)
tags: added: udp
Changed in ayatana-design:
importance: Undecided → Medium
importance: Medium → Low
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in ayatana-design:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → backlog
status: New → Triaged
assignee: nobody → Ugo Riboni (uriboni)
Changed in unity (Ubuntu):
assignee: nobody → Ugo Riboni (uriboni)
Marc Deslauriers (mdeslaur) wrote :

Possible dupe of #689731

Omer Akram (om26er) on 2012-08-06
affects: unity (Ubuntu) → compiz (Ubuntu)
affects: compiz-core → compiz
Changed in compiz:
importance: Undecided → Low
status: New → Triaged
assignee: nobody → Ugo Riboni (uriboni)
John Lea (johnlea) on 2012-08-06
description: updated
John Lea (johnlea) on 2012-08-07
Changed in compiz:
assignee: Ugo Riboni (uriboni) → nobody
Changed in unity:
assignee: Ugo Riboni (uriboni) → nobody
Changed in compiz (Ubuntu):
assignee: Ugo Riboni (uriboni) → nobody
Sam Spilsbury (smspillaz) wrote :

The code handling this can be found in the expo plugin. Just track how far the currently dragged window was dragged and if its less than a couple of pixels then terminate the workspace switcher.

Daniel van Vugt (vanvugt) wrote :

Sounds awesomely simple.

Hang on, this is a duplicate, I'm sure of it...

Changed in compiz:
milestone: none → 0.9.8.0
Daniel van Vugt (vanvugt) wrote :

Sorry, ignore comment #4.

Sam's suggestion in comment #2 should be used to fix this bug and bug 1011084.

no longer affects: unity
Changed in compiz:
status: Triaged → In Progress
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
importance: Low → Wishlist
Changed in compiz (Ubuntu):
importance: Low → Wishlist
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3307

Launchpad Janitor (janitor) wrote :
Download full text (7.9 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3319-0ubuntu1

---------------
compiz (1:0.9.8+bzr3319-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/patches/ubuntu-config.patch:
    - refresh with latest trunk
  * debian/*docs:
    - remove the TODO copy now removed upstream
  * debian/compiz-plugins.install:
    - install stackswitch, trip plugins
  * debian/rules, debian/control:
    - remove the compiz gnome-control-center key sedding through metacity.
      Compiz now directly ships them.
    - we do not need metacity-common anymore as a build-dep then
  * debian/compiz-gnome.migrations, debian/control:
    - build-dep on dh-migrations and ship gconf -> gsettings migration file

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix Compiz crash in movementWindowOnScreen (LP: #1015151)
    - Start window decorator when decor plugin starts (LP: #1014461)
    - Fixed: Crash in compiz::wall::movementWindowOnScreen (LP: #1015151)
    - Don't waste memory leaving /bin/sh running (LP: #1015422)
    - Add reliable detection of the compiz bin directory (LP: #1015898)
    - Check if the window would actually paint before painting the shadow,
      since it is possible that another plugin could be inhibiting paint of
      the dock window. (LP: #1012956)
    - Don't insert the window into the server list above the window it was
      created above. (LP: #1008020) (LP: #886605)
    - makes compiz enhanced zoom and show mouse plugins considerably
      smoother to use (LP: #930783)
    - Don't set decoration contexts on undecorated windows, since that
      might be read later and code will assume the window is decorated when
      it isn't. (LP: #1015593)
    - Fix potentially unterminated string leading to an uninitialized memory
      read (LP: #1018302)
    - Lift the 31/32 character restriction on key names that was causing so
      many warnings. It's now 1024 characters according to glib. (LP: #1018730)
    - Don't print the result of BUILD_DEB. It prevents ccsm et al from
      installing. (LP: #1018916)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Do the initial work to get libcompizconfig under test. (LP: #990690)
    - Add support for initiating window picker in other than nomal mode. For
      now added only the additional 'All windows' picker (LP: #933776)
      (LP: #955035)
    - Fixes (LP: #1018602) : An invalid read when using g_variant_iter_loop.
    - Don't allow unbinds of textures kept around for animations in any case,
      not just resizing. (LP: #1016366)
    - Wait for the server to finish processing requests before doing a bind
      (LP: #1016367)
    - Using the next/previous bindings the wall plugin didn't calculate
      correctly the next workspace when it reaches the begin or the end of a
      row of workspaces, so it didn't jump to the n...

Read more...

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-09-19
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers