Awn

Comment 11 for bug 160375

Julien Lavergne (gilir) wrote :

In my packager point of view, I don't think installing python applets with the current system is a good way :
- you need to install them to /usr/lib or /usr/local/lib, not good for no compile thinks (should go to /usr/share)
- you can't uninstall them, or edit them because there are installed with root rights
- python don't need compilation like C, so don't need the same build system that C or Vala applets

The perfect way to go for me :
- add possibility to download and install python applet with awn-manager, like a deb repo but for awn applets.
- add depends somewhere (maybe the .desktop) and use policykit/packagekit or other tool to install missing depends.

For short term, packagers need to manage this depends. Others are people who test or develop AWN. So point to the official docs is not a bad idea :) And now, there is a warning in compilation for those depends. Or if it's not, it should be added.