Pandora applet reports a URL Error and reports a traceback

Bug #339069 reported by angeleum on 2009-03-07
4
Affects Status Importance Assigned to Milestone
Awn Extras
Low
Andrew Starr-Bochicchio

Bug Description

Running awn extras and Pandora applet under Ubuntu 8.04 with Compiz Fusion on Dell 4500, 1-GB RAM
nVidea XServer v 169.12, GEForce FX5500

Traceback (most recent call last):
  File "/build/buildd/awn-extras-applets-trunk-0.3.3~bzr1128-hardy1/debian/awn-extras-applets-trunk//usr/lib/python2.5/site-packages/awn/extras/awnlib.py", line 1537, in init_start
  File "/usr/share/avant-window-navigator/applets/pandora/pandora.py", line 87, in __init__
    pandurl=self.returnurl()
  File "/usr/share/avant-window-navigator/applets/pandora/pandora.py", line 123, in returnurl
    page=urllib2.urlopen('http://www.pandora.com/?cmd=mini')
  File "/usr/lib/python2.5/urllib2.py", line 124, in urlopen
    return _opener.open(url, data)
  File "/usr/lib/python2.5/urllib2.py", line 381, in open
    response = self._open(req, data)
  File "/usr/lib/python2.5/urllib2.py", line 399, in _open
    '_open', req)
  File "/usr/lib/python2.5/urllib2.py", line 360, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.5/urllib2.py", line 1107, in http_open
    return self.do_open(httplib.HTTPConnection, req)
  File "/usr/lib/python2.5/urllib2.py", line 1082, in do_open
    raise URLError(err)
URLError: <urlopen error (-2, 'Name or service not known')>

Thanks for the report. This has already been fixed in trunk. The fix hasn't hit the PPA yet. If you'd like to fix this locally until an update rolls out, open the following file with a text editor:

/usr/share/avant-window-navigator/applets/pandora/pandora.py

Change the the URL line to:

 https://www.pandora.com:443/radio/tuner_8_8_0_0_pandora_mini.swf

Sorry, on second look I realize that the fix was issues in rev 1128, which you have.

Could you please open gconf-editor and see if you have a configuration key under:

 apps>avant-window-navigator>applets>pandora

If so what is it?

Also if you run avant-window-navigator from the terminal, is there any other output?

I can not reproduce this here.

Changed in awn-extras:
status: New → Incomplete

Alright, I was just able to reproduce this. It happened for me on log in to the gnome session. This seems to happen when awn starts before there is a network connection. Restarting awn resolved the issue.

 We should find a way for this to happen more gracefully if there is no connection. Also, it shouldn't be accessing the page until the applet is clicked.

Changed in awn-extras:
importance: Undecided → Low
status: Incomplete → Confirmed
Download full text (7.4 KiB)

Hi Andrew,

Sorry for a slow reply. This has happened to me twice now and appears to be
what you say;
at least, if I close AWN and relaunch, Pandora then loads without reporting
a traceback and
the icon is correct on the bar. So, Pandora is trying to launch prior to my
connection being
established. I have no scripts to force an auto-launch.

Something else is apparently strange in my installation, going by your
earlier notes.

First, /usr/share/avant-window-navigator/applets/pandora/pandora.py has no
URL path
statement available to change (See quote 1). *Find* highlights many url
hits, but not an
actual https address.

Second gconf-editor does not show a Pandora applet under
apps>avant-window-navigator>
applets> and thus no key.

Finally, I've always had to launch Firefox and connect to Pandora directly
via the browser *
first*, and then the applet will find Pandora's site and make a connection.
Your info above
suggests why. Comments appreciated, either prior or future.

I play with this at times via AWN, but most often just connect via FF. I'd
rather not resort
to using FF by default as the overhead is apparently bigger in FF and can
interfere if I'm
running another memory hog.

I suspect some of this overhead issue is caused by the Pandora site itself
to some degree.
They took part of their site down for operational changes last week and FF
perked up
thereafter, though that may also be partly the result of the FF update
released last week.
FF had been a slug on my machine before the FF update while Opera and others
were not
sluggish at all. Too many variables.

Hope that's not info overload. ;->

Gary Greene <email address hidden>
San Jose, California

Quote 1:

#!/usr/bin/python
"""
Copyright 2008 Sharkbaitbobby
<<email address hidden><sharkbaitbobby%<email address hidden>>
>

This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
"""

import os
import htmllib, formatter
import urllib2
import gtk
import pygtk
import awn
from awn.extras import awnlib

# workaround for weirdness with regards to Ubuntu + gtkmozembed
if os.path.exists('/etc/issue'):
  import re
  fp = open('/etc/issue')
  os_version = fp.read()
  fp.close()
  if re.search(r'7\.(?:04|10)', os_version): # feisty or gutsy
    os.putenv('LD_LIBRARY_PATH', '/usr/lib/firefox')
    os.putenv('MOZILLA_FIVE_HOME', '/usr/lib/firefox')

try:
  import gtkmozembed
except ImportError:
  print ' #####################################'
  print 'Gtkmozembed is needed to run Pandora, please install.'
  print ' * On Debian or Ubuntu based systems, install python-gnome2-extras'
  print ' * On Gentoo based systems, install dev-pyt...

Read more...

Revision 1128 introduced new code which now finds the url on it's own, so we don't have to manually push updates every time Pandora changes it. So you will not have the actual https address. That comment was when I had miss read what bzr revision you had installed and though that you still had the older code.

This was fixed back in rev 1130.

It now loads the gconf url if no connection is present. It handles connection problems like the rest of the gtkmozembed applets now, which is still less than ideal. But this specific problem is resolved, so I'm marking fix committed.

Changed in awn-extras:
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Confirmed → Fix Committed
Mark Lee (malept) on 2009-09-09
tags: added: applet pandora traceback
Changed in awn-extras:
milestone: none → 0.4.0
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers