New Spy Effects (actually old ones in TS, but new for here)

Bug #895875 reported by MasterHaosis on 2010-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Wishlist
AlexB

Bug Description

Here
http://modenc.renegadeprojects.com/Agent
It says
1.,,Building with Factory= set to any valid type, the cameo of whatever object the owning player is currently constructing will be displayed to the infiltrating player above the selected building whenever the infiltrated building is selected by the infiltrating player."
2. ,,Building with Refinery set to 'yes', the player that owns the infiltrator unit can now see the financial situation (i. e. amount of credits) of the player whose refinery was infiltrated."
3.,,Building with Power set to a number greater than "0" - Shows the power levels of the infiltrated player."

So can following things can be done here with Ares?
1. SpyEffect.RevealProduction= to works on any Factory=yes not just war factory. Which means that we can infiltrate barracks, con yards and airfields and know what enemy is constructing.
2. Add new code SpyEffect.RevealMoneySituation=yes so when spy enters into Ore refinery we will know how much money enemy has by clicking on it. And it should write ,,Money=xxxx(amount)" I am sure that modders wants to know how how much AI has money because he is cheating often hahaha
3. Add new code SpyEffect.RevealPowerSituation=yes so when we infiltrate power plant, when we click on it, we would know how much power enemy has. It should be exactly like we clikc on our own power plant to display ,,Power=xxx (amount)"

Basically those new effects are separated from current ones, so can work togheder (mixed with spy codes) or not, if modder chooses it.

WoRmINaToR (worminator) wrote :

1) is already coded and confirmed working. Please have a look at the related SpyEffect.Custom topic. you will find it there.

MasterHaosis (masterhaosis) wrote :

WoRmINaToR thanks man for replying in my requests.
Where is that topic? So actually it works at all factory types not just war factory like in Ares 0.2 1P Manual?

Marshall (m-edward) wrote :

The manual does not say it only works with war factory therefore it is safe to assume that it does work with any factory.
We do put some thought into how the manual is worded, you know!

Linglin (linglin) wrote :

3) can use the 1) logic and can see the power status

MasterHaosis (masterhaosis) wrote :

Renegade, what is wrong with my requests? What is missed?

DCoder DCoder (dcoder1337) wrote :

You need a really good reason to make things High Priority.

MasterHaosis (masterhaosis) wrote :

Ah thanks, I did not know that. SO I should edit into low priority or normal?
Or can you administrators edit that, I did not know.

Renegade (renegade) wrote :

Closing this for now, as, even though the issue was still open for comment and had not been rejected on request-basis, commenting lasted only for 8 hours, and after that, nobody cared for this request.

AlexB (alexander-b) wrote :

The last effect that wasn't possible until now: Support SpyEffect.RevealProduction on refineries and silos
If Storage > 0, enemy buildings show the available money using TXT_MONEY_FORMAT_1 as format string. Observers can always see the amount of money.

Changed in ares:
assignee: nobody → AlexB (alexander-b)
milestone: none → 0.b
status: Won't Fix → Fix Committed
AlexB (alexander-b) on 2016-03-11
tags: added: infiltrate spy spyeffect
removed: building enemy improperlyfiled infiltrated know new plant player power refinery set
AlexB (alexander-b) on 2016-03-15
Changed in ares:
status: Fix Committed → Fix Released
Chanterier (speederyr) wrote :

Support SpyEffect.RevealProduction on refineries - works. My question is why does it need Storage>0? Is it so that the game knows the building is a refinery? There are two other tags that could be used for this. Right now this spy effect can't be used on original RA2 type refinery and it would be an interesting choice to put this 'money revealing' spy effect on some other structures, for example economy boosters.

This whole display thing also works for power plants.

AlexB (alexander-b) wrote :

Right, Storage distinguishes refineries and silos from other buildings. Note that Storage= itself does not do anything else except for providing storage. You need to also have to enable Refinery.UseStorage=yes on an refinery to actually put Tiberium into storage. The normal RA2 refineries (also in YR) have Storage= set (which was the reason Refinery.UseStorage= had to be introduced in the first place). If no Refinery.UseStorage=yes refiniery exists and you want to show the money on an Ore Purifier, just give it Storage=1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.