Start-game crash loading side

Bug #1219990 reported by Nemo Starem on 2013-09-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Undecided
Unassigned

Bug Description

Whenever I use my "Ally" side, or perhaps just some countries (I haven't tested them all) , during load the game crashes.

This didn't happen before I actualized my version to the last version of AttachEffect (unstable) - I was using a previous version of the same development branch.

Perhaps it is a unit with =yes on AllowedToStartInMultiplayer=yes,

but if so, it's still a version mistake, since I haven't changed anything at all on that side or it's factions between a version and the other. What's more, I had just played a game with Germans, which now crash the game before it even shows ingame images.

I include the Syringe for reference.

* * *

Also, additional bug:

The next code is suppossed to bring 10 of each type in paradrop, and so it worked in previous versions:

ParaDrop.Types=E2,E2A,SVCONSCRIPT
ParaDrop.Num=10,10,10
ParaDrop.Aircraft=PDPLANEDARK
ParaDrop.Count=3

however, in the last revisions, EVERY plane has EVERY paradrop, so it puts into the ground a full 30 of each, which was not intended and wasn't that way before.

Please fix it. Thank you on advance.

Nemo Starem (igal-igal) wrote :
Graion Dilach (graiondilach) wrote :

The game crashed during drawing a spotlight.

There is no additional bug, except PEBKAC. Correct code for such would be:

ParaDrop.Types=E2
ParaDrop.Plane2.Types=E2A
ParaDrop.Plane3.Types=SVCONSCRIPT
ParaDrop.Num=10
ParaDrop.Aircraft=PDPLANEDARK
ParaDrop.Count=3

But what else would have i expected from you, NimoStar. RTFM.

Nemo Starem (igal-igal) wrote :

Then how do you explain the spotlight bug if before was none? And also it onlly happens with allied nations. There has to be an error with this version since in others it doesn't happen.

Furthermore, the manual hasn't changed http://ares-developers.github.io/Ares-docs/new/superweapons.html#type-paradrop-and-type-amerparadrop and it's rather confusing - you just use "types" with not even .Plane on the first, which makes it a default tag... and it says the first pane is not numbered, etc. etc. and nowhere does it says the default content will be used for each plane instead as, as before, spread. Cryptic and inconsistent implementation is not my responsibility, it should be clearer.

AlexB (alexander-b) wrote :

Spotlight? For me this looks like a voxel problem. Crash is in a voxel-related function.

The INI settings tell Ares to send three planes (ParaDrop.Count=3) with ten units of each of the three types. You should get 90 infantry units. If you want only 30, set ParaDrop.Count=1 (which sends one plane with all 30 units, or spread the infantry types over three planes (using ParaDrop.Plane2.Types=E2A, ParaDrop.Plane2.Num=10, and so on). It should have worked like that for years.

Yes, the paradrop code is complex, but I won't change it. Changing tag names now would just break existing code for no reason. It does say that your plane is used as default plane: in the list below "Values are read in this order, top down. The first value found is used.". But I concur that it is confusing.

Your syringe.exe is outdated. A newer syringe version is available in the Ares 0.3 download package.

Nemo Starem (igal-igal) wrote :

Thank you, alex. Yes, I had understood the code now, but before it wasn't so much so - I thought that if more planes were added without specifying the contents, the main content (which doesn't identify any plane) would just be spread over them.

Anyways... I have deleted all AllowedToStartInMultiplayer units and put back only some basic ones, it seems to be running OK now. I have yet to encounter what unit/voxel is the problem, but I think it would have still to do with the actualization.

Hm, I will try to fix that "outdated". I have only been downloading the ft-attacheffect versions lately and they don't come with the Syringe.

Nemo Starem (igal-igal) wrote :

PD: Is the 0.4 rc1 including the attacheffect yet? I assume it already has the custom rockets.

AlexB (alexander-b) wrote :

The 0.4 release candidate contains everything that was in 0.3, plus AE and some minor stuff. (It also comes with latest Syringe.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments