[0.2] Locomotor beam alternate crash

Bug #1006319 reported by Nemo Starem on 2012-05-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Undecided
Unassigned

Bug Description

I have made a RA3 style Apocalypse Tank, but for Yuri.
Magnetic harpoon included... uses Locomotor Beam logic
It works, and my omnicrush tank uses it good.

However, theres some issues:
- When I use it on a unit, it will be paralyzed (cannot be selected, move or shoot) forever, even if it is de-targeted. I think this has to do with the fact that I use a ground locomotor (tank), so the unit doesn't ever "drop", because it does not lift ground.
- I have a seemingly random crash when making some attacks... Ares 0.2 beta can't identify it.
yet untested: Modify the locomotor beam to amphibious... don't think it will work, though.

Here are relevant parts of the code:
[ONTHETANK]
TargetLaser=yes
Primary=EvilBeam ;EvilCannonE
ElitePrimary=EvilBeamE ;EvilCannonE
Secondary=EvilCannon
EliteSecondary=EvilCannonE

IsTilter=yes
OpportunityFire=yes
CanPassiveAquire=yes
DefaultToGuardArea=yes
GuardRange=5
VHPScan=Strong
Crusher=yes
OmniCrusher=yes
MovementZone=CrusherAll

[EvilBeam]
Damage=1000
ROF=50
Range=6.75
Speed=100
Projectile=InvisibleHigh
Warhead=TowWH
Report=MagnetronAttack
IsRadBeam=yes
Beam.Color = 200,1,255
Beam.IsHouseColor = no

[TowWH]
Verses=0%,0%,0%,100%,100%,100%,0%,0%,0%,0%,0%
IsLocomotor=yes
Locomotor={4A582741-9839-11d1-B709-00A024DDAFD1}

Is it possible to have locomotor beam controls that do not disable the tank except for moving? I think tanks in Mental omega mod could shoot while lifted by magnetron, for example... and what of the crash?

Also, my Ares crash dumps are over 200 mb each...is that normal? Should I delete them?
(more bugs I will report in other threads, with 0.2 version)

Nemo Starem (igal-igal) wrote :
description: updated
Graion Dilach (graiondilach) wrote :

Having 200 MB dumps on a 64 bit system is normal, yes. But when you compress it, it goes down to 20-40 MB.

Usually people use the infantry locomotor ({4A582746-9839-11d1-B709-00A024DDAFD1}) for such stuff, but even that disables the unit entirely (MO 1.2 Infector Tank uses this).

AlexB (alexander-b) wrote :

The game tries to do something to the unit to drag. One function succeeds, but the second function right after that fails, because the first function apparently changed some stuff around. It looks like the drive locomotor does not support being used in IsLocomotor weapons.

For reference: this->LocomotorTarget->Deselect() fails because LocomotorTarget==NULL, after a this->LocomotorTarget->SetDestination(this, 1) call.

Nemo Starem (igal-igal) wrote :

Amphibious (?) locomotor only disables moving; it does not cause crashes, but it does not allow my beam to "tow" the vehicles neither... (I disabled VHP scan on the tank just in case it was that, too; since magnet beam causes a lot of "virtual" damage...)
From what you have told me, infantry locomotor won't "drag" them either. And jumpjet makes them be in the air, and my tank won't crush them there.

Is there a way to fix it?
Why not re-code islocomotor tag in a way it works with drive?

Nemo Starem (igal-igal) wrote :

Correction: Amphibious locomotor beam doesn't even do that, because units still move if you click twice... so, useless. And if the tank is not towed, my Apocalypse will not run over it unless it is really close.

AlexB (alexander-b) wrote :

Is there a way to fix it?
Safe for using an other locomotor, I don't know.

Why not re-code islocomotor tag in a way it works with drive?
This might be possible, but I'm not too keen to touch the locomotor code.

Nemo Starem (igal-igal) wrote :

I have tried other locomotors, but it keeps crashing on seemingly random combat in enemy bases (can do everything without crashing seemingly, but still crashes somewhere). Tried even the default, but also Infantry locomotors.

Here, have list: ;{4A582742-9839-11d1-B709-00A024DDAFD1} ;{4A582744-9839-11d1-B709-00A024DDAFD1} ;{92612C46-F71F-11d1-AC9F-006008055BB5} ;{4A582741-9839-11d1-B709-00A024DDAFD1} ;{4A582744-9839-11d1-B709-00A024DDAFD1} ;

Can anybody have a more precise idea of what is wrong? It was not exactly this causing the crashes, then what?

AlexB (alexander-b) wrote :

Please attach an except file from your latest crashes. Maybe it's a different reason.

Nemo Starem (igal-igal) wrote :

I have had differents excepts since then.

My "solution" was to change the beam to an EMP weapon. It works as intended (but does not drags).

But, if you want to know what is wrong, I can reproduce it and attach it...

Well, I have not been able to reproduce it with the infantry locomotor. I attach an old except file if you want to examine it. I will keep using the EMP version if there are no plans for the drive locomotor to be ever fixed for IsLocomotor...

AlexB (alexander-b) wrote :

The newly attached except shows the same problem. The reason should be the same.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers