PiTiVi fails to render

Bug #882790 reported by Christopher Small on 2011-10-27
220
This bug affects 55 people
Affects Status Importance Assigned to Milestone
PiTiVi
Expired
Critical
pitivi (Arch Linux)
New
Undecided
Unassigned
pitivi (Ubuntu)
Undecided
Unassigned

Bug Description

I have a project that was rendering just fine and needed to make some modifications. I took out the last clip and threw in another one and adjusted some of the audio gain lines. Everything played fine in the preview window. When I go to export now, as it starts estimating time to completion, the time bloats and never starts exporting (by the time I hit cancel it was telling me it was going to take 330 hours or something to finish rendering). I've tried several times now, restarted the application and everything, and am still getting the same behavior. Has anyone else experienced this and know how to get around the issue?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pitivi (Ubuntu):
status: New → Confirmed
Christopher Small (metasoarous) wrote :

I'll update in saying that when I took out the audio processing on that clip and set the audio level so that the end of the first clip of beginning of the following clip aligned, I was able to export the whole thing. But even then, it was buggy. Somewhere in the process of messing with things, it almost got through the whole thing, but stopped and froze at the point where the last track started.

Ben Klaasen (ben-fluidlogic) wrote :

Hi - this bug has been logged in the pitivi bugzilla database as https://bugzilla.gnome.org/show_bug.cgi?id=665902.

Timo Jyrinki (timo-jyrinki) wrote :

Starting from the command line, I get the following error report repeated four times:

ERROR [ 8450] [0x7fd7a4b8c700] "<Pipeline at 0x3312450>" pipeline Mar 28 17:08:57 _handleErrorMessage: error from /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition1/GnlSource:gnlsource: FileSourceFactory3/GstBin:bin4/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin2/GstFileSrc:urisrc (__main__.GstFileSrc): GStreamer encountered a general stream error. (gstbasesrc.c(2625): gst_base_src_loop (): /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition1/GnlSource:gnlsource: FileSourceFactory3/GstBin:bin4/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin2/GstFileSrc:urisrc:
streaming task paused, reason not-linked (-1)) (/usr/lib/pitivi/python/pitivi/pipeline.py:858)

And like it says, "streaming task paused", nothing really happens and CPU isn't used. I can cancel from the Rendering / Estimating dialog to go back to the codec selection screen.

cadogan (cadogan32) wrote :

I have a similar problem too.I installed a new version of ubuntu 12.04 and pitivi would not let me render the video.No matter what i tried,it always gets stuck on "Rendering" I'm hoping it gets fixed since it's one of my favorite video editors.thanks

Ben Clapp (ibenrunnin) wrote :

Having the exact same problem as cadogan. ARGH

Ulisse (ulipo) wrote :

same here, ubuntu 12.04 64 bit

I've updated the summary to more accurately characterise the problem.

summary: - PiTiVi takes forever to render
+ PiTiVi fails to complete render
summary: - PiTiVi fails to complete render
+ PiTiVi fails to render
Changed in pitivi:
importance: Unknown → Critical
status: Unknown → Confirmed
Victor (vic-tor) wrote :

Same problem here.
Has anybody found one format which pitivi can render as of now (I mean, amongst those who experience the bug)? Without rendering the soft is of no practical use, but if it was be possible to render to something not too lossy, the output could at least be reconverted to the target format later...

Keith Nunn (kapn) wrote :

I got one video to render in AVI one time. However, I haven't been able to repeat the feat. The resolution was very low, so I couldn't use it and I'm not sure of the exact settings I used, else I might be able to do it again. Other than that, my experience has been the same as others. The large number of input formats is greak, but the lack of rendering makes it pretty much useless..

Keith Nunn (kapn) wrote :

Openshot had some issues too, but offered inline help. After following their codec install instructions the rendering on OpenShot went fine. The render in Pitivi was more willing to begin after I installed the library that OpenShot wanted, but still wouldn't complete. In the end, I used OpenShot which was willing to render in many different formats.

AaronVanDevender (sig-0) wrote :

I had this with pitivi installed using apt-get under Ubuntu 12.04. However, when I used pitivi 0.15.2 downloaded from sources checked out from pitivi.org, everything worked fine. So I suspect some packaging error.

Jeff Fortin Tam (kiddo) wrote :

For those of you who experienced this in 0.15.1, see bug #995749.

Timo Jyrinki (timo-jyrinki) wrote :

0.15.2, the release called "I accidentally... the whole render", is in Ubuntu 12.04 LTS's proposed updates now, which should fix pitivi problems for many that originally experienced problems in Ubuntu 12.04 LTS.

This bug report is however (apparently) about a different upstream bug report that is still open, but just FYI.

Dustin Kirkland  (kirkland) wrote :

Unfortunately, 0.15.2 from the Ubuntu proposed repository is not solving this for me.

florin (florin-arjocu) wrote :

0.15.2 is at this point in the official PPA (12.04 LTS), but the bug is still here. Did any of you find any solution? THanks!

Matthew Daines (73ktcew) wrote :

After beating my head over this all day I found a solution for my particular project. I had two video tracks, one shot from a tripod, and the other from a handheld camera hovering. I had the tripod track on the timeline above and the hovering track below. I'd split the tripod track at several points and used the option for dragging the red bar on every other resulting segment down to zero so it would not show, thus revealing the hovering track below during those intervals. The preview played fine, but rendering had the problem mentioned in this bug. What I did was instead of dragging the red bar down to zero, I simply deleted the tripod segments that I wanted hidden, and voila, it rendered out fine. I also decided to try not deleting the segments, but setting the opacity to just above zero, and that works also. So apparently it has something to do with multiple video tracks overlapping, or with one being set to 0% opacity? Maybe a division by zero error somewhere? I'm running PiTiVi v0.13.5 on Linux Mint 11, 64 bit.

Fabián Rodríguez (magicfab) wrote :

From comment by one of the devs upstream:

"Currently PiTiVi's core is being replaced by GStreamer Editing Services. This is a major overhaul and we sadly can't investigate much bugs that occur on the "traditional" core of PiTiVi."
"Okay, confirming the bug[...] to be perfectly honest, we are very short on developer resources right now and there is no immediate fix for this. Someone needs to come up and do the proper debugging and bug fixing work in GES (or in gstreamer if the problem is in gstreamer)."

That was back in February :|

Rick Gabriel (klaxian1) wrote :

ERROR [ 5243] [0x7fd74a83a700] "<Pipeline at 0x33e9610>" pipeline Dec 09 12:03:42 _handleErrorMessage: error from /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition1/GnlSource:gnlsource: FileSourceFactory9/GstBin:bin16/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin9/GstAviDemux:avidemux3 (__main__.GstAviDemux): GStreamer encountered a general stream error. (gstavidemux.c(5212): gst_avi_demux_loop (): /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition1/GnlSource:gnlsource: FileSourceFactory9/GstBin:bin16/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin9/GstAviDemux:avidemux3:
streaming stopped, reason not-negotiated) (/usr/lib/pitivi/python/pitivi/pipeline.py:858)

Jonathan Mark (jhmark000) wrote :

FYI, on pitivi 0.15.2 (installed by Ubuntu) I have seen 2 different problems causing rendering to hang, which I was able to find workarounds for:

1. Rendering hangs forever at the initial "Estimating" step. It seems this was caused by opacity being 0, as suggested above. The opacity had been set to fade to black at the end of my clip. I dragged the ending opacity upward a little, and then the problem did not occur.

2. Rendering dialog shows an estimated time which continuously increases. This happened when I accidentally had whitespace between the beginning of the timeline and my clip. After dragging all segments of my clip to the left, I could render successfully.

Changed in pitivi:
status: Confirmed → Incomplete
maxmix (prova705) wrote :

I think i just had similar problem, now i`m using ubuntu 14.04 and first video i was rendering was stucking on initialize render.....
But i found a simple solution :)

Just close pitivi, open shell and try to type:
sudo pitivi
than when it opens it should be able to render (eve if i would say slow anyway).
At least this one worked for me :)

Changed in pitivi:
status: Incomplete → Expired

To fix the problem you must change the codek for video or audio.
you can find it under render... ---> video --> Codec MPEG-4 part 2 workt for me.

Igor Trush (igor-trush-2) wrote :

PiTiVi hangs on initialising if I use wide screen for rendering.
4:3 screen is OK

Kubuntu 16.04.1

Igor Trush (igor-trush-2) wrote :

Update: PiTiVi hangs on MP4 and avi. For matroska works OK.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.