No HDMI Sound with Jaunty 9.04, Kernel 2.6.30, ALSA 1.0.20, Conexant CX20561 & nvidia MCP65 HD Audio (Geforce 8400M GS)

Bug #389494 reported by Renard Voß on 2009-06-19
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
alsa-driver (Arch Linux)
New
Unknown
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I did a fresh install of jaunty on my HP DV9812EG Notebook, but HDMI Audio out isn't working.

In the beginning i had ALSA Version 1.0.18 installed, which came with Ubuntu 9.04. Even tough the lastest proprietary geforce driver (NVIDIA-Linux-x86_64-185.18.14-pkg2.run) seems to work properly, there was no HDMI sound. Thus, I updated to the lastest Kernel 2.6.30 (official release, no RC) and ALSA 1.0.20, but it didn't change anything. The HDMI "device" can't be recognized even tough it should be there.

ALSA 1.0.20 was configured with the following command:

./configure --with-cards=all --with-card-options=all --with-sequencer=yes && make

Under Windows Vista Everest finds the following soundcard and HD Audio Modem:

Conexant Cx20561 @ nVIDIA MCP65 - High Definition Audio Controller
Modem HDAUDIO Soft Data Fax Modem with SmartCP

"hwinfo --short" under ubuntu 9.04 confirms this, but "aplay -l" list only these two audio devices (it should be three at least):

rennie@Riese:~$ aplay -l
**** Liste von PLAYBACK Geräten ****
Karte 0: NVidia [HDA NVidia], Gerät 0: CONEXANT Analog [CONEXANT Analog]
  Untergeordnete Geräte: 1/1
  Untergeordnetes Gerät '0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 1: Conexant Digital [Conexant Digital]
  Untergeordnete Geräte: 1/1
  Untergeordnetes Gerät '0: subdevice #0
rennie@Riese:~$

So what's missing is something like this:

Karte 0: NVidia [HDA NVidia], Gerät 3: NVIDIA HDMI [NVIDIA HDMI]
  Untergeordnete Geräte: 1/1
  Untergeordnetes Gerät '0: subdevice #0

"aplay -L" shows this result:

rennie@Riese:~$ aplay -L
default:CARD=NVidia
    HDA NVidia, CONEXANT Analog
    Default Audio Device
front:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, Conexant Digital
    IEC958 (S/PDIF) Digital Audio Output
null
    Discard all samples (playback) or generate zero samples (capture)
rennie@Riese:~$

So again there is missing something like:

hdmi:CARD=NVidia,DEV=0
    HDA NVidia, NVIDIA HDMI
    HDMI Audio Output

I even tried to go back to ALSA 1.0.19 but it is not possible to ./configure the original alsa-driver package (there was an error, but i don't remember which). As an alternative i tried to install the linuxant deb-version of ALSA (alsa-driver-linuxant_1.0.20.3_all.deb) and the realtek version (realtek-linux-audiopack-5.11) but both versions didn't work.

So this must be a bug, because everything else works fine (e.g. HDMI Video out, Laptop Speakers, Ear-Plug-Audio out...)

Unfortunately, to find and eliminate the bug, I can contribute only with some other information:

Result of "lspci | grep -i audio!":
---------------------------------------------------

rennie@Riese:~$ lspci | grep -i audio
00:07.0 Audio device: nVidia Corporation MCP65 High Definition Audio (rev a1)

...and the result of "cat /proc/asound/cards"

rennie@Riese:~$ cat /proc/asound/cards
 0 [NVidia ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf2480000 irq 21
rennie@Riese:~$

Result of "alsactl init NVidia":
------------------------------------------------

rennie@Riese:~$ alsactl init NVidia
Unknown hardware: "HDA-Intel" "Conexant CX20561 (Hermosa)" "HDA:14f15051,103c30cf,00100000" "0x103c" "0x30cf"
Hardware is initialized using a guess method
/usr/share/alsa/init/default:51: control element not found
/usr/share/alsa/init/default:52: missing closing brace for format
/usr/share/alsa/init/default:52: error parsing CTL attribute
/usr/share/alsa/init/default:52: invalid rule
rennie@Riese:~$

Renard Voß (renardvoss) on 2009-06-19
description: updated
description: updated
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux - the package that provides the kernel.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
Renard Voß (renardvoss) wrote :

Thank you for classifing my bug report. I have not been sure how to classify it, because it could be a bug of ALSA, of the Nvidia graphics driver or in the Linux Kernel.

Is there something else I could do to ensure that the "proper developers" would take a look at it?

Zebra-Rake (faheyd) wrote :

Have a HP 2700 laptop with the same specs and ubuntu 9.04, and I also cannot play any audio over the HDMI.
I've done all the howto's, checking 598 stuff in the sound mixer, etc. Something is broke but I also don't know if it's alsa or the nvidia drivers .

Please help us.

tutysara (tutysara) wrote :

I also face the same issue. I have used ubuntu gutsy and hardy heron and the sound worked fine with those version. It is not working with Jaunty. Any info on when this will be fixed?

tutysara (tutysara) wrote :

Hi,
I made some changes to the kernel boot params. The progress bar got struck at regular intervals and I have to press any key to make it move again. I googled it and found many users are having this same issue and an workaround was provided by adding pci=noacpi to the kernel boot params. Is this workaround preventing me from playing sound?

tutysara (tutysara) wrote :

@Brian Murray
This bug is still in new state. Can you please move it to confirmed state so, that it would get worked on. When this can be fixed?

Liu Hui (lion-hui) wrote :

I also got the same problem. My computer is HP dv1702 . The sound is OK , but I cann't use the mic .
Jaunty 9.04, Kernel 2.6.30, ALSA 1.0.20

And when I use the 8.10 , everything is OK.

beytu (beytu) wrote :

Hi,

 i have a similar problem : no sound throught hdmi.

I have Jaunty on a hp dv 2700 with 8400M GS, Conexant CX20561 and :
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03) (this point seems to be different from Renard)

I have installed the latest nvidia driver (190.18.03) to enable sound over hdmi but it didn't worked. I also installed alsa 1.0.20 using options "--with-cards=all --with-card-options=all" but it didn't resolve the problem.

Renard Voß (renardvoss) wrote :

Today I installed:

ALSA 1.0-21
Kernel 2.6.31 (Final)
NVIDIA Linux x64 Driver 190.32
Pulseaudio 0.9.17

But guess what?!

HDMI Audio is still NOT WORKING!

Could anybody help us, please?

kidgasosa (kidgasosa) wrote :

Could anybody help us, please?

Changed in linux (Ubuntu):
assignee: nobody → José Manuel Fernandes (kidgasosa)
assignee: José Manuel Fernandes (kidgasosa) → nobody
Zebra-Rake (faheyd) wrote :

Could "→ nobody " please help us out.

Justin Dalton (pablious) wrote :

On karmic, I just upgraded everything:

Alsa 1.0.21
Kernel 2.6.31-16
nvidia 190.42 drivers

And I still have no hdmi audio. aplay -l shows no digital output at all:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This is really really annoying. I don't like having to boot windows just to get hdmi sound.

Simon (gigathon) wrote :

This bug also happens in Slackware but I couldn't find it on your list of distros. It is in all distros because it is in the driver.

I put a link to my bug-report on the ALSA site. They don't seem able to fix it either.

Renard Voß (renardvoss) wrote :

Hello Simon!

Thanks for your comment!

How did you connect your ALSA bug report to this one?

I would like to do the same with the ALSA bug report I opened simultaneously with my launchpad report.

My ALSA bug report can be found here:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4589

... but it has been ignored by the ALSA developers, too.

============================================================

And only to let everybody know:

Some time ago I upgraded to Karmic, but the HDMI sound problem is still there.

My actual config is:

ALSA 1.0.22
Kernel 2.6.31-16

NVIDIA Linux x64 Driver 190.53

Simon (gigathon) wrote :

I can't remember how I connected that bug report to this one.

When I use alsamixer I get a slider for microphone volume as a playback device. Is this a clue to the problem?

Jeremy Foshee (jeremyfoshee) wrote :

Hi Renard,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 389494

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Brad Figg (brad-figg) on 2010-03-15
tags: added: hdmi nvidia

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: beytu 2099 F.... pulseaudio
 /dev/snd/pcmC0D1p: beytu 2099 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4500000 irq 22'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,103c30cd,00100000'
   Controls : 14
   Simple ctrls : 7
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout dip lpadmin netdev plugdev sambashare

beytu (beytu) wrote : BootDmesg.txt
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
gabr10 (gabriobarbieri) wrote :

Having the same problem here. HP Pavilion dv6870us Audio device: nVidia Corporation MCP65 High Definition Audio, no sound over HDMI output. Although I see two interfaces listed on aplay-l:
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: NVidia [HDA NVidia], dispositivo 0: CONEXANT Analog [CONEXANT Analog]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
tarjeta 0: NVidia [HDA NVidia], dispositivo 1: Conexant Digital [Conexant Digital]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

But no matter how I tweak around with my audio config I can't get audio on my TV via HDMI.

Daniel T Chen (crimsun) wrote :

Use linux-alsa-driver-modules-$(uname -r) from ppa:ubuntu-audio-dev.

C Pirnat (histoplasmosis) wrote :

linux-alsa-driver-modules-$(uname -r) doesn't fix it either.

C Pirnat (histoplasmosis) wrote :

I just tried linux-alsa-driver-modules-$(uname -r) from ppa with lucid problem still persists with all recent updates. Digital output is showing under aplay -l but you can get any output switching in sound preferences to any of the digital outputs.

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: Conexant Digital [Conexant Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I do notice that subdevices for the digital is now 1/1 instead of 0/1 before. I will try later and see if anything has changed maybe an update snuck in with in the last few hours.

Daniel T Chen (crimsun) wrote :

Renard Voß, this issue is fixed in Maverick's kernel (2.6.34-rc7 based).

Changed in linux (Ubuntu):
status: New → Fix Released
Changed in alsa-driver (Ubuntu):
status: New → Fix Released
Renard Voß (renardvoss) wrote :

Good to know that somebody seems to know where's the problem.

Unfortunately the Mainline Kernel 2.6.34 for Lucid (which I'd like to keep on using) doesn't work with Broadcom WLAN cards.

Look here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/577136

That's why I didn't even try to compile the above mentioned 2.6.34-rc7 based Maverick's kernel.

Does somebody know if there will be a Kernel release for Lucid with the fix for our HDMI problem and working Braodcom STA drivers?

gabr10 (gabriobarbieri) wrote :

I'm confused, if the issue is with the alsa-driver, and will be integrated in this kernel, is there any way to upgrade our alsa-driver on an older kernel to fix this?

Changed in alsa-driver (Arch Linux):
status: Unknown → New
Renard Voß (renardvoss) wrote :

Still the same, even with Ubuntu 10.10.

Look here:

rennie@Pavillon:~$ aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: NVidia [HDA NVidia], Gerät 0: CONEXANT Analog [CONEXANT Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 1: Conexant Digital [Conexant Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
rennie@Pavillon:~$ aplay -L
default
pulse
    Playback/recording through the PulseAudio sound server
front:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, Conexant Digital
    IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    Direct sample mixing device
dmix:CARD=NVidia,DEV=1
    HDA NVidia, Conexant Digital
    Direct sample mixing device
dsnoop:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=1
    HDA NVidia, Conexant Digital
    Direct sample snooping device
hw:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=1
    HDA NVidia, Conexant Digital
    Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=0
    HDA NVidia, CONEXANT Analog
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=1
    HDA NVidia, Conexant Digital
    Hardware device with all software conversions
rennie@Pavillon:~$

I use Ubuntu and Sabayon
Nvidia Conexant also has problem on Gentoo and Sabayon.

HP Presario f750US, AMD64x2, nVidia MCP67

Result of alsactl init NVidia.
Unknown hardware: "HDA-Intel" "Conexant CX20561 (Hermosa)" "HDA:14f15051,103c30ea,00100000" "0x103c" "0x30ea"
Hardware is initialized using a guess method.

I do not get controll of all input and output that I have seen before on my card.
This web page says alsa-drivers is not installed in Gentoo. That is incorrect.

I have 30 hours of intense working on getting this solved.
http://www.linuxant.com/ seems to have an update. I will try to bypass the package managers and do a source install.

I will let you know how it goes.

Just to be technically correct Saybayon uses alsa-firmware instead of alsa-drivers.
Ubuntu packages are not used in Sabayon.

This problem is across all distributions of Linux.

The correct Conexant drivers are in some of the folders. Alsa mixer picks these up and opens more channels but not all of them.The modem is also being driven by nVidia mcp67 and there seems to be some not tolerant reactions to minor faults in the bios dsts files. I'm hoping the updates take care of some of the faults.

I speculate that the folks at nVidia don't allow typographical sloppiness in their in house code unlike the bios windows coders.

There is not a failure point that causes a bug report window to pop up.

I am hoping that by working the problem from source I can fix both of my distros.

I always use two distros and a Data partition to keep my projects going.

I have more updates to do.

I run a sound editing studio in Sarasota, Fl and I am really pleased with the opportunities that Ubuntu gives me to advance my career.

Stress and hard work make for great music.

jhoechtl (johann-hoechtl) wrote :

Ok, it's 2013, I have that driver and no sound via HDMI. Wow, that is frustrating!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.