Application menu module for GTK+

Alt-shortcuts display submenus of the local menu bar

Reported by Maia Everett on 2010-07-30
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Undecided
Cody Russell

Bug Description

1. Open any application with menu shortcuts (for example, any Nautilus window).
2. Press a menu keyboard shortcut (for example, Alt-F for "File").

Expected result: the corresponding item of the global menu bar opens.
Actual result: the "hidden" submenu of the local menu bar opens.

Omer Akram (om26er) wrote :

F10 is the simplest way to reproduce this bug.

Changed in appmenu-gtk:
status: New → Confirmed
Cody Russell (bratsche) wrote :

The part about displaying the menu in the local window is already fixed, but I'll keep this open for tracking the activation of the menu on the menubar.

Changed in appmenu-gtk:
assignee: nobody → Cody Russell (bratsche)
status: Confirmed → In Progress
Cody Russell (bratsche) wrote :

Actually, I've already got another bug for tracking that. I'll close this one, as it should have been fixed in yesterday's releases.

Changed in appmenu-gtk:
status: In Progress → Fix Released
Omer Akram (om26er) wrote :

this bug is still there appmenu-gtk 0.1.7-0ubuntu2

Changed in appmenu-gtk:
status: Fix Released → New
Cody Russell (bratsche) wrote :

Okay then maybe it's just not released, because the code is done.

Changed in appmenu-gtk:
status: New → Fix Committed
Cody Russell (bratsche) on 2010-09-14
Changed in appmenu-gtk:
status: Fix Committed → Fix Released
Dylan McCall (dylanmccall) wrote :

I am still seeing this bug, exactly as described, under Unity in up to date 10.10.

However, I have noticed that I am completely unable to open specific menus with their shortcut keys (such as Alt+F for the file menu). Can't remember if that's changed from before.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers