Alltray's show is broken, but undock works

Bug #890430 reported by k anliot on 2011-11-14
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
AllTray
Undecided
Unassigned
Lubuntu Software Center
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Using Lubuntu Oneric (LXDE, Openbox)
Install Alltray.
open Alltray, click on leafpad.
Leafpad appears in the system tray.
Alltray allows a menu to be shown with show/hide
Show does not work, window is already hidden

k anliot (mistertwig) on 2011-11-14
Changed in launchpad:
status: New → Invalid
affects: launchpad → ubuntu
Changed in lubuntu-software-center:
status: New → Invalid
k anliot (mistertwig) on 2011-11-14
Changed in lubuntu-software-center:
status: Invalid → New
Stephen Smally (stephen-smally) wrote :

In which way is this related to Lubuntu Software Center? is an alltray bug.

Changed in lubuntu-software-center:
status: New → Invalid
Artem Gabrielyan (synthakai) wrote :

I agree it is alltray's bug.

I'm using natty with gnome2 + compiz.
I hunt down the problem is and I launched alltray from gnome-terminal.
Show/hide didn't work. Upon selecting "undock" alltray gives "Segmentation fault". Luckily, the window I docked to tray with alltray appeared, but its position was not the same as before docking.

There is no such problem when running gnome2 + metacity

Artem Gabrielyan (synthakai) wrote :

yesterday I realised I was using ubuntu1104-32's stock alltray (version 0.71b).
I uninstalled it, and compiled and installed the most recent version 0.75dev from this site.
to compile I had to install some dev packages:
sudo apt-get install xorg-dev libgtk2.0-dev libgtop2-dev libwnck-dev
and all of the dependencies (I had removed them after installation).
now everything works fine, the bug has gone.

gantz (j0rn) wrote :

I have the same problem on 12.04/gnome-classic, launching alltray via menus/mouse clic then selecting a window docks well but can not show/hide, undocking works.
also, running from the command line like alltray <progname> works fine

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers