Menu not translated

Bug #1241028 reported by Olivier Febwin on 2013-10-17
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Activity Log Manager
Medium
Unassigned
activity-log-manager (Ubuntu)
Medium
Robert Ancell

Bug Description

As you can see on my capture, the time menu is not translated

Related branches

Olivier Febwin (febcrash) wrote :
summary: - not fully translated
+ Menu not translated
Adolfo Jayme (fitojb) on 2013-11-08
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Changed in activity-log-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in activity-log-manager:
status: New → Confirmed
Changed in activity-log-manager:
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in activity-log-manager (Ubuntu):
status: Confirmed → Triaged
no longer affects: ubuntu-translations
Changed in activity-log-manager (Ubuntu):
status: Triaged → In Progress
Changed in activity-log-manager:
status: Triaged → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Changed in activity-log-manager (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Olivier Febwin (febcrash) wrote :

UP !!!

This bug is still present in 14.10 beta

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2015-01-12 15:06, Gabor Kelemen wrote (in bug #1409550):
> On 2015-01-12 00:32, Gunnar Hjalmarsson wrote:
>> Did you notice the presence of the Ubuntu patch
>> debian/patches/14_seconds_combo.patch?
>
> No, but even then: the strings are still untranslated, so that patch
> may be wrong somehow. Strings are translated to my language, so that
> can't be the problem, but I don't see what's wrong with it.

I don't see what's wrong in it either. At the same time I noticed that Robert just made the same changes in trunk as you proposed. Maybe the proper next step is to simply drop the 14_seconds_combo.patch.

Gabor Kelemen (kelemeng) wrote :

Hi Gunnar

I think the other patch had some merit by reducing the number of strings a bit, but given that here we work with fixed number values, this solution should not pose much problem from translation POV.

I have been thinking on the ngettext problem, and my best guess is that this happened because the a-l-m code runs inside the g-c-c process, but uses its own translation domain. This is when ngettext does not work, as it uses the default translation domain of the main process - g-c-c here.
So you would need dngettext() to explicitly set the translation domain: http://www.valadoc.org/#!api=glib-2.0/GLib.dngettext

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2015-01-14 16:41, Gabor Kelemen wrote:
> So you would need dngettext() to explicitly set the translation
> domain: http://www.valadoc.org/#!api=glib-2.0/GLib.dngettext

Aha, that may be it.

Luo Lei (luolei) wrote :

Sorry to disturb, but when the po files will be updated?
Bug #1375598 required a po-update. When run "debconf-updatepo", an error of non-ASCII is prompted.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2015-02-02 03:23, Luo Lei wrote:
> Sorry to disturb, but when the po files will be updated?

I think the PO templates are up to date already. This bug is about making the translated strings actually used.

#1375598 is about some strings not translatable, such as "Add application...", due to miss of "_(" in the code.
The code has been fixed, but the strings are not show on Rossata. So I suppose the po files need an update.

Regards,
Luo Lei
Ubuntu Kylin Team
Website: http://www.ubuntukylin.com/
Distribution: http://distrowatch.com/table.php?distribution=ubuntukylin

在2015年02月02 16时09分,"Gunnar Hjalmarsson"<email address hidden>写道:

On 2015-02-02 03:23, Luo Lei wrote:
> Sorry to disturb, but when the po files will be updated?

I think the PO templates are up to date already. This bug is about
making the translated strings actually used.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1241028

Title:
  Menu not translated

Status in Privacy Manager for Zeitgeist:
  In Progress
Status in Ubuntu Translations:
  New
Status in activity-log-manager package in Ubuntu:
  In Progress

Bug description:
  As you can see on my capture, the time menu is not translated

To manage notifications about this bug go to:
https://bugs.launchpad.net/activity-log-manager/+bug/1241028/+subscriptions

Gunnar Hjalmarsson (gunnarhj) wrote :

@Luo: Yes, it looks like things remain to be done with respect to bug #1375598. So please post your reminders on that bug report then. As far as I can tell it's unrelated to this bug.

Adolfo Jayme (fitojb) on 2015-02-17
Changed in activity-log-manager (Ubuntu):
status: In Progress → Fix Committed
no longer affects: ubuntu-translations
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.7-0ubuntu22

---------------
activity-log-manager (0.9.7-0ubuntu22) wily; urgency=medium

  * debian/patches/dngettext.patch: specify domain so translations
    work in unity-control-center, thanks Gabor Kelemen (lp: #1241028)

 -- Sebastien Bacher <email address hidden> Tue, 13 Oct 2015 17:51:27 +0100

Changed in activity-log-manager (Ubuntu):
status: Fix Committed → Fix Released
Changed in activity-log-manager:
assignee: Robert Ancell (robert-ancell) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers