BTree keeps some deleted objects referenced

Bug #294788 reported by Adam Groszer
2
Affects Status Importance Assigned to Milestone
ZODB
Fix Released
Undecided
Unassigned
Zope 3
Fix Released
Undecided
Unassigned
Revision history for this message
Jim Fulton (jim-zope) wrote :

I suspect a bug in the logic to remove objects from the BTrees.

Can you recreate this with a simpler test case? (I understsnd probably not given the time that's passes.)

Changed in zodb:
status: New → Incomplete
Revision history for this message
Adam Groszer (agroszer) wrote :

ummmm, I'll try to add some tests

Revision history for this message
Adam Groszer (agroszer) wrote :

Was not that hard:

svn://svn.zope.org/repos/main/ZODB/branches/adamg-btree-keeps-reference

r103237

Seems like this happens when the object is in the key of the BTree.

Revision history for this message
Jim Fulton (jim-zope) wrote : Re: [Bug 294788] Re: BTree keeps some deleted objects referenced

On Wed, Aug 26, 2009 at 12:58 PM, Adam Groszer<email address hidden> wrote:
> Was not that hard:
>
> svn://svn.zope.org/repos/main/ZODB/branches/adamg-btree-keeps-reference
>
> r103237
>
> Seems like this happens when the object is in the key of the BTree.

Ah. That makes sense. I hate messing with the BTree C code this late
in the release cycle, but I'll see how hard this would be to fix.

Jim

--
Jim Fulton

Revision history for this message
Jim Fulton (jim-zope) wrote :

Well, it was hard, but it's done.

Thanks for coming up with a test case.

Changed in zodb:
status: Incomplete → Fix Committed
Tres Seaver (tseaver)
Changed in zope3:
status: New → Won't Fix
Revision history for this message
Adam Groszer (agroszer) wrote :

huhh, Won't Fix? Jim fixed this with r103321

Revision history for this message
Jim Fulton (jim-zope) wrote :

On Thu, Apr 15, 2010 at 5:04 AM, Adam Groszer <email address hidden> wrote:
> huhh, Won't Fix? Jim fixed this with r103321

With *much* resulting pain. But yeah, it's fixed. The fix is even
fixed and released.

Jim

--
Jim Fulton

Changed in zope3:
status: Won't Fix → Fix Released
Changed in zodb:
status: Fix Committed → Fix Released
Revision history for this message
Tres Seaver (tseaver) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Adam Groszer wrote:
> huhh, Won't Fix? Jim fixed this with r103321

Yup, but the fix was in the 'zodb' project (this one wasn't ever really
a Zope3 bug).

Marking anything "Fix Released" on the 'Zope3' projxect is actually a
bit suspect, unless the fix was actually part of one of the monolithic
tarballs.

Tres.
- --
===================================================================
Tres Seaver +1 540-429-0999 <email address hidden>
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkvHIjcACgkQ+gerLs4ltQ6B3wCeLd5Dq0xiQdQTKLkhGlYU3cln
iLwAniikrPax8O4GKe0z3a/sDRkQHc0m
=+XSE
-----END PGP SIGNATURE-----

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers