zope.component 3.5.0 not allowing zope:utility declarations without a "provides" attribute

Reported by tmog on 2008-07-25
4
Affects Status Importance Assigned to Milestone
Zope 3
Undecided
Unassigned

Bug Description

I get a TypeError("Missing 'provides' attribute") on the first utility registration.

I notice that in zcml.py:utility() is is never checked what the "factory" provides, only the "component" is checked.

Is this the intended behavior?

Marius Gedminas (mgedmin) wrote :

Bug in zope.component 3.5.0. I've got the fix ready.

Marius Gedminas (mgedmin) wrote :

Fixed in rev 88820. I made a 3.5.1 release tag, but don't have the privileges to upload it to pypi.

Changed in zope3:
status: New → Fix Committed
Changed in zope3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers