Incompatible changes in zope.app.securitypolicy

Bug #158743 reported by Philipp von Weitershausen on 2007-10-30
2
Affects Status Importance Assigned to Milestone
Zope 3
Fix Released
Undecided
Philipp von Weitershausen

Bug Description

zope.app.securitypolicy 3.4.x changed in incompatible ways (compared to previous 3.4.x versions). Apart from the fact that the split up to zope.securitypolicy shouldn't have occurred in the 3.4.x line (and should be reverted), zope.app.securitypolicy 3.4.3 breaks old imports:

    from zope.app.securitypolicy.rolepermission import rolePermissionManager
    ...
    ImportError: cannot import name rolePermissionManager

Assigning this to Roger since he is responsible for the split up.

Changed in zope3:
assignee: nobody → rogerineichen

I'll take this one then.

Changed in zope3:
assignee: rogerineichen → philipp-weitershausen

It turned out, import of zope.app.securitypolicy failed because it couldn't import ZopeMessageFactory from zope.i18nmessageid. The problem was that zope.app.securitypolicy wasn't stating that it needed a newer version of zope.i18nmessageid (3.4.2 or higher). Instead it was accepting any version, including the one in the Grok KGS. zope.app.securitypolicy 3.4.6 now specifies the dependency correctly, so if you're not using zope.i18nmessageid 3.4.2 or higher, you'll rightfully get a version conflict from buildout instead of the cryptic ImportError when trying to run the app.

Changed in zope3:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers