testrunner option to disable -1

Reported by Fred Drake on 2007-05-18
2
Affects Status Importance Assigned to Milestone
Zope 3
Undecided
Fred Drake
zope.testing
Undecided
Unassigned

Bug Description

When used with zc.buildout and the zc.recipe.testrunner recipe, it's generally reasonable to include the "-1" option in the "defaults" setting. It would be good to have an option that turns off the "-1" effects, so that the few times when re-enabling the extra reporting makes sense, it can be done, and treated as the special case that it is.

Benji York (benji) wrote :

If it were a lower case letter option; I'd suggest upper case to turn it off. By that line of reasoning -! would be my suggestion, but that's kind of silly.

Perhaps instead we add --first-failure as an alias of -1 and --no-first-failure or --all-failures as its opposite.

On 5/18/07, Benji York <email address hidden> wrote:
> Perhaps instead we add --first-failure as an alias of -1 and --no-first-
> failure or --all-failures as its opposite.

Something like that would work for me, though we should be especially
careful about the names. There are enough people that find the
semantics of -1 confusing as it stands; it's very specific to doctest
behavior.

Benji York (benji) wrote :

Fred Drake wrote:
> On 5/18/07, Benji York <email address hidden> wrote:
>> Perhaps instead we add --first-failure as an alias of -1 and --no-first-
>> failure or --all-failures as its opposite.
>
> Something like that would work for me, though we should be especially
> careful about the names. There are enough people that find the
> semantics of -1 confusing as it stands; it's very specific to doctest
> behavior.

How about --first-doctest-failure and --all-doctest-failures; kinda long
though.
--
Benji York
Senior Software Engineer
Zope Corporation

Fred Drake (fdrake) wrote :

On 5/18/07, Benji York <email address hidden> wrote:
> How about --first-doctest-failure and --all-doctest-failures; kinda long
> though.

Kinda long, and not completely clear still. Since this is about
reporting, and non-doctest tests already do what this is about making
doctest tests do, perhaps

    --hide-secondary-failures

and

    --show-secondary-failures

would be good? Still long, but optparse only requires enough of that
to be unambiguously identifiable.

  -Fred

--
Fred L. Drake, Jr. <fdrake at gmail.com>
"Chaos is the score upon which reality is written." --Henry Miller

Benji York (benji) wrote :

--hide-secondary-failures and --show-secondary-failures sound good to me. As an upside, non doctest tests that have yet to be invented could use those options as well.

Fred Drake (fdrake) wrote :

Added support for --hide-secondary-failures and --show-secondary-failures in zope.testing trunk, revision 75845.

Changed in zope3:
assignee: nobody → fdrake
status: Unconfirmed → Fix Committed
Changed in zope.testing:
status: New → Fix Released
Wolfgang Schnerring (wosc) wrote :

has long been released

Changed in zope3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers