Zope 2.12.6 fails to run on Fedora

Bug #587760 reported by Robin Lee on 2010-05-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Zope 2
Medium
Hanno Schlichting

Bug Description

The installation following http://docs.zope.org/zope2/releases/2.12/INSTALL.html#id2 was successful. But Zope fails to start.

[cheese@cheese-laptop my_zope]$ pwd
/home/cheese/Programming/my_zope
[cheese@cheese-laptop my_zope]$ ls
bin include lib zope
[cheese@cheese-laptop my_zope]$ ls bin/
activate mkzeoinst rst2newlatex.py zconfig
activate_this.py mkzeoinstance rst2odt_prepstyles.py zconfig_schema2html
debug mkzopeinstance rst2odt.py zdaemon
easy_install pip rst2pseudoxml.py zeoctl
easy_install-2.6 python rst2s5.py zeopack
fsdump repozo rst2xml.py zeopasswd
fsoids rst2html.py rstpep2html.py zopectl
fsrefs rst2latex.py runzeo zope-testrunner
fstail rst2man.py runzope zpasswd
[cheese@cheese-laptop my_zope]$ zope/bin/zopectl fg
python: Objects/typeobject.c:1741: extra_ivars: Assertion `t_size >= b_size' failed.
Aborted

Where ./zope is an instance.

The version of Python in Fedora 13 is 2.6.4 .
All the patches applied to the Fedora build of Python is accessible here: http://cvs.fedoraproject.org/viewvc/rpms/python/F-13/ .

I am pretty new to Zope. I would provide additional information if needed.

Bill Dagg (bill-dagg) wrote :

I'm experiencing the same issue:

- Fedora 13
- Zope 2.12.6
- Python 2.6.4

Any help would be greatly appreciated. I fear I will have to start over again with Fedora 12 and Zope 2.11 (something I'm not looking forward to).

Thanks

Robin Lee (cheeselee) wrote :

When manually importing the extensions, the same error message will show.

[cheese@cheese-laptop my_zope]$ bin/python
Python 2.6.4 (r264:75706, Apr 1 2010, 02:56:02)
[GCC 4.4.3 20100226 (Red Hat 4.4.3-8)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import AccessControl
python: Objects/typeobject.c:1741: extra_ivars: Assertion `t_size >= b_size' failed.
Aborted

>>> import DocumentTemplate
python: Objects/typeobject.c:1741: extra_ivars: Assertion `t_size >= b_size' failed.
Aborted

>>> import Acquisition
python: Objects/typeobject.c:1741: extra_ivars: Assertion `t_size >= b_size' failed.
Aborted

>>> import ExtensionClass
python: Objects/typeobject.c:1741: extra_ivars: Assertion `t_size >= b_size' failed.
Aborted

>>> import Products.ZCTextIndex
python: Objects/typeobject.c:1741: extra_ivars: Assertion `t_size >= b_size' failed.
Aborted

So the issue seems in the code of the ExtensionClass extension.

Artur Zaprzała (arturz) wrote :

I'm experiencing the same issue:
- Fedora 12
- Zope 2.12.6
- python-2.6.2-4.fc12.i686

Robin Lee (cheeselee) on 2010-06-02
summary: - Zope 2.12.6 fails to run on Fedora 13
+ Zope 2.12.6 fails to run on Fedora
Hanno Schlichting (hannosch) wrote :

Is this a problem specific to 2.12.6? Or did it already happen in 2.12.5 or earlier 2.12 releases?

Robin Lee (cheeselee) wrote :

2.12.6 is the first version of Zope I ever installed. Other subscribers may help.

Artur Zaprzała (arturz) wrote :

The same problem exists in Zope 2.12.0.

Here is how to trace the bug (assuming ZOPE is installed in /opt/Zope-2.12.6) under Fedora 12:

yum install --disablerepo '*' --enablerepo updates-debuginfo python-debuginfo
gdb /opt/Zope-2.12.6/bin/python
set args -c 'import ExtensionClass'
break Objects/typeobject.c:1728 if type.tp_base!=0 && type.tp_base.tp_basicsize>type.tp_basicsize
run
print type.tp_base.tp_basicsize
print type.tp_basicsize
bt

The problem is in _ExtensionClass.c: tp_basicsize is 0 for ExtensionClassType, BaseType, NoInstanceDictionaryBaseType and in PyExtensionClass_Export() when typ->tp_base is set, typ->tp_basicsize should be set, too.

Changed in zope2:
importance: Undecided → Medium
status: New → Confirmed
Artur Zaprzała (arturz) wrote :

Here is a patch that fixed the problem for me, but I'm not sure if it is 100% correct.

Robin Lee (cheeselee) wrote :

Artur, how to apply the patch?

Robin Lee (cheeselee) wrote :

Oh, I got it, and the patch works also for me.

Changed in zope2:
assignee: nobody → Hanno Schlichting (hannosch)
status: Confirmed → In Progress
Hanno Schlichting (hannosch) wrote :

I applied the patch to both ExtensionClass and Persistence. New releases of both these distributions are out. They will be included in the next Zope 2 release.

Thanks a lot for the patch and the confirmations!

Changed in zope2:
milestone: none → 2.12.8
status: In Progress → Fix Committed
Bill Dagg (bill-dagg) wrote :

Could someone provide directions for installing the patch please? Thanks

Changed in zope2:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers