mkzeoinstance: wrong reference to "zdaemon"

Bug #441141 reported by Dieter Maurer on 2009-10-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zope 2
Invalid
High
Zope 2 Developers
zope.mkzeoinstance
Fix Released
Undecided
Jim Fulton

Bug Description

Zope 2.12.0

Apparently, "zdaemon" used to be shipped inside the "ZODB" egg but this is no longer the case. However, "mkzeoinstance" still writes "zeo.conf" referencing "zdaemon" from within "ZODB". As a consequence "bin/zeoctl" does not work.

To reproduce the bug:
easy_install -i http://download.zope.org/Zope2/index/2.12.0 Zope2
mkzeoinstance I
I/bin/zeoctl start
Error: /home/dieter/ZopeSVN/ZClasses/zcpython/lib/python2.6/site-packages/ZODB3-3.9.0-py2.6-linux-i686.egg/zdaemon/zdrun.py is not an existing path
(line 41 in file:///home/dieter/ZopeSVN/ZClasses/I/etc/zeo.conf)
For help, use /home/dieter/ZopeSVN/ZClasses/zcpython/lib/python2.6/site-packages/ZODB3-3.9.0-py2.6-linux-i686.egg/ZEO/zeoctl.py -h

Andreas Jung (ajung) wrote :

Must fixed for 2.12.1

Changed in zope2:
importance: Undecided → High
status: New → Confirmed
tags: added: 2.12.1
Andreas Jung (ajung) wrote :

The generated zeo.conf should contain something like

zdrun /tmp/oo/lib/python2.6/site-packages/zdaemon-2.0.4-py2.6.egg/zdaemon/zdrun.py

instead of referencing the ZODB 3.9.0 egg

Andreas Jung (ajung) wrote :

I think the problem is burried in ZEO/mkzeoinst where the 'zdrun' path is hard-coded
and does not reflect the reality (zdaemon is not part of the ZODB package). I think
that mkzeoinst should detect the path of the zdaemon package and use its path
instead

65 <runner>
 66 program $INSTANCE/bin/runzeo
 67 socket-name $INSTANCE/etc/%(package)s.zdsock
 68 daemon true
 69 forever false
 70 backoff-limit 10
 71 exit-codes 0, 2
 72 directory $INSTANCE
 73 default-to-interactive true
 74 # user zope
 75 python %(python)s
 76 zdrun %(zodb3_home)s/zdaemon/zdrun.py
 77
 78 # This logfile should match the one in the %(package)s.conf file.
 79 # It is used by zdctl's logtail command, zdrun/zdctl doesn't write it.
 80 logfile $INSTANCE/log/%(package)s.log
 81 </runner>

Changed in zodb:
assignee: nobody → Jim Fulton (jim-zope)
Changed in zope2:
assignee: nobody → Zope 2 Developers (zope2-dev)
Tres Seaver (tseaver) wrote :

This bug is in the ZODB packages, and can't be fixed on the Zope side.

Changed in zodb:
status: New → Confirmed
Changed in zope2:
status: Confirmed → Invalid
Tres Seaver (tseaver) wrote :

The attached patch makes the instance generated by 'ZEO.mkzeoinst' actually work.

Note: There are no existing tests for that module, so I haven't added any.

Jim Fulton (jim-zope) on 2010-04-23
affects: zodb → zope.mkzeoinstance
Changed in zope.mkzeoinstance:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers