[2.12.0b1] RESPONSE.setCookie() throws AttributeError

Reported by Jürgen Herrmann on 2009-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zope 2
Undecided
Tres Seaver

Bug Description

traceback:
 Module Products.GlobalSearch.GlobalSearchContainer, line 356, in session2request
 Module ZPublisher.HTTPRequest, line 1367, in __getattr__
 Module ZPublisher.HTTPRequest, line 1324, in get
 Module Products.Sessions.SessionDataManager, line 106, in getSessionData
 Module Products.Sessions.BrowserIdManager, line 192, in getBrowserId
 Module Products.Sessions.BrowserIdManager, line 443, in _setCookie

BrowserIdManager assumes there is an instance attribute "cookie_http_only" which is not existant at BrowserIdManager instances created in zope instances before 2.12

Andreas Jung (ajung) on 2009-05-11
Changed in zope2:
assignee: nobody → Tres Seaver (tseaver)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Andreas Jung wrote:
> ** Changed in: zope2
> Assignee: (unassigned) => Tres Seaver (tseaver)
>

 status inprogress

- --
===================================================================
Tres Seaver +1 540-429-0999 <email address hidden>
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFKCDAT+gerLs4ltQ4RAoseAJ4oToKPxsUcGRwP/ptGoJQwXDVlVQCgmzIq
H04ne8I/jc06V++9Tk4eKPE=
=2iJW
-----END PGP SIGNATURE-----

Changed in zope2:
status: New → In Progress

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 status fixcommitted

- --
===================================================================
Tres Seaver +1 540-429-0999 <email address hidden>
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFKCGIZ+gerLs4ltQ4RAkoBAJ9DWzKIC+KOky1/J2o0HidsFE0gTgCfWGps
BIjLZ6Cez9vqgUOSC/s8eKE=
=v5Gq
-----END PGP SIGNATURE-----

Changed in zope2:
status: In Progress → Fix Committed
Changed in zope2:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers