medusa needs to be updated for Python 2.6

Bug #280020 reported by Sidnei da Silva on 2008-10-08
2
Affects Status Importance Assigned to Milestone
Python
Won't Fix
Unknown
Zope 2
Critical
Zope 2 Developers
Nominated for 1.10 by Gerry C.
Nominated for 2.0 by Gerry C.
Nominated for 2.1 by Gerry C.
Nominated for 2.10 by Gerry C.
Nominated for 2.12 by Gerry C.

Bug Description

Some of the changes in asyncore on Python 2.6 have broken the version of medusa in Zope 2.

Traceback (most recent call last):
  File "C:\src\zope-on-python-2.5\parts\instance\bin\servicewrapper.py", line 9, in <module>
    run.run()
  File "C:\src\zope-on-python-2.5\parts\zope2/lib/python\Zope2\Startup\run.py", line 22, in run
    starter.run()
  File "C:\src\zope-on-python-2.5\parts\zope2/lib/python\Zope2\Startup\__init__.py", line 142, in run
    Lifetime.loop()
  File "C:\src\zope-on-python-2.5\parts\zope2\lib\python\Lifetime\__init__.py", line 48, in loop
    lifetime_loop()
  File "C:\src\zope-on-python-2.5\parts\zope2\lib\python\Lifetime\__init__.py", line 58, in lifetime_loop
    asyncore.poll(timeout, map)
  File "c:\Python26\lib\asyncore.py", line 118, in poll
    is_w = obj.writable()
  File "C:\src\zope-on-python-2.5\parts\zope2\lib\python\ZServer\medusa\http_server.py", line 533, in writable
    return self.ac_out_buffer or len(self.producer_fifo)
  File "c:\Python26\lib\asyncore.py", line 391, in __getattr__
    return getattr(self.socket, attr)
AttributeError: '_socketobject' object has no attribute 'ac_out_buffer'

Related branches

Sidnei da Silva (sidnei) wrote :

Looks like a change similar to this one is required:

http://codereview.appspot.com/744/diff/1/23

Changed in zope2:
importance: Undecided → Critical
status: New → Confirmed
Sidnei da Silva (sidnei) wrote :

Wrong url.

Changed in python:
status: Unknown → New
Changed in python:
status: New → Won't Fix
Baiju Muthukadan (baijum) wrote :

In revision r92577 the above mentioned code is commented in trunk:

http://svn.zope.org/Zope/trunk/lib/python/ZServer/medusa/http_server.py?rev=92577&r1=24763&r2=92577

So, this bug is fixed ?

2009/2/11 Baiju Muthukadan <email address hidden>:
> In revision r92577 the above mentioned code is commented in trunk:
>
> http://svn.zope.org/Zope/trunk/lib/python/ZServer/medusa/http_server.py?rev=92577&r1=24763&r2=92577
>
> So, this bug is fixed ?

Yes, thanks for the reminder. You could as well just remove that code,
if you feel so inclined. And even close the bug.

--
Sidnei da Silva
Canonical Ltd.
 Landscape · Changing the way you manage your systems
http://landscape.canonical.com

Baiju Muthukadan (baijum) wrote :

Fixed in r96442

Changed in zope2:
status: Confirmed → Fix Committed
ChrisW (chris-simplistix) wrote :

Is this in Zope 2.12? if so, shouldn't this bug be closed?

Changed in zope2:
assignee: nobody → Zope 2 Developers (zope2-dev)
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.