Control_Panel.Products persists .home attribute in zodb and won't refresh if Data.fs moved elsewhere

Reported by Matt on 2008-03-23
2
Affects Status Importance Assigned to Milestone
Zope 2
Undecided
Unassigned

Bug Description

see thread http://groups.google.com/group/plone-developers/browse_thread/thread/7421a5f112fc69ee

initializeProduct of http://svn.zope.org/Zope/tags/2.10.5/lib/python/App/Product.py?rev=81177&view=markup
seems to be the culprit here. The home attribute is only updated if a product version is updated. If you move a Data.fs to another zope instance with a different software home, then the home attribute does not update itself. The CMFQuickinstaller uses this home attribute to determine the version of the software on the filesystem, and so breaks in this scenario.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Matt wrote:
> Public bug reported:
>
> see thread http://groups.google.com/group/plone-
> developers/browse_thread/thread/7421a5f112fc69ee
>
> initializeProduct of http://svn.zope.org/Zope/tags/2.10.5/lib/python/App/Product.py?rev=81177&view=markup
> seems to be the culprit here. The home attribute is only updated if a product version is updated. If you move a Data.fs to another zope instance with a different software home, then the home attribute does not update itself. The CMFQuickinstaller uses this home attribute to determine the version of the software on the filesystem, and so breaks in this scenario.

A better workarounc would be to delete all objects from
/Control_Panel/Products/manage_main after moving the site, and then
restart the appserver: they get recreated on startup if they don't
exist. I would argue that the real bug is storing *any* information in
the ZODB about filesystem products, BTW, which happens only to support
the use of "lever" or "ZClass" proeducts, which are stored there.

Tres.
- --
===================================================================
Tres Seaver +1 540-429-0999 <email address hidden>
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFH5kV2+gerLs4ltQ4RAg9uAKDIQNOfxo9ywhuNoAH7k+MucmurpQCfZjEx
lYLHOhwQFxmBC6WR7IsBzGg=
=FUO6
-----END PGP SIGNATURE-----

Hanno Schlichting (hannosch) wrote :

You can today disable the product section completely, by using "enable-product-installation off". The buildout recipes used in Plone 4.0+ do this by default. I think this is the proper fix for this issue.

Changed in zope2:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers