Remove dependency on zope.formlib

Bug #673718 reported by Michael Howitz on 2010-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zope.mimetype
Undecided
Unassigned

Bug Description

This package depends on zope.formlib. This dependency is surprising for a package describing itself as "A simple package for working with MIME content types." I think I should not depend on a specific form library.
zope.formlib is only needed to define a widget which is able to translate and sort its choices. This widget is only used in its own tests and registered in configure.zcml but it is not used anywhere else in the package.

The widget should be moved to zope.formlib as it might be expected to be found there but not in zope.mimetype.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers