While installing on PyPy, zope.interface should not build the C extension

Bug #804832 reported by fijal on 2011-07-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zope.interface
Fix Released
Undecided
Tres Seaver

Bug Description

It used to be the case that PyPy simply didn't manage to compile the C extension and everything was fine. However, recently it started working, but the extension is not running. It builds fine and then segfaults. Since it's for speedup reasons only, there is no reason to use it in PyPy at all - even if it did work (arguably pypy bug, unless proven otherwise) it would still be a slowdown rather than speedup

I'm attaching the patch, which should fix this bug.

Tres Seaver (tseaver) wrote :

The folks on #pypy say that C extensions under PyPy are always going to be super-slow, because the C extension
compatibility layer is never going to be optimizable.

Therefore, i think we can merge the patch as a "forever" fix for PyPy.

Tres Seaver (tseaver) wrote :

I plan to merge Arfrever's patch to the trunk for the next release.

Changed in zope.interface:
assignee: nobody → Tres Seaver (tseaver)
status: New → Confirmed
Tres Seaver (tseaver) wrote :

I committed a variation on Arfrever's patch in r122115:

  http://svn.zope.org/zope.interface/trunk/?rev=122115&view=rev

Note that several doctests fail under PyPy while passing under CPython,
which is one reason I am not pushing out a quick release.

Changed in zope.interface:
status: Confirmed → Fix Committed

dict order?

Gediminas Paulauskas (menesis) wrote :

Fix released in zope.interface 3.6.5 or 3.7.0

Changed in zope.interface:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers