Zope Content Management Framework (CMF)

GenericSetup 1.4 mistakenly unregisters local utilities that are Acquisition wrapped

Reported by Erik Rose on 2009-04-22
2
Affects Status Importance Assigned to Milestone
Zope CMF
Undecided
Tres Seaver

Bug Description

We ran into a problem with plone.app.relations (actually plone.relations) where the utility they registered through GS was getting replaced on every reinstall, thus losing all relationship data. This patch against the 1.4 branch of GS fixes it. (It's parallel to some stuff that was fixed in a different way on trunk—a way that apparently won't do us Plone users any good because our registrations don't maintain a `factory` attr, which is why I fixed it on the branch.)

Erik Rose (psucorp) wrote :
Changed in zope-cmf:
assignee: nobody → tseaver

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Launchpad Bug Tracker wrote:
> You have been subscribed to a public bug:
>
> We ran into a problem with plone.app.relations (actually
> plone.relations) where the utility they registered through GS was
> getting replaced on every reinstall, thus losing all relationship data.
> This patch against the 1.4 branch of GS fixes it. (It's parallel to some
> stuff that was fixed in a different way on trunk—a way that apparently
> won't do us Plone users any good because our registrations don't
> maintain a `factory` attr, which is why I fixed it on the branch.)
>
> ** Affects: zope-cmf
> Importance: Undecided
> Assignee: Tres Seaver (tseaver)
> Status: New

 status fixreleased

- --
===================================================================
Tres Seaver +1 540-429-0999 <email address hidden>
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJ713X+gerLs4ltQ4RAgepAJ0bNPzpyP06/LJZmnJoM+M/OdW6JQCglhAc
gpYsIX45DcF8GL6B7xau7tE=
=fl9Y
-----END PGP SIGNATURE-----

Changed in zope-cmf:
status: New → Fix Released
Erik Rose (psucorp) wrote :

Tres fixed this just as I was filing the bug. It's in http://svn.zope.org/Products.GenericSetup/branches/1.4/Products/GenericSetup/components.py?rev=99396&view=rev and released in GS 1.4.3. Thanks, Tres!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers