Can't start runzeo: FSConfig instance has no attribute 'packer'

Bug #410571 reported by gd2shoe on 2009-08-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ZODB
Undecided
Unassigned

Bug Description

I'm very new to zodb and zeo. I'm interested in using them alongside pylons (wsgi stack framework).

Because my only interaction with this installation of ZODB up to this point is the runzeo command, I should not be getting a stack trace. I believe this is a bug in ZEO, but may also have been an update to ZODB that didn't take ZEO into account.

(note, all paths below are absolute paths that have been truncated for privacy.)

=== My setup ===

Running in a python virtual environment (using virtualenv.py rather than Buildout for a pylons deployment) :
http://pylonsbook.com/en/1.0/installing-pylons.html#setting-up-a-virtual-python-environment

using ZODB3-3.9.0b5 obtained using:
env/bin/easy_install -U zodb3
gcc is version 4:4.3.3-9
system is Debian

=== My problem ===

$ env/bin/runzeo -a run/zeo.socket -f myDB.fs.zodb

2009-08-07T20:20:15 INFO ZEO.runzeo (11225) opening storage '1' using FileStorage
Traceback (most recent call last):
  File "env/bin/runzeo", line 8, in <module>
    load_entry_point('ZODB3==3.9.0b5', 'console_scripts', 'runzeo')()
  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 377, in main
    s.main()
  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 156, in main
    self.open_storages()
  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 205, in open_storages
    self.storages[opener.name] = opener.open()
  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZODB/config.py", line 158, in open
    if self.config.packer:
AttributeError: FSConfig instance has no attribute 'packer'

As near as I can tell, ZEOOptions in runzeo.py doesn't include some important members such as packer and pack_gc. I've poked around in the code a bit, but I'm out of my element. Again, unless my environment is broken somehow, I should not be getting a stack trace. (and yes, I tried removing and reinstalling zodb3, same behavior)

Tags: zeo Edit Tag help

Thanks for the report. Investigating.

On Sat, Aug 8, 2009 at 12:03 AM, gd2shoe<email address hidden> wrote:
> Public bug reported:
>
> I'm very new to zodb and zeo.  I'm interested in using them alongside
> pylons (wsgi stack framework).
>
> Because my only interaction with this installation of ZODB up to this
> point is the runzeo command, I should not be getting a stack trace.  I
> believe this is a bug in ZEO, but may also have been an update to ZODB
> that didn't take ZEO into account.
>
> (note, all paths below are absolute paths that have been truncated for
> privacy.)
>
> === My setup ===
>
> Running in a python virtual environment (using virtualenv.py rather than Buildout for a pylons deployment) :
> http://pylonsbook.com/en/1.0/installing-pylons.html#setting-up-a-virtual-python-environment
>
> using ZODB3-3.9.0b5 obtained using:
> env/bin/easy_install -U zodb3
> gcc is version 4:4.3.3-9
> system is Debian
>
> === My problem ===
>
> $ env/bin/runzeo -a run/zeo.socket -f myDB.fs.zodb
>
> 2009-08-07T20:20:15 INFO ZEO.runzeo (11225) opening storage '1' using FileStorage
> Traceback (most recent call last):
>  File "env/bin/runzeo", line 8, in <module>
>    load_entry_point('ZODB3==3.9.0b5', 'console_scripts', 'runzeo')()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 377, in main
>    s.main()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 156, in main
>    self.open_storages()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 205, in open_storages
>    self.storages[opener.name] = opener.open()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZODB/config.py", line 158, in open
>    if self.config.packer:
> AttributeError: FSConfig instance has no attribute 'packer'
>
>
> As near as I can tell, ZEOOptions in runzeo.py doesn't include some important members such as packer and pack_gc.  I've poked around in the code a bit, but I'm out of my element.  Again, unless my environment is broken somehow, I should not be getting a stack trace.  (and yes, I tried removing and reinstalling zodb3, same behavior)
>
> ** Affects: zodb
>     Importance: Undecided
>         Status: New
>
>
> ** Tags: zeo
>
> --
> Can't start runzeo: FSConfig instance has no attribute 'packer'
> https://bugs.launchpad.net/bugs/410571
> You received this bug notification because you are a member of Zodb-
> developers, which is the registrant for ZODB.
>

--
Jim Fulton

Jim Fulton (jim-zope) wrote :

On Sat, Aug 8, 2009 at 12:03 AM, gd2shoe<email address hidden> wrote:
> Public bug reported:
>
> I'm very new to zodb and zeo.  I'm interested in using them alongside
> pylons (wsgi stack framework).
>
> Because my only interaction with this installation of ZODB up to this
> point is the runzeo command, I should not be getting a stack trace.  I
> believe this is a bug in ZEO, but may also have been an update to ZODB
> that didn't take ZEO into account.
>
> (note, all paths below are absolute paths that have been truncated for
> privacy.)
>
> === My setup ===
>
> Running in a python virtual environment (using virtualenv.py rather than Buildout for a pylons deployment) :
> http://pylonsbook.com/en/1.0/installing-pylons.html#setting-up-a-virtual-python-environment
>
> using ZODB3-3.9.0b5 obtained using:
> env/bin/easy_install -U zodb3
> gcc is version 4:4.3.3-9
> system is Debian
>
> === My problem ===
>
> $ env/bin/runzeo -a run/zeo.socket -f myDB.fs.zodb
>
> 2009-08-07T20:20:15 INFO ZEO.runzeo (11225) opening storage '1' using FileStorage
> Traceback (most recent call last):
>  File "env/bin/runzeo", line 8, in <module>
>    load_entry_point('ZODB3==3.9.0b5', 'console_scripts', 'runzeo')()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 377, in main
>    s.main()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 156, in main
>    self.open_storages()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZEO/runzeo.py", line 205, in open_storages
>    self.storages[opener.name] = opener.open()
>  File "env/lib/python2.5/site-packages/ZODB3-3.9.0b5-py2.5-linux-i686.egg/ZODB/config.py", line 158, in open
>    if self.config.packer:
> AttributeError: FSConfig instance has no attribute 'packer'
>
>
> As near as I can tell, ZEOOptions in runzeo.py doesn't include some important members such as packer and pack_gc.  I've poked around in the code a bit, but I'm out of my element.  Again, unless my environment is broken somehow, I should not be getting a stack trace.  (and yes, I tried removing and reinstalling zodb3, same behavior)

Thanks. I can reproduce this.

Most people use (poorly documented :() zeo configuration files, and
the command-line interface lacks tests. :( I'll fix this bug in the
next release.
(I have a long term project to write decent docs.)

In the mean time, I suggest using a ZEO configuration file. A
configuration file corresponding to the options you used is:

  <zeo>
    address run/zeo.socket
  </zeo>

  <filestorage>
     path myDB.fs.zodb
  </filestorage>

When running runzeo, use the -C option to specify a configuration file.

Jim

--
Jim Fulton

gd2shoe (gd2shoe) wrote :

Thank you for your reply. I've been out of town for a few days, and will be
again tomorrow. Your suggestion seems to work, but I still wish I could get
away with using the command line options. (It would simplify things in my
case.) I'll have more time to double check when I get back. (I've only
tested very superficially.) I really want ZEO to work in my project.

The best of luck to you. Thanks for all the hard work.

Jim Fulton (jim-zope) on 2009-08-21
Changed in zodb:
status: New → Fix Committed
Tres Seaver (tseaver) wrote :

Fix released with ZODB 3.9.0:

 http://pypi.python.org/pypi/ZODB3/3.9.0#id14

Changed in zodb:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers