Add host address argument to mkzeoinst.py

Reported by Igor Stroh on 2005-03-30
2
Affects Status Importance Assigned to Milestone
ZODB
Medium
Jim Fulton
Zope 2
Wishlist
Unassigned
zope.mkzeoinstance
Medium
Tres Seaver

Bug Description

Hi,

it would be nice if mkzeoinst.py would accept a host address as an additional argument instead of only a port number, I patched the script a bit, see attached file for more info.

Igor Stroh (igor-rulim) wrote :
Changed in zope2:
importance: Low → Wishlist
Tres Seaver (tseaver) wrote :

We aren't going to be releasing new versions of Zope2 containing feature changes to bundled ZODB: modern releases (>= 2.12) all use an external ZODB egg.

Changed in zodb:
importance: Undecided → Wishlist
Changed in zope2:
status: New → Won't Fix
Tres Seaver (tseaver) on 2010-04-17
Changed in zodb:
assignee: nobody → Tres Seaver (tseaver)
status: New → Confirmed
Tres Seaver (tseaver) wrote :

Starting to work on this bug, I realized that mkzeoinst has been fundamentall broken since ZODB quit shipping is own copy of the 'zdaemon' package, in favor of pulling it in as a dependency.

I have fixed the breakage, along with merging the patch, here:

  http://svn.zope.org/ZODB/branches/tseaver-lp_143361/

and requested Jim to review and merge the branch.

Changed in zodb:
status: Confirmed → In Progress
assignee: Tres Seaver (tseaver) → Jim Fulton (jim-zope)
importance: Wishlist → Medium
Jim Fulton (jim-zope) wrote :

mkzeoinstance was split off into a separate project.

See http://pypi.python.org/pypi/zope.mkzeoinstance/3.9.4

Changed in zodb:
status: In Progress → Fix Released
Tres Seaver (tseaver) wrote :

Released separately from ZODB:

  http://pypi.python.org/pypi/zope.mkzeoinstance/3.9.4

Changed in zodb:
status: Fix Released → Won't Fix
Changed in zope.mkzeoinstance:
status: New → Fix Released
assignee: nobody → Tres Seaver (tseaver)
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers