minimum options for all tools

Bug #142970 reported by John Belmonte on 2004-05-04
2
Affects Status Importance Assigned to Milestone
ZODB
Wishlist
Unassigned

Bug Description

I'd like to propose that all command-line tools and scripts shipped in the ZODB distribution support at least the "--help" and "--version" options. This will allow automatic man page generation by help2man, which will be a great help to packagers who must provide man pages for everything in /usr/bin according to the policy of their distribution.

Most tools already have --help, but none currently have a --version option.

Florent Guillaume (efge) wrote :

Changes: submitter email, topic (Database => Zope), classification (bug => feature), new comment

It's a feature request.

affects: zope2 → zodb
Changed in zodb:
importance: Medium → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers