DemoStorage.close should not close the underlying storage.

Bug #118512 reported by Jim Fulton
2
Affects Status Importance Assigned to Milestone
ZODB
Fix Released
Medium
Unassigned

Bug Description

A common use case is to use DemoStorage for testing where DemoStorage is layered on top of a storage that will be reused for multiple tests.

Changed in zodb:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Revision history for this message
Stefan H. Holek (stefanholek) wrote :

Can we please make this dependent on a constructor argument?

Revision history for this message
Jim Fulton (jim-zope) wrote : Re: [Bug 118512] Re: DemoStorage.close should not close the underlying storage.

Good idea.

Jim

On Jul 7, 2007, at 2:41 PM, Stefan H. Holek wrote:

> Can we please make this dependent on a constructor argument?
>
> --
> DemoStorage.close should not close the underlying storage.
> https://bugs.launchpad.net/bugs/118512
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Jim Fulton mailto:<email address hidden> Python Powered!
CTO (540) 361-1714 http://www.python.org
Zope Corporation http://www.zope.com http://www.zope.org

Jim Fulton (jim-zope)
Changed in zodb:
milestone: none → 3.10.0b1
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers