Zim

Zim 0.54 doesn't work on Windows XP

Bug #923679 reported by Sven Brütt on 2012-01-30
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Zim
Undecided
Unassigned

Bug Description

While Zim 0.53 worked quite well on Windows XP, version 0.54 doesn't. The program doesn't start. This is the output of "zim -D":

---------------------------------------------------------------------------------------------------------------------------------------------
WARNING: Trashing of files not supported, could not import 'gio'
INFO: This is zim 0.54
DEBUG: Python version is sys.version_info(major=2, minor=7, micro=2, releaselevel='final', serial=0)
DEBUG: Platform is nt
DEBUG: Zim revision is:
  branch: zim-054-win
  revision: 469 <email address hidden>
  date: 2012-01-16 01:05:03 -0500
DEBUG: Running from a source dir: C:\Program Files\Zim
DEBUG: Set XDG_DATA_HOME to C:\Documents and Settings\Administrator\.local\share
DEBUG: Set XDG_DATA_DIRS to [<Dir: C:\usr\share>, <Dir: C:\usr\local\share>]
DEBUG: Set XDG_CONFIG_HOME to C:\Documents and Settings\Administrator\.config
DEBUG: Set XDG_CONFIG_DIRS to [<Dir: C:\etc\xdg>]
DEBUG: Set XDG_CACHE_HOME to C:\Documents and Settings\Administrator\.cache
DEBUG: Running command: gui
DEBUG: Loading C:\Documents and Settings\Administrator\Notes\notebook.zim
DEBUG: Wrote C:\Documents and Settings\Administrator\.config\zim\notebooks.list
INFO: Opening default notebook
Traceback (most recent call last):
  File "zim.py", line 66, in <module>
  File "zim\__init__.pyo", line 409, in main
  File "zim\gui\__init__.pyo", line 18, in <module>
  File "gtk\__init__.pyo", line 40, in <module>
  File "gtk\_gtk.pyo", line 12, in <module>
  File "gtk\_gtk.pyo", line 10, in __load
ImportError: DLL load failed: The specified procedure could not be found.
---------------------------------------------------------------------------------------------------------------------------------------------

I'm using Windows XP SP3 32-bit and Windows 7 32-bit. Windows 7 still works!

Thanks,
Sven

Related branches

Ted Lilley (ted-lilley) wrote :

To the developers, there is a requirement to explicitly add gio to the py2exe setup file as detailed here:

http://www.py2exe.org/index.cgi/Py2exeAndPyGTK

I don't know if that's already the case, but if not, that should be tried.

It's likely to be the same cause for the Vista and W7 x64 issues as well.

@brendan: this may be a duplicate, but has a solution suggestions - please have a look

bdouxx (bdouxx-zim) wrote :

The new compilation on 17 Feb 2012 solve the problem for me. I think you can close this ticket.

http://www.glump.net/content/zim/Zim-setup-0.54win2_2012-02-17.exe

Sven Brütt (sven-bruett) wrote :

I've tested this new build. Unfortunately, Zim crashes immediately after start. I've attached the following two logs: output of zim -D and the output of the applications crash.

Brendan Kidwell (bkidwell) wrote :

http://stackoverflow.com/a/3212695
http://www.py2exe.org/index.cgi/Tutorial#Step5

Builder (that's me) needs to manually grab version 9.0.21022.8 (exactly that version) of MSVCR90.dll and put it in the ./windows folder before running build script. I have updated the instructions and also updated the script to include this file.

Fix to be committed and released shortly.

Brendan Kidwell (bkidwell) wrote :

Fix is present in Zim 0.56 for Windows build here: http://www.glump.net/software/zim

Changed in zim:
status: New → Fix Released
Sven Brütt (sven-bruett) wrote :

I can confirm that version 0.56 fixes the problem. Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments