Unable to add the first notebook

Reported by Jiří Janoušek on 2011-04-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Zim
Critical
Unassigned

Bug Description

Zim (trunk, rev 387) terminates after filling Add New Notebook dialog at first run of Zim.

Steps to reproduce:
1) Remove ~/.config/zim/notebooks.list
2) Run Zim, Add New Notebook dialog popups
3) Fill & confirm the dialog, Zim terminates

Debug Output:
$ ./zim.py -D --no-daemon
INFO: This is zim 0.51
DEBUG: Python version is (2, 6, 6, 'final', 0)
DEBUG: Platform is posix
DEBUG: No bzr version-info found
DEBUG: Running from a source dir: /home/doublej/dev/prj/zim/trunk
DEBUG: Set XDG_DATA_HOME to /home/doublej/.local/share
DEBUG: Set XDG_DATA_DIRS to [<Dir: /usr/share/gnome>, <Dir: /usr/local/share>, <Dir: /usr/share>]
DEBUG: Set XDG_CONFIG_HOME to /home/doublej/.config
DEBUG: Set XDG_CONFIG_DIRS to [<Dir: /etc/xdg/xdg-gnome>, <Dir: /etc/xdg>]
DEBUG: Set XDG_CACHE_HOME to /home/doublej/.cache
DEBUG: Running command: gui
DEBUG: First time usage - prompt for notebook folder
DEBUG: Opening dialog "Add Notebook - Zim"
DEBUG: Opening dialog "Select Folder - Zim"
DEBUG: Dialog response OK
DEBUG: Closed dialog "Select Folder"
DEBUG: Dialog response OK
DEBUG: Closed dialog "Add Notebook"
DEBUG: Loading /home/doublej/dev/wiki/notebook.zim
DEBUG: Wrote /home/doublej/dev/wiki/notebook.zim
Traceback (most recent call last):
  File "./zim.py", line 56, in <module>
    zim.main(argv)
  File "/home/doublej/dev/prj/zim/trunk/zim/__init__.py", line 298, in main
    notebook = zim.gui.notebookdialog.prompt_notebook()
  File "/home/doublej/dev/prj/zim/trunk/zim/gui/notebookdialog.py", line 47, in prompt_notebook
    list.write()
  File "/home/doublej/dev/prj/zim/trunk/zim/notebook.py", line 260, in write
    lines.extend(info.uri + '\n' for info in self)
  File "/home/doublej/dev/prj/zim/trunk/zim/notebook.py", line 260, in <genexpr>
    lines.extend(info.uri + '\n' for info in self)
AttributeError: 'str' object has no attribute 'uri'

Jiří Janoušek (fenryxo) wrote :

Looks like we will need a new release just for this bug fix :S

Changed in zim:
status: New → Confirmed
importance: Undecided → Critical

Fix committed in rev388.

Changed in zim:
status: Confirmed → Fix Committed

Released in 0.52

Changed in zim:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers