Zim

zim 0.48 windows build ignores system locale

Bug #666121 reported by ras on 2010-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zim
Medium
Unassigned

Bug Description

Installed on Windows XP, zim 0.48 2010-08-01 shows menus in English, instead of Russian,
also CamelCase linking works for English, but not for Russian.
Encoding is cp1251.
Setting environment variables LANG, LC_ALL, LANGUAGE to "ru" does not help.

Can you run zim with -D to check for any errors are warnings when the
locale is loaded?

On Mon, Oct 25, 2010 at 6:15 AM, ras <email address hidden> wrote:
> Public bug reported:
>
> Installed on Windows XP, zim 0.48 2010-08-01 shows menus in English, instead of Russian,
> also CamelCase linking works for English, but not for Russian.
> Encoding is cp1251.
> Setting environment variables LANG, LC_ALL, LANGUAGE to "ru" does not help.
>
> ** Affects: zim
>     Importance: Undecided
>         Status: New
>
> --
> zim 0.48 windows build ignores system locale
> https://bugs.launchpad.net/bugs/666121
> You received this bug notification because you are subscribed to Zim.
>

ras (ras82x) wrote :

No any error or warning related to locale, as far as I see: http://pastebin.com/LdcxQdf5

About CamelCase, it seems that it is not windows specific, as Linux version also doesn't turn to links camel-cased text written in national language.
Maybe it is a missing feature.

For the camel case there is already another report: bug #518323. Please limit each report to one topic.

Strange there is no error. Either the gettext library does not understand your locale, or it can not find the translation files - I suspect the latest one.

Can you check the files are installed correctly? Otherwise try creating a folder "locale" in the same folder as the zim executable and put the translation files in there.

ras (ras82x) wrote :

Installer put `locale' folder under $ZIM_ROOT/share/. I have moved it to the root directory, and zim uses proper locale now. Thanks.

Changed in zim:
status: New → Confirmed
importance: Undecided → Medium
Brendan Kidwell (bkidwell) wrote :

Fix released. Ras, since I don't have any Windows installs configured for a non-English locale, can you please try it from the latest installer at http://www.glump.net/software/zim ? Be sure to backup your notebooks (just in case) and uninstall the previous version of Zim before you install the new one.

Changed in zim:
status: Confirmed → Fix Released
ras (ras82x) wrote :

Works for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers