Zim

[win] cannot open another notebook

Bug #569091 reported by Gregor Rosenauer on 2010-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zim
Medium
Zim

Bug Description

When trying to open another Notebook and selecting one from the list or creating a new one, pressing OK only closes the selection dialog, but Zim does not open the notebook; it stays on the old notebook.

In the log, an error shows up:

ERROR: Failed running: ['C:\\Program Files (x86)\\Zim Desktop Wiki\\zim.exe', 'file:///D:/Dokumente/wiki/ToolEvaluierung', '--no-daemon']
Traceback (most recent call last):
  File "zim\applications.pyo", line 122, in spawn
GError: Hilfsprogramm (Invalid argument) konnte nicht ausgeführt werden

(last message should translate to "helper program (...) cannot be executed")

Using Windows-installer Zim-setup-0.46_2010-04-13.exe on Windows 7 64 bit.

summary: - cannot open another notebook
+ [win] cannot open another notebook

This looks like something that is caused by the Gtk runtime environment.

Ok, checked the gtk source code and this error is caused when the following executable can not be found "gspawn-win32-helper.exe" this executable should be included in the gtk installation directory.

We may need to force set the path so this file can be found correctly.

Changed in zim:
assignee: nobody → Brendan Kidwell (bkidwell)
status: New → Confirmed
Changed in zim:
importance: Undecided → Medium
Brendan Kidwell (bkidwell) wrote :

I've confirmed this isn't a problem with the installer. If you run Zim with all of GTK's global installation in your $PATH, this problem still occurs. :^(

I might take a look at this later, but Jaap I'm assigning it back to you.

Changed in zim:
assignee: Brendan Kidwell (bkidwell) → Zim (zim-wiki)
Brendan Kidwell (bkidwell) wrote :

I mean if you run it from source, on Windows, ignoring build_win32 and its output -- in this case it still fails to open another notebook by launching "zim.py --no-daemon" whereas if you run the .exe build it fails to run "[path ...]zim.exe --no-daemon"

Brendan Kidwell (bkidwell) wrote :

** WORKAROUND **

If running from the Windows .exe package, you should have "*.zim" registered in your desktop to be handled by zim.exe, by default. Browse to the notebook you want to open and double-click the .zim file.

Brendan Kidwell (bkidwell) wrote :

Problem seems to have been solved! Not sure exactly what solved it -- maybe I fixed a build script earlier, or maybe it's because some of the libraries I used to build today are only weeks old releases.

I verify that gspawn-win32-helper.exe ends up in my build folder, and when I install and run the final package, I am able to open two notebooks using File -> Open.

Changed in zim:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers