Zim

Moving to GitHub

Bug #1639439 reported by sojusnik on 2016-11-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Zim
Undecided
Unassigned

Bug Description

Since bzr is practically dead, GitHub seems to be more inviting to new potential contributors. It's easily to accomplish with the git-remote-bzr package. Took the following explanation from here: https://bugs.launchpad.net/variety/+bug/1588978/comments/1

I highly recommend using the git-remote-bzr package for this. With that installed, you can add bzr sources as a remote in any Git repo using something like 'git remote add launchpad bzr::lp:variety'. Then you can 'git fetch launchpad', branch off, and push to Git as another remote.

Commit history and author info is all preserved (even in a reproducible way AFAIK). I use this to import Variety sources in Debian packaging Git: https://anonscm.debian.org/cgit/collab-maint/variety.git/log/

For me bzr is still my work-horse, no active committers using git. Will consider moving onze I get patch requests using git.

REgards,

Jaap

P.S. Closing as invalid as this is not an issue with the application itself

Changed in zim:
status: New → Invalid
hi2u (l-uvuntuone-7) wrote :

The thing is, simply existing on Github will itself make it a million times more likely that people will even consider contributing. Because, it's much easier, and pretty much everyone understands Git and Github's interface in general. Not only code, but also contributing to the bug/issue tracker itself, documentation, plugins etc. Zim is the only reason I signed up for an account here on Launchpad, and most people are more lazy than me on silly stuff like this, but would be willing pour quite of lot of time into actual development for Zim.

I'm not surprised you haven't received any patches in Git, because most of us have no idea how to even do that under the current set up. And I would have assumed they would be more likely to be ignored. It might be easy, but we don't know where to even start, and the time and mental effort taken to work it out (for 99% of us) to use a different platform will probably be more than the amount of work put into patches etc.

Sure Github isn't perfect, but it's mainstream and good enough. This is very much a social/motivation relevant issue more so than technical.

I love Zim, and it would be a perfect program with a few basic feature additions. I don't know Python currently, but I'd be willing to learn in order to submit some new features to Zim that I think would make it a much more efficient program to use.

While I'm willing to learn a new programming language to contribute to Zim, I'm not really inclined to under the current bzr/launchpad setup, but it just all feels kind of dead & unfamiliar, and those aren't useful skills for me to use elsewhere. I know a lot of this mental stuff sounds really stupid, but that's how our brains work sometimes.

There are better photo and event hosting systems out there, but hardly anyone would bother using them when we can just use Facebook.

Changed in zim:
status: Invalid → Opinion
hi2u (l-uvuntuone-7) wrote :

I can't figure out how to edit my comment in this interface, so just the clarify the last thing I said about Facebook...

The biggest reason people use that for events and photos is because the userbase is already there. An imperfect system with lots of users is usually much more useful than a better system with hardly any users to collab with.

Alex Ivkin (sogetthis) wrote :

Jaap,

https://github.com/jaap-karssenberg/zim-wiki/wiki has no code in it, so I can't fork and create a pull request.

I would commit via git if I could.

Alex

sojusnik (sojusnik) on 2017-04-08
Changed in zim:
status: Opinion → Fix Released
E2rd (r-ubunt3-5) wrote :

Hello,
What does it mean, fix released? I found zim code nowhere on GitHub. (Only on a very old https://github.com/gdw2/zim repository.) Did we switch to GitHub or not?
Keen regards,
 Edvard

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers