Zim

Package build is not reproducible

Bug #1604833 reported by Raphaël Hertzog on 2016-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zim
Undecided
Unassigned

Bug Description

(Forwarding a patch from https://bugs.debian.org/829708)

zim's package build is not reproducible because:
- it will generate locale-dependent non-overridable timestamp in the generated manual pages
- it relies on filesystem ordering of files to list plugins in zim/plugins/__init.py__

The attached patch fixes all those issues, please apply it.

Thank you.

Committed in rev846

Changed in zim:
status: New → Confirmed
Changed in zim:
status: Confirmed → Fix Committed
Changed in zim:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers